MozillaZine

Firefox 70, blue bar under Address bar

User Help for Mozilla Firefox
bo elam
 
Posts: 23
Joined: October 23rd, 2018, 10:44 pm

Post Posted October 22nd, 2019, 8:05 pm

Until Firefox 70, the userChrome.css code below worked to get rid of the annoying blue bar that pops up below the address bar when you write something in the address bar. With Firefox 70, the code below don't work anymore.

@NamEspace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");
panel#urlbar-results { display: none !important }

Does anyone know the new code that makes it possible to get rid of that distraction (blue bar).

Image

Thank you

Bo

bo elam
 
Posts: 23
Joined: October 23rd, 2018, 10:44 pm

Post Posted October 26th, 2019, 3:01 am

This code works to get rid of the blue bar in Firefox 70. :D

#urlbar-results {
display: none !important;
}

Bo

toggle
 
Posts: 6
Joined: November 18th, 2003, 5:47 pm

Post Posted October 26th, 2019, 3:46 pm

I'm having the same annoyance with 70
A full width "search with" bar pops up every time I type inside the address box. This should only happen with the search box on the right.
I'm using that CSS code and it does nothing.
Any solution?

Image

kerft
 
Posts: 578
Joined: January 30th, 2019, 9:38 am

Post Posted October 26th, 2019, 9:12 pm

If you do not use the one click search function, you can click the gear on the right when you start typing, or go to options and search for one-click, and click each check mark to remove all engines from the one-clicks. They will still be selectable from the search bar icon. I expect there is a CSS solution also.

bo elam
 
Posts: 23
Joined: October 23rd, 2018, 10:44 pm

Post Posted October 27th, 2019, 3:34 pm

toggle wrote:I'm using that CSS code and it does nothing.
Any solution?

The new code works. Is only slightly different than the one that worked with versions prior to Firefox 70. Look here:

Image

When I first tested this new code, it didn't work for me. I had to play with it a little bit until I found that placing it all the way to the top (like in the picture below) was the way to make it work in my W10. So, try placing the new code at the top, like in the picture. It should work whether you are using code for other changes or only the code to get rid of the blue bar.

Image

Bo

toggle
 
Posts: 6
Joined: November 18th, 2003, 5:47 pm

Post Posted October 27th, 2019, 3:56 pm

bo elam wrote:The new code works. Is only slightly different than the one that worked with versions prior to Firefox 70. Look here:

When I first tested this new code, it didn't work for me. I had to play with it a little bit until I found that placing it all the way to the top (like in the picture below) was the way to make it work in my W10. So, try placing the new code at the top, like in the picture. It should work whether you are using code for other changes or only the code to get rid of the blue bar.

Bo


Thanks. I found that I had to do two things.

1) use the code like you described placing it at the top of the userChrome.css
2) change my about:config setting -------> browser.urlbar.oneOffSearches = false
With those changes my bar is now gone. :D

bo elam
 
Posts: 23
Joined: October 23rd, 2018, 10:44 pm

Post Posted October 27th, 2019, 4:52 pm

You are welcome, toggle. I am glad to help.

Bo

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot] and 8 guests