MozillaZine


Thunderbird removing PDF attachments when forwarding

User Help for Mozilla Thunderbird
simonas
 
Posts: 5
Joined: January 4th, 2021, 2:39 am

Post Posted January 4th, 2021, 2:44 am

Hello,
I have PC with Windows 7, Thundebird newest version, suddenly Thunderbird stopped work correctly, if i want to forward mail with attachments, for example - 2 excel files, 1 word and 2 pdf files, after i click "Forward" all of pdf files just gone, leaves just excel and word.. this is very annoying issue... and i cant find any solution.. ?? On my Linux PC with same mailbox works everything fine, on other PC too, if i log in to server from roundcube console, also works fines.. I tried older thunderbird version, i tried complete uninstall and fresh install.. nothing can fix this problem...

tanstaafl
Moderator

User avatar
 
Posts: 47421
Joined: July 30th, 2003, 5:06 pm

Post Posted January 4th, 2021, 5:58 am

I can't duplicate your problem using Thunderbird 78.6.0 and Windows 10. No problem forwarding messages with a .pdf or .png or .jpg file attachment, or a message with a .docx, .pptx and a .xlsx attachment. However I noticed that if I forward a message to my gmail account with either a .zip or .wav file attachment I don't get an error, and I never get the message. I assume that is because they're executable files.

I suggest you use view -> message source or Control-U and compare the raw message source of the message you received and what you sent. See if the received message contains the file attachment but changes the headers for that MIME section to something else (causing it to be hidden).

--------------393CD45EE0D74809EE256C7F
Content-Type: application/pdf;
name="Quick Carbon 1GCBoston Globe32215.pdf"
Content-Transfer-Encoding: base64
Content-Disposition: attachment;
filename="Quick Carbon 1GCBoston Globe32215.pdf"

JVBERi0xLjUNCiW1tbW1DQoxIDAgb2JqDQo8PC9UeXBlL0NhdGFsb2cvUGFnZXMgMiAwIFIv
TGFuZyhlbi1VUykgL1N0cnVjdFRyZWVSb290IDM1IDAgUi9NYXJrSW5mbzw8L01hcmtlZCB0
cnVlPj4+Pg0KZW5kb2JqDQoyIDAgb2JqDQo8PC9UeXBlL1BhZ2VzL0NvdW50IDIvS2lkc1sg

for example has a boundary string used to separate that MIME section, followed by the headers, followed by part of the base64 encoded file. If you are forwarding a message with a .pdf file attachment you want to see a Content-Type header set to application/pdf; and a Content-Disposition: header set to attachment.

If the attachment was mis-identified as Content-Type: application/octet-stream for example that would mean its treated as a generic bunch of binary data. Normally I'd expect the attachment to be visible in that case, but Thunderbrid not call the appropriate utility to view it if you tried to open the attachment because it doesn't know what type of file it is. It uses the Content-Type header, not the file extension, to figure out what type of file it is.

simonas
 
Posts: 5
Joined: January 4th, 2021, 2:39 am

Post Posted January 4th, 2021, 11:20 pm

I also dont have any problems with Windows 10 or Linux... This problem appears on one of PC with Windows 7, and as i told, didint helped fresh reinstall or older version..

tanstaafl
Moderator

User avatar
 
Posts: 47421
Joined: July 30th, 2003, 5:06 pm

Post Posted January 4th, 2021, 11:51 pm

Okay. Did you look at the raw message source of the message on Windows 7 (not to be confused with what you see when you open a message)?

simonas
 
Posts: 5
Joined: January 4th, 2021, 2:39 am

Post Posted January 5th, 2021, 1:22 am

------=_NextPart_000_0047_01D6E34A.5489F260
Content-Type: application/pdf;
name="doc03868020210105095456.pdf"
Content-Transfer-Encoding: base64
Content-Disposition: attachment;
filename="doc03868020210105095456.pdf"

looks everything normal...

Stefan776
 
Posts: 1
Joined: January 5th, 2021, 6:18 am

Post Posted January 5th, 2021, 6:50 am

Hello, I have a similar problem. All file extensions for received emails are renamed .. like " pd_ " for " .pdf " ... in fact the last letter of the file extension is replaced with " _ " .
And it's annoing, because I can't open any files .. unless if I rename all of them.
And when I have to forward an email wich has a file with the file extension renamed it's the same.
Can anybody help me?
Thank you!

tanstaafl
Moderator

User avatar
 
Posts: 47421
Joined: July 30th, 2003, 5:06 pm

Post Posted January 5th, 2021, 8:05 am

simonas:

That looks fine. It should list the attachment unless something messed up the structure of the message so that it can't find that MIME section. The only other possibility I can think of is you have invalid MIME types information stored in your profile.

Thunderbird used to use the mimetypes.rdf file to specify what action should be used for each type of MIME section (different type of attachment). I think that has been replaced by the handlers.json file. Try exiting Thunderbird, moving that file to somewhere safe outside of the profile, and restarting Thunderbird. It should create a new version of that file with default settings. Hopefully that will let you see the .pdf attachment again, though you will have to respecify what utility should be used to open many attachments.

tanstaafl
Moderator

User avatar
 
Posts: 47421
Joined: July 30th, 2003, 5:06 pm

Post Posted January 5th, 2021, 8:10 am

Stefan776:

Look in your handlers.json file and see if it mentions pd_ . Mine contains just:

{"defaultHandlersVersion":{},"mimeTypes":{"image/jpeg":{"action":4,"extensions":["jpg"]},"application/pdf":{"action":4,"extensions":["pdf"]},"text/plain":{"action":4,"extensions":["txt"]},"text/html":{"action":4,"extensions":["html","htm","shtml","ehtml"]}},"schemes":{"http":{"action":4},"https":{"action":4}}}

Notice it specifies a pdf file extension should be used for a "application/pdf" MIME type, not pd_ . That is also consistent with Thunderbird using my windows system default handler for PDF files (Nitro Reader 5).

You might need to delete your handlers.json file and let it replace it with one with default values.

sfhowes
 
Posts: 586
Joined: April 1st, 2012, 10:21 am

Post Posted January 5th, 2021, 11:23 am

Stefan776 wrote:Hello, I have a similar problem. All file extensions for received emails are renamed .. like " pd_ " for " .pdf " ... in fact the last letter of the file extension is replaced with " _ " .
And it's annoing, because I can't open any files .. unless if I rename all of them.
And when I have to forward an email wich has a file with the file extension renamed it's the same.
Can anybody help me?
Thank you!

This is usually caused by Kaspersky attachment filtering.

https://support.kaspersky.com/KS4MO365/ ... 177819.htm

simonas
 
Posts: 5
Joined: January 4th, 2021, 2:39 am

Post Posted January 7th, 2021, 3:55 am

As i told, i done FRESH installation of older and newest version of thunderbird... That didint helped, why should help this method ? I see all attachments fine, and works fine, the problem is only when i want to forward email with pdf... there are just vanishing somehow..

tanstaafl wrote:simonas:

That looks fine. It should list the attachment unless something messed up the structure of the message so that it can't find that MIME section. The only other possibility I can think of is you have invalid MIME types information stored in your profile.

Thunderbird used to use the mimetypes.rdf file to specify what action should be used for each type of MIME section (different type of attachment). I think that has been replaced by the handlers.json file. Try exiting Thunderbird, moving that file to somewhere safe outside of the profile, and restarting Thunderbird. It should create a new version of that file with default settings. Hopefully that will let you see the .pdf attachment again, though you will have to respecify what utility should be used to open many attachments.

DanRaisch
Moderator

User avatar
 
Posts: 124270
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted January 7th, 2021, 5:34 am

simonas wrote:As i told, i done FRESH installation of older and newest version of thunderbird... That didint helped, why should help this method ? I see all attachments fine, and works fine, the problem is only when i want to forward email with pdf... there are just vanishing somehow.


Did you review the information posted by sfhowes?

simonas
 
Posts: 5
Joined: January 4th, 2021, 2:39 am

Post Posted January 7th, 2021, 6:29 am

DanRaisch wrote:
simonas wrote:As i told, i done FRESH installation of older and newest version of thunderbird... That didint helped, why should help this method ? I see all attachments fine, and works fine, the problem is only when i want to forward email with pdf... there are just vanishing somehow.


Did you review the information posted by sfhowes?


Yes, there is no kaspersky software on that PC

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot] and 4 guests