MozillaZine

SpellBound Development version

Announce and Discuss the Latest Theme and Extension Releases.
appoloin
 
Posts: 35
Joined: November 27th, 2005, 3:13 pm

Post Posted December 14th, 2005, 4:47 pm

Norvin wrote: It still amazes me they are not included with the default release version of Mozilla Firefox.


In the product plan for Ff2/3 there's inline spell checker mentioned

XerBlade

User avatar
 
Posts: 865
Joined: October 4th, 2005, 10:45 pm
Location: Nashville, TN, US

Post Posted December 14th, 2005, 5:13 pm

Most of the time, but not all the time (doesn't seem to be any pattern to it at all [the bug seems to reappear and reappear without me even touching anything sometimes]), if in a multi-line text box, and there are flagged words in the current line, if I hit Enter to move down to the next line, the line I was on before will lose all its flags. Also, if I move back and forth between lines which are actually separated by end-lines via the arrow keys, it will about 3 out of 5 times do the same thing, only flagging words in the line I am on at the time, and the other times it will not remove the flags on the old line. So, if I hit up and down enough times in a row, I can get all kinds of crazy combinations of flagged and not flagged lines. And sometimes for no apparent reason all lines will stay flagged no matter what I do (what should be happening all the time).
Here are the only non-default prefs for SpellBound I have, ones pulled from prefs.js.
Code: Select all
user_pref("extensions.spellbound.firstRun", false);
user_pref("extensions.spellbound.myspell.lastModifiedTime", 1133885442);

Getting no errors in console.
User Agent
Extensions
AMD64/2.41GHz RAM/1.0GB ATI/256MB-GDDR3/128-bit/8xAGP Cable6.0M/384kbps

appoloin
 
Posts: 35
Joined: November 27th, 2005, 3:13 pm

Post Posted December 15th, 2005, 11:33 am

Would it be possible to change the single left click to double left click

Norvin
 
Posts: 86
Joined: February 22nd, 2004, 3:45 pm

Post Posted December 15th, 2005, 4:08 pm

Norvin wrote:With each new version of Mozilla Firefox, I create a CUSTOM version which has several extensions added to it. It still amazes me they are not included with the default release version of Mozilla Firefox. One of those extensions is Spellbound. I will upload my CUSTOM version later tonight to my website and post the link to it here. Anyway, to get Spellbound working with Mozilla Firefox 1.5 (assuming it has never been installed to your Firefox before)...

1) Download and install Spellbound 0.7.3 from Robert's website at http://spellbound.sourceforge.net/download then close and reopen Firefox.

2) Download and install the dictionary of your choice such as "spell-en-US.xpi" from http://dictionaries.mozdev.org/installation.html then close and reopen Firefox.

3) Download and install "Windows Mozilla spell check libraries from the Thunderbird 1.0+ 20050727 nightly build" also from Robert's website. Close and reopen Firefox.

It should work just fine now.

<del>http://tinyurl.com/bwk59</del>

DonGato

User avatar
 
Posts: 589
Joined: December 1st, 2005, 9:57 am

Post Posted December 16th, 2005, 6:08 am

appoloin wrote:Would it be possible to change the single left click to double left click

I have to agree. It should be configurable as I would like to use middle click instead.

dknelson
 
Posts: 4
Joined: December 14th, 2005, 5:40 pm

Post Posted December 16th, 2005, 8:07 am

Today I noticed that the old version of Spellbound was not working. I removed it and installed this one and it's working great. Thanks.

Don

RobertJ
Moderator

User avatar
 
Posts: 10846
Joined: October 15th, 2003, 7:40 pm
Location: Chicago IL/Oconomowoc WI

Post Posted December 16th, 2005, 12:16 pm

GCG wrote:Hi Robert-
This is a very nice enhancement! Works well on my Mac. One slight problem, I can't close your Extension's Pref panel w/o restarting FFX. There's no visible <DONE>, <OK> or <CLOSE> button on the Mac version's Pref Panel. Otherwise it's a very useful addition to FFX. Thanks


Found I was able to close it with "Command + W" on my mac
FF 73.0 - FF 74b3 - FF 75a - TB 68.5 - Mac OSX 10.13.6
Computers I've used: IBM 7094/UNIVAC 1108/IBM 360/DEC PDP11/DEC VAX-11 780/DEC VAXstation 8000/Sun SPARCstation 2/Mac from 1984 to 2019

RobertJ
Moderator

User avatar
 
Posts: 10846
Joined: October 15th, 2003, 7:40 pm
Location: Chicago IL/Oconomowoc WI

Post Posted December 16th, 2005, 12:28 pm

I read this whole thread to avoid double posting, sorry if this is a duplicate.

In the previous version of spellbound, I could spell check in the googlebar lite text box. I still can but it comes back with no misspelled words even when I intentionally add some.

This is absolutely a quantum leap from the last version.
FF 73.0 - FF 74b3 - FF 75a - TB 68.5 - Mac OSX 10.13.6
Computers I've used: IBM 7094/UNIVAC 1108/IBM 360/DEC PDP11/DEC VAX-11 780/DEC VAXstation 8000/Sun SPARCstation 2/Mac from 1984 to 2019

appoloin
 
Posts: 35
Joined: November 27th, 2005, 3:13 pm

Post Posted December 16th, 2005, 12:28 pm

I've just had a look at the latest mozilla checkin's, there's a lot of work being done on a inline spellchecker. It looks like Ff2 will have this feature.

RobertJ
Moderator

User avatar
 
Posts: 10846
Joined: October 15th, 2003, 7:40 pm
Location: Chicago IL/Oconomowoc WI

Post Posted December 17th, 2005, 9:52 am

Every once in a while, the dialog preference window opens like this

Image

On my mac it extends off the bottom of the screen.
FF 73.0 - FF 74b3 - FF 75a - TB 68.5 - Mac OSX 10.13.6
Computers I've used: IBM 7094/UNIVAC 1108/IBM 360/DEC PDP11/DEC VAX-11 780/DEC VAXstation 8000/Sun SPARCstation 2/Mac from 1984 to 2019

Old R.Marotta
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted December 18th, 2005, 5:38 am

Same Problem here on my Mac System using Latest Spellbound Dev Build and FF: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051217 Firefox/1.5 ID:2005121704
Options Menu Drops off the bottom of the display, and must close FF to exit....
Last edited by Old R.Marotta on December 18th, 2005, 1:39 pm, edited 1 time in total.

RobertJ
Moderator

User avatar
 
Posts: 10846
Joined: October 15th, 2003, 7:40 pm
Location: Chicago IL/Oconomowoc WI

Post Posted December 18th, 2005, 10:07 am

You can hit "Command + W" to exit and if you change tabs in the prefs panel the window returns to "normal". Still need to hit "Command + W" to exit.
FF 73.0 - FF 74b3 - FF 75a - TB 68.5 - Mac OSX 10.13.6
Computers I've used: IBM 7094/UNIVAC 1108/IBM 360/DEC PDP11/DEC VAX-11 780/DEC VAXstation 8000/Sun SPARCstation 2/Mac from 1984 to 2019

Old R.Marotta
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted December 18th, 2005, 1:38 pm

Thanks; Maybe Robert S. Will have some time over the holiday weekend to possibly come up with a fix....

Robert S.

User avatar
 
Posts: 4399
Joined: April 24th, 2004, 3:04 am
Location: Bay Area, CA

Post Posted December 18th, 2005, 8:14 pm

I have a fix but haven't had the time to package and upload the new version... perhaps this evening but it won't have the context menu options added. I should be able to get to it over the holidays.

Old R.Marotta
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted December 19th, 2005, 2:49 am

Great! - Looking forward to the next release!

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 3 guests