MozillaZine

Attachments with long file names being split into 2 fields

User Help for Mozilla Thunderbird
irvin
 
Posts: 1
Joined: January 27th, 2006, 6:17 pm

Post Posted January 27th, 2006, 6:25 pm

When our users attach files with very long file names, Thunderbird (version 1.5 (20051201)) seems to split the filename into pieces in the MIME header. The receiving side doesn't understand this and the results seem to be somewhat unpredicatble (some received convert to an ATT####.dat file, some take just the first part of the filename (the "filename*0" part)).... etc. It doesn't appear that other MUAs do this filename splitting (or understand this), is there a way to turn off this "feature"?

Example -- here is the MIME header from an attached Word document named:

Bacme English Dealer Locator Software Requirements Specification 2003-01-01 v0.1.1.doc

Content-Type: application/octet-stream;
name*0="Bacme English Dealer Locator Software Requirements Specification";
name*1=" 2003-01-01 v0.1.1.doc"
Content-Transfer-Encoding: base64
Content-Disposition: attachment;
filename*0="Bacme English Dealer Locator Software Requirements Specifica";
filename*1="tion 2003-01-01 v0.1.1.doc"

Any help would be great!

Tim

tanstaafl
Moderator

User avatar
 
Posts: 45769
Joined: July 30th, 2003, 5:06 pm

Post Posted January 28th, 2006, 3:48 am

I don't know of a way to disable that feature.

wintogreen
 
Posts: 3891
Joined: October 31st, 2003, 8:38 pm

Post Posted January 28th, 2006, 9:53 am

Go into about:config and change the value of "mail.strictly_mime.parm_folding" to 0.
http://kb.mozillazine.org/about:config

I've had to do that because even short Japanese filenames get converted into really long ASCII strings when sent by TB as attachments. FYI, here's the bug: https://bugzilla.mozilla.org/show_bug.cgi?id=309566

Guest
Guest
 

Post Posted March 24th, 2006, 10:46 am

I had a very similar issue. When sending a file, .xls with over 65 characters in the file name excluding the extension, this file name was truncated on the recieving end as ATT0001.xls. After making the change to "mail.strictly_mime.parm_folding" change, this issue was also fixed.

Thanks.

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot] and 11 guests