MozillaZine

Bookmarks file keeps duplicating...

User Help for Mozilla Firefox
Rhiannon
 
Posts: 7
Joined: March 23rd, 2005, 10:08 pm

Post Posted January 9th, 2006, 2:22 am

Running Firefox 1.5 on Mac OS X 10.4.3


Just stumbled across something else very WEIRD... I've found that Firefox has been taking forever to start up so I had a peek in the profile folder and found 118 copies of my bookmarks.html named "bookmarks-1.html thru bookmarks-118.html" all created between Dec. 6 and now... which is about when I upgraded my OS from Panther to Tiger. FF has worked wonderfully for me til now.

Have tried creating new profile... thrashed firefox's .plist... upgraded from FF1.0.7 to FF1.5 and the issue continues... how do I make it stop?

leafdude

User avatar
 
Posts: 40
Joined: January 27th, 2005, 2:35 pm

Post Posted January 9th, 2006, 9:26 am

Seems to me a path reference to your bookmarks is not being set when you exit Firefox. I don't know the fix (because I don't know Mac Tiger OS).
A few suggestions (and they are suggestions !):
1) copy your profile and your extensions and put away (just the one set of bookmarks, of course). Uninstall and reinstall
a) use the Firefox uninstall module
b) clear out the file folders of where firefox was located
c) clear OS cache which hold temporary files
d) reinstall FF
2) check the preferences of where your bookmarks are being stored. Use 'about:config' and search for 'bookmark' location
a) check to see if that is where your bookmarks are suppose to go
b) check also if this is true any settings in about:config that refer to backup copies

That's all I can think of - sorry I could not be of more help...

eleanor
 
Posts: 1167
Joined: March 5th, 2005, 6:55 pm
Location: California

Post Posted January 9th, 2006, 10:32 am

Make sure bookmarks.html file isn't set as "Read Only".

eleanor
Windows 7 Home SP2

Underwood 5

User avatar
 
Posts: 357
Joined: October 21st, 2004, 9:38 am

Post Posted January 9th, 2006, 12:21 pm

It's Spotlight indexing and reindexing the bookmarks until the cows come home.

Go into System Preferences and click on Spotlight. Then click on Privacy, then the + sign at the bottom. Navigate to the profile folder — not the Firefox application — and choose it. That will stop the bookmarks from duplicating.

I don't know whether it's necessary, but kill the bloated bookmark backups, too. I've no idea how long it would take for 118 of those to delete automatically.
Running a Mac.

Rhiannon
 
Posts: 7
Joined: March 23rd, 2005, 10:08 pm

Post Posted January 9th, 2006, 2:11 pm

Thanks guys... adding the profile folder to Spotlight's privacy list did the trick... :)

old FatJohn
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted January 28th, 2006, 5:28 am

Nice solution Underwood 5, I've seen this question many a times but didn't know why this happens. Thanks for sharing!

krmathis

User avatar
 
Posts: 4699
Joined: May 24th, 2004, 9:40 pm
Location: Oslo, Norway

Post Posted January 28th, 2006, 6:11 am

... and its a known bug!
294584 - Spotlight/Norton Antivirus contention with bookmarks.html causing multiple backups (boomarks-n.html created)

Dr. X
 
Posts: 22
Joined: April 17th, 2005, 10:18 am
Location: Iowa, USA

Post Posted January 28th, 2006, 7:51 am

I'm also having this same problem. Firefox does take sometime to start up.

I've even created an Automator script in order to delete Firefox bookmarks after I'm done using Firefox. Here is the link to my topic about this same issue: http://forums.mozillazine.org/viewtopic.php?p=2049258

Dr. X
 
Posts: 22
Joined: April 17th, 2005, 10:18 am
Location: Iowa, USA

Post Posted January 28th, 2006, 3:37 pm

I think I found a solution for Norton AntiVirus as well as Spotlight.

Those of you who use "Symantec Norton AntiVirus" version 10x For Macintosh (I'm not sure about the PC) go to your dock and click System Preferences.

Next, where it says "other" at the very bottom of the window, you will see two preferences for Symantec Norton AntiVirus. Click the one that says "Norton Auto-Protect" and click the SafeZones tab.

You will see "Scan Files:" with the following two options:
  • Everywhere (Universal SafeZone)
  • Everywhere EXCEPT in:


By default the first option is selected.

Before I go any further you need to click the Lock at the bottom of the window and enter your Administrator username and password to gain access to these settings.

Back on track, select the second option, "Everywhere EXCEPT in:" and a window will drop down. Navigate to your userfolder/Library/Application Support/Firefox/Profiles and add the profiles folder to the list.

Also, if you like, add the one profile in the profiles folder as well. You will now have two lines as follows in the box under Everywhere EXCEPT in:
/Users/yourname/Library/Application Support/Firefox/Profiles
/Users/yourname/Library/Application Support/Firefox/Profiles/ (this ending might be different for you but mine is bq72ul3m.default)

Next, quit System Preferences and see if you get duplicating bookmarks. I haven't tried this yet.

I hope these instructions are clear for everyone and I hope this workaround works.

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 4 guests