MozillaZine

external apps vs. plugins

User Help for Mozilla Firefox
why???
Guest
 

Post Posted February 6th, 2006, 2:08 am

""Note: some of the file types listed there (such as all file types associated with the Windows Media Player plugin like .wma, .wmv, etc), if enabled/set to open with the plugin will, when clicked, automatically download and open with an external program instead of playing in the browser. ""
http://forums.mozillazine.org/viewtopic.php?t=206216

so, then how Does one have things open In The Browser???

it's somewaht annoying that everything opens in their associated apps...

Guest
Guest
 

Post Posted February 13th, 2006, 1:01 am

yoohoo...???

Guest
Guest
 

Post Posted February 24th, 2006, 12:43 am

um... hello?

kentuckykid
Guest
 

Post Posted February 24th, 2006, 12:50 am

I'm setting up firefox and I can't get the Tab's to open in 'New Tabs' each time... can someone help me

kentuckykid
Guest
 

Post Posted February 24th, 2006, 12:50 am

I'm setting up firefox and I can't get the Tab's to open in 'New Tabs' each time... can someone help me

Old BushVenom
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted February 24th, 2006, 1:08 am

Install Tab Mix Plus and essentially everything will open in a new tab (once you configure the options):

https://addons.mozilla.org/extensions/m ... hp?id=1122

Guest
Guest
 

Post Posted February 26th, 2006, 12:01 am

um.... excuse me, but What does any of that have to do with my OP???

Roger77
 
Posts: 2146
Joined: December 19th, 2004, 3:40 am
Location: Austin, Texas

Post Posted February 26th, 2006, 12:46 am


Vectorspace
Moderator

User avatar
 
Posts: 14455
Joined: November 27th, 2003, 4:50 am
Location: Warwickshire, UK

Post Posted February 26th, 2006, 1:11 am

Let me clarify what I meant when I said what you quoted: When you click a link to a file you have a pugin for, Firefox will try to open it in a browser window with the plugin. The WMP plugin, though, does not allow itself to be loaded directly like that - it will load invisibly in a blank browser window, and instead of playing the file it will simply load the whole file and then automaticaly open it with the default external player for that file type.

It's a function of the WMP plugin, not Firefox - you cannot make the file types associated with it open in the browser instead of externally.
"All things being equal, the simplest answer is usually the correct one" - Occam's Razor
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20110624 Thunderbird/5.0

Guest
Guest
 

Post Posted February 27th, 2006, 12:22 am

ok, fine... but all such is set for the quicktime plugin...
and i'm not even speaking of windows media...
wavs, mp3s... open up winamp...
pdf's open the reader, even though set to use the plugin...
know what i mean?

Vectorspace
Moderator

User avatar
 
Posts: 14455
Joined: November 27th, 2003, 4:50 am
Location: Warwickshire, UK

Post Posted February 27th, 2006, 12:50 am

You quoted what I said about the Windows Media Plugin - I assumed that was what you were asking about.
Maybe the settings have become messed up...

To manually reset those settings;
Type about:config into the address bar.
Find the preference browser.download.pluginOverrideTypes, and if it is present right-click on it and select reset.
Find the preference plugin.disable_full_page_plugin_for_types, and if it is present right-click on it and select reset.

Close Firefox, then go into your profile folder: http://kb.mozillazine.org/Profile_Folder
And delete the file 'mimeTypes.rdf'
"All things being equal, the simplest answer is usually the correct one" - Occam's Razor
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20110624 Thunderbird/5.0

Guest
Guest
 

Post Posted February 27th, 2006, 1:08 am

so... if neither Are present?

Vectorspace
Moderator

User avatar
 
Posts: 14455
Joined: November 27th, 2003, 4:50 am
Location: Warwickshire, UK

Post Posted February 27th, 2006, 2:41 am

Then just delete mimeTypes.rdf from your profile.
"All things being equal, the simplest answer is usually the correct one" - Occam's Razor
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20110624 Thunderbird/5.0

Guest
Guest
 

Post Posted February 28th, 2006, 2:36 am

okay... so i've done that and still not using the plugins.

???

Vectorspace
Moderator

User avatar
 
Posts: 14455
Joined: November 27th, 2003, 4:50 am
Location: Warwickshire, UK

Post Posted February 28th, 2006, 3:02 am

Type about:plugins into the address bar, copy the entire contents and post them here
"All things being equal, the simplest answer is usually the correct one" - Occam's Razor
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20110624 Thunderbird/5.0

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 11 guests