MozillaZine

[Ext] Yahoo Mail Notifier 1.0.7.3 - discussion

Announce and Discuss the Latest Theme and Extension Releases.
tempjag
 
Posts: 78
Joined: April 7th, 2006, 2:32 am

Post Posted June 1st, 2006, 9:14 pm

Hey it's not logging in properly. Any ideas? I can login through the extension (because I see the 0 beside the icon) but when you click on the icon, it will transfer you to Yahoo Mail's login page. Any ideas?

menet

User avatar
 
Posts: 158
Joined: February 24th, 2006, 12:38 am
Location: France

Post Posted June 4th, 2006, 11:10 pm

Hi Morac,

Have you no idea of my problem of YMN refresh not working if i am already on Yahoo Mail ? :?:

- Receiving an email, the count is to 1 in YMN and stays to 1 until i go to YM using YMN. Doing refresh on YMN or in YM have no effect in the new message count of YMN. :?
- With YahooToolBar-1.2.0.20060518_us, after few minutes YTB, shows 1 new message, doing refresh in YM and then in YTB, suppress the icon of new message in YTB. =D>

regards :wink:

Noyce

User avatar
 
Posts: 115
Joined: December 25th, 2003, 7:12 pm

Post Posted June 26th, 2006, 1:01 pm

Hi,

Just installed YMN 0.9.9.2 on Firefox 1.5.0.4. Every time the browser is started, the "Yahoo! Mail Login" pop-up shows...

Image

...with the "Login" button always greyed out, regardless of what I enter in the fields.

Clicking the statusbar icon Image successfully pulls up the Yahoo Mail url, but the icon does not turn orange or show the new mail pop-up (as I've configured it to do in the YMN preferences) even when there actually are new, unread emails in Yahoo.

Can anyone help with this?
Thanks. :)

Noyce

User avatar
 
Posts: 115
Joined: December 25th, 2003, 7:12 pm

Post Posted June 30th, 2006, 2:30 pm

Noyce wrote:Hi,

Just installed YMN 0.9.9.2 on Firefox 1.5.0.4. Every time the browser is started, the "Yahoo! Mail Login" pop-up shows...

Image

...with the "Login" button always greyed out, regardless of what I enter in the fields.

Clicking the statusbar icon Image successfully pulls up the Yahoo Mail url, but the icon does not turn orange or show the new mail pop-up (as I've configured it to do in the YMN preferences) even when there actually are new, unread emails in Yahoo.

Can anyone help with this?
Thanks. :)


This same issue continues...

If anyone has any suggestions, please let me know.
Thanks. :)

Noyce

User avatar
 
Posts: 115
Joined: December 25th, 2003, 7:12 pm

Post Posted July 3rd, 2006, 12:42 am

<Bump>

:| Anyone? :P

I actually have this same Firefox version (1.5.0.4) and same YMN version (0.9.9.2) installed on a laptop, (both installed several weeks ago, as opposed to this desktop installation which is a week old) and for some reason the extension works fine on the laptop. :-k So I'm assuming that there's something fishy going on with this recent installation on the desktop.

[-o< If anyone can advise me on how to troubleshoot, I'd appreciate it - I love this extension and am missing it every day it's out of commision!

Morac

User avatar
 
Posts: 2519
Joined: February 9th, 2004, 8:20 pm

Post Posted July 5th, 2006, 2:11 pm

Sorry about not responding. The message board decided not to notify me that someone had posted here even though I have it set to.

Anyway the way it is coded, the login box should only be gray if both the username and password fields are empty. If this is not the case then something is wrong.

Make sure you type the username in first and then the password since the extension will clear out the password field if the username field changes.

If this doesn't work go to the Tools menu and select "javascript console" and try again. See if there are any errors in the window. You should probably clear out the console first to get rid of old errors.

Worse comes to worse you can try reinstalling.

If none of this helps, go to this URL "about:config" and then filter on "ym_notifier" and tell me which preferences appear in bold (meaning not the default).

Noyce

User avatar
 
Posts: 115
Joined: December 25th, 2003, 7:12 pm

Post Posted July 6th, 2006, 2:52 pm

Morac wrote:Sorry about not responding. The message board decided not to notify me that someone had posted here even though I have it set to.

Anyway the way it is coded, the login box should only be gray if both the username and password fields are empty. If this is not the case then something is wrong.


Make sure you type the username in first and then the password since the extension will clear out the password field if the username field changes.

If this doesn't work go to the Tools menu and select "javascript console" and try again. See if there are any errors in the window. You should probably clear out the console first to get rid of old errors.

Worse comes to worse you can try reinstalling.

If none of this helps, go to this URL "about:config" and then filter on "ym_notifier" and tell me which preferences appear in bold (meaning not the default).


Hi Morac,
Thanks for the reply. :)

=D> :D Upon trying to recreate the error while the javascript console was open, I entered my u & p data differently than before: I added the "@yahoo.com" to my username (I guess I had forgotten that part since setting up YMN on the laptop a while back and it wasn't immediately clear to me this time) and manually entered my password character by character, instead of dragging & dropping the full password from a separate form filling application. #-o

So, this was all due to a couple of oversights on my part and nothing having to do w/ your very handy extension. 8-[

Peace.

tempjag
 
Posts: 78
Joined: April 7th, 2006, 2:32 am

Post Posted July 7th, 2006, 12:36 am

Still not working for me :(

Here's what I get in the Javascript Console :
ConQuery >> FillMainMenu sub:
TypeError: bContextMenu.childNodes[i].getAttribute is not a function

Morac

User avatar
 
Posts: 2519
Joined: February 9th, 2004, 8:20 pm

Post Posted July 10th, 2006, 6:15 am

tempjag wrote:Still not working for me :(

Here's what I get in the Javascript Console :
ConQuery >> FillMainMenu sub:
TypeError: bContextMenu.childNodes[i].getAttribute is not a function

That doesn't look like any of my code. I'm not sure where that's coming from.
First of what browser and version are you using since the code does things differently for certain browsers.
Secondly have you tried creating a brand new profile and installing the extension in that new profile and see if it works? This is especially important to try if you aren't using Firefox 1.5.0.x since older versions were notorious for having extensions get screwed up.

If it still doesn't work, you can enable logging by going to the about:config URL (type that in the location bar), and filtering on ym_notifier. There will be a preference name entitled "extensions.ym_notifier.logenable" which should be set to false. Double click that (or right click and choose toggle) to change it to true which will enable logging. Change it back to false to disable logging.

While logging is enabled, the extension will output extra debugging information to the javascript console. Just copy and paste it here when you see the problem.

tempjag
 
Posts: 78
Joined: April 7th, 2006, 2:32 am

Post Posted July 11th, 2006, 1:26 am

Thanks for replying Morac.

I'm using Fx 1504, I think that's the latest right?

I toggled that and changed it to True, and here's what I saw in the Java Console.

ym_notifier: manualCheckMail
loginState : 5


ym_notifier: Checking mail for *@yahoo.com at http://update.companion.yahoo.com/slv/v4/not

ym_notifier: request status (200)


ym_notifier: no mail


ym_notifier: Observer callback - aSubject : null, aTopic : ym-gui-change, aData : 0 *@yahoo.com (16:23)


ym_notifier: loginState : 5, checkerror : false, loggedin : true, justloggedin : false, mailChange : true, newMail : false, aData[0] : 0, aData[1] : *@yahoo.com, aData[2] : (16:23)

ym_notifier: Observer callback - aSubject : [xpconnect wrapped nsISupports], aTopic : timer-callback, aData : null


ym_notifier: Checking mail for *@yahoo.com at http://update.companion.yahoo.com/slv/v4/not


ym_notifier: request status (200)


ym_notifier: no mail


ym_notifier: Observer callback - aSubject : null, aTopic : ym-gui-change, aData : 0 *@yahoo.com (16:24)


ym_notifier: loginState : 5, checkerror : false, loggedin : true, justloggedin : false, mailChange : true, newMail : false, aData[0] : 0, aData[1] : *@yahoo.com, aData[2] : (16:24)


I also made sure that I have a new mail in my Inbox, but Yahoo Notifier still displays 0.
Last edited by tempjag on July 11th, 2006, 11:43 pm, edited 1 time in total.

Morac

User avatar
 
Posts: 2519
Joined: February 9th, 2004, 8:20 pm

Post Posted July 11th, 2006, 11:06 am

The checking mail for "*@yahoo.com" is a little odd. I'm not sure where that is coming from. It also looks like you are putting your email address in the username field. This should work, but try just putting in your username.

Also you may be one of the people affected by the Yahoo bug where it just won't work no matter what you do. This can be easily tested by logging out with the extension and then logging in normally to Yahoo and going to this address:

http://update.companion.yahoo.com/slv/v4/not

Make sure you have new mail (send yourself a message before checking). The page will contain a lot of weird characters, but there should be the text "You have x new mail message" where x is a number. If there is no text on the page indicating that you have new mail, then Yahoo is not correctly reporting you have new mail. You can also test this by installing the Yahoo Toolbar which uses the same method to check for mail.

If it doesn't work you'll need to contact Yahoo and tell them the new mail notification isn't working when using the Yahoo toolbar.

tempjag
 
Posts: 78
Joined: April 7th, 2006, 2:32 am

Post Posted July 11th, 2006, 11:26 pm

*@yahoo.com

I'm the one who made that asterisk to hide the address from spammers :)

I tried logging out on the extension and clicked on that link. Got this

Y!Alertsmno2.bmp2884id=mnoY!poll4800

Morac

User avatar
 
Posts: 2519
Joined: February 9th, 2004, 8:20 pm

Post Posted July 11th, 2006, 11:33 pm

tempjag wrote:*@yahoo.com

I'm the one who made that asterisk to hide the address from spammers :)

I tried logging out on the extension and clicked on that link. Got this

Y!Alertsmno2.bmp2884id=mnoY!poll4800

That's what normally shows up if either a) you are not logged in or b) you are logged in, but have no new mail. New mail is mail that has arrived since you last clicked the "Check Mail" button on the Yahoo Mail page (or you last went to http://mail.yahoo.com).

If you are logged in and have new mail (not just unread mail) and are getting the above, then something is wrong with Yahoo.


BTW you missed 3 of your emails above when replacing them with *.

tempjag
 
Posts: 78
Joined: April 7th, 2006, 2:32 am

Post Posted July 11th, 2006, 11:43 pm

Oh ok. Then how do I solve this? Thanks for the time :)

Morac

User avatar
 
Posts: 2519
Joined: February 9th, 2004, 8:20 pm

Post Posted July 12th, 2006, 7:57 am

Unfortunately you have to take it up with Yahoo since the problem is on their end. Tell them that the Yahoo toolbar isn't notifying you of new mail (don't mention my extension since they probably won't help you).

See the FAQ on http://ymnotifier.mozdev.org for more details.

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 1 guest