MozillaZine

Turn off image re-sizer for ever and ever

User Help for Mozilla Firefox
chrisjw37
Guest
 

Post Posted November 11th, 2006, 1:27 am

FF2 has a copied feature from IE6

Very annoying and I'd like to turn it off for ever.

SYMPTOM:
Images resize to fit the browser window automatically,
one has to mouse click them to go back to original size.

THIS TRICK DOES NOT WORK, or do anything actually:

Type: about:config in the adress bar
Filter or scroll to find: browser.enable_automatic_image_resizing
Set it to false.

flanagan
 
Posts: 3073
Joined: February 13th, 2005, 3:27 am

Post Posted November 11th, 2006, 2:21 am

It works here. Have you tried safe mode yet? Maybe an extension is interfering.

Guest
Guest
 

Post Posted November 21st, 2006, 2:40 pm

What would be the point of 'Safe Mode'?

I need the thing to run as normal, without the copycat IE6 graphic re-sizer.

Old Bozz
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted November 21st, 2006, 2:50 pm

Anonymous wrote:What would be the point of 'Safe Mode'?

I need the thing to run as normal, without the copycat IE6 graphic re-sizer.

The point is to find out if you might have an add-on that would interfere with the about:config change to false.

To stop the magnifier from appearing, put this in userContent.css. This plus the about:config change works fine for me.
Code: Select all
/* Turn off the magnifier for resize images */
body > img:only-child {
width: auto !important;
height: auto !important;
cursor: auto !important;
}

chrisjw37
Guest
 

Post Posted November 28th, 2006, 9:46 am

Righto

That seems like a better answer and much appreciated, I'll give it a go and destroy said magnifier.

chrisjw37
Guest
 

Post Posted November 28th, 2006, 10:17 am

Your solution works!
Ace and nothing to do with plug-ins - its all that damn magnifiers fault, even scrolling will force a drop in image size. I literally felt quite nauseous some days from the flashing images.
Heres how to get rid of the bloody thing. (Yep, I'm a true Brit)

Use Windows Explorer (Win Key + E)
Navigate to:

C:\Program Files\Mozilla Firefox\defaults\profile\chrome

(example - but yours is probably the same route)

Copy the file: userContent-example.css

Trick: rt click and drag the mouse to an empty bit in the folder and it will copy it in Win XP

Highlight the file and press function Key F2
Now you can rename it, remove the crap from the name and it should read:

userContent.css

Open the file, dble-click and edit it. If you have front page - it will open in that otherwise use Notepad because it must be a plain text file, no fancy formatting, nuthin mate. OK? Righto chaps......

Delete the bottom half example texts, we don't need them.

Copy and paste Mr Bozz's excellent script, this bit:

/* Turn off the magnifier for resize images */
body > img:only-child {
width: auto !important;
height: auto !important;
cursor: auto !important;
}

Save the file. Quit Firefox and re-open it.

Voila !!! No more bloody magnifier, if you want to test it out, open an image from NASA or Nat Geographic, like this.
http://www.nasa.gov/images/content/1633 ... s_full.jpg
No more re-sizing images, just like Firefox 1.5 and just like IE6 if you disable the damn thing-first thing I do everywhere.

Lets hope the Firefox design team make this a switch or would someone like to make it an add-on?
Essential tool, stops nausea - Trust me on this, I'm a Medical Scientist.

Chris

Kab
 
Posts: 1095
Joined: April 17th, 2006, 11:52 pm

Post Posted November 28th, 2006, 11:05 am

Use Windows Explorer (Win Key + E)
Navigate to:

C:\Program Files\Mozilla Firefox\defaults\profile\chrome

(example - but yours is probably the same route)

Thats the incorrect position. userContent.css can let you customize FF options and is created in your "profile" folder, which is here: http://kb.mozillazine.org/Profile

flanagan
 
Posts: 3073
Joined: February 13th, 2005, 3:27 am

Post Posted November 28th, 2006, 11:39 am

And I have verified under both Windows XP Pro SP2 and Ubuntu (Dapper, and Edgy Eft) that the image resizing works properly. There are no flashing images; no nausea. The only way to get images to "flash" is if you continually click on them to expand and contract. The about:config value merely determines whether the image is show full-size (false) or fit to the window (true). I don't really see the problem with that, so I would be hard-pressed to even suggest to the developers what they should do.

dickvl

User avatar
 
Posts: 51381
Joined: July 18th, 2005, 3:25 am

Post Posted November 29th, 2006, 10:49 pm

See this pref on the about:config page (via the url bar)
browser.enable_automatic_image_resizing

Bereddy
Guest
 

Post Posted November 29th, 2006, 11:05 pm

For me the about:config flag does work as designed, but there is still a problem, which is why I tried the usercontent method. That worked, except for a side effect.
I use the "save image in folder" extension. Double-clicking (with the extension) saves an image, but with the new resize icon this makes the image shrink and then enlarge, which is distracting.

Also, the usercontent fix has a side effect. When viewing an image, you can no longer zoom it to 200% with the imagezoom extension.

What some people would argue for is another about:config option along with "browser.enable_automatic_image_resizing"
maybe ""browser.enable_manual_image_resizing."
The first one would act as it does now. True would resize, false would not. The second would determine if the resize icon would show up in either case. True shows zoom icon, false shows normal arrow.

Guest
Guest
 

Post Posted December 3rd, 2006, 10:43 am

flanagan wrote:And I have verified under both Windows XP Pro SP2 and Ubuntu (Dapper, and Edgy Eft) that the image resizing works properly. There are no flashing images; no nausea. The only way to get images to "flash" is if you continually click on them to expand and contract. The about:config value merely determines whether the image is show full-size (false) or fit to the window (true). I don't really see the problem with that, so I would be hard-pressed to even suggest to the developers what they should do.


Flanigan me 'ol mate, it's like this.

On a bloody fast 'puter, with a bloody fast cabled T1 line, the time scale is thusly reduced.

When the image loads, a single fart or indeed any other movement of the highly sensitive Microsoft Moose (TM) sends a signal to said faster than shite off a shovel 'puter using aforementioned Firefox 2 to re-size said image in a downwards fashion. This is most definitely annoying, another moose movement (not the brown type) and the image re-sizes upwards.

At the mega speed of my machine, unhindered by other operating systems, because lets face it, I ain't that sad or can be that bothered - the down and upsizing of the image appears to 'flash'.
This is a figurative term, in the same way a dirty old geezer flashing his raincoat open does not actually have a flasgun device under his coat.

In fact the whole, missed, point is - how does one (in Royal English speak) turn the feature off on a 100% permanent basis. No ifs, no buts; no multiple systems, just turn the damn thing off.

After all if Billy Gates Boys did it 5 years ago; surely Firefox can do it now?

Guest
Guest
 

Post Posted December 3rd, 2006, 10:52 am

Kab wrote:
Use Windows Explorer (Win Key + E)
Navigate to:

C:\Program Files\Mozilla Firefox\defaults\profile\chrome

(example - but yours is probably the same route)

Thats the incorrect position. userContent.css can let you customize FF options and is created in your "profile" folder, which is here: http://kb.mozillazine.org/Profile



Kab

You are a bloody Genius boyo.

You were correct, there is an identical user location under the document and settings folders, should have thought of that, but interestingly - no-one else did and I did not come across that MISSING PART OF THE INSTRUCTIONS from the Firefox developers, who obviously assume we all know how they work and all their foibles for file placement.

Nice Work

Waylon
 
Posts: 58
Joined: December 4th, 2005, 9:30 am

Post Posted December 13th, 2006, 3:04 am

Bereddy wrote:For me the about:config flag does work as designed, but there is still a problem, which is why I tried the usercontent method. That worked, except for a side effect.
I use the "save image in folder" extension. Double-clicking (with the extension) saves an image, but with the new resize icon this makes the image shrink and then enlarge, which is distracting.

Also, the usercontent fix has a side effect. When viewing an image, you can no longer zoom it to 200% with the imagezoom extension.

What some people would argue for is another about:config option along with "browser.enable_automatic_image_resizing"
maybe ""browser.enable_manual_image_resizing."
The first one would act as it does now. True would resize, false would not. The second would determine if the resize icon would show up in either case. True shows zoom icon, false shows normal arrow.


I agree with this last segment wholeheartedly. This little copied-from-IE auto-fit feature is pure SHIT and I want it removed completely! If I by any chance would want my images resized (and sure as hell not by default) I'll do so with the Imagezoom extension - which is 100 times better than this, thankyouverymuch - and a quick scroll on the mousewheel.

I set the config boolean to false, so that images at least won't "auto-fit" automatically, but that doesn't get rid of the looking glass pointer and the auto-fit feature itself. But I'm not gonna do the usercontent fix for the very reason stated above - it messes up Imagezoom!

So developers, I leave you with a simple choice - either implement the excellent Imagezoom extension fully into Firefox, or remove every trace of this auto-fit crap and continue to leave users with the option of installing Imagezoom for extra functionality themselves. As it stands, this is the most annoying feature in FF 2.0. (Let the fact that I haven't really found any other annoyances be a testament to your otherwise fine abilities.)

Guest
Guest
 

Post Posted November 25th, 2008, 4:14 pm

just check this

view-->zoom-->check "zoom text only"

Dartman
Moderator

User avatar
 
Posts: 11950
Joined: February 9th, 2006, 9:43 pm

Post Posted November 25th, 2008, 4:42 pm

Guest wrote:just check this

view-->zoom-->check "zoom text only"

Why reply to a thread from two years ago? It's unlikely anyone from that time is even watching this thread.

This thread is closed.
Alcohol and Calculus don't mix. Never drink and derive.

Return to Firefox Support


Who is online

Users browsing this forum: akahige, Bing [Bot], Frejoh466 and 14 guests