MozillaZine

Thunderbird not honoring SpamAssassin headers despite config

User Help for Mozilla Thunderbird
whafro
 
Posts: 24
Joined: July 15th, 2004, 7:56 am
Location: Washington, DC

Post Posted December 30th, 2006, 12:10 pm

Hey folks,

I've set the junk mail controls to trust junk mail headers set by spamassassin, and it doesn't seem to be doing so. It doesn't filter out mail where the spamassassin header says that it is spam, and it does filter out messages spamassassin says is not spam (when the adaptive filter is on). I have tried turning the adaptive filters off, and nothing is treated as junk. I have also set spamassassin to operate in header mode as well as attachment mode, with no positive results.

I've done this both on 1.5 and on the 2.0 beta, and no dice.

Is there something I'm missing? This is becoming very frustrating...

Cheers

tanstaafl
Moderator

User avatar
 
Posts: 46840
Joined: July 30th, 2003, 5:06 pm

Post Posted December 30th, 2006, 1:50 pm

If the junk mail controls no longer recognize the headers, you could use message filters to test the headers added by SpamAssassin instead.

Use "View -> message source" and look at the headers for a spam message. While the exact headers depend upon how your email provider customize SpamAssassin besides the headers that state the spam score and what test it failed you should normally see a header that states its spam (if its spam) plus the subject should have a prefix you can test. That would be easier to test than the spam score.

whafro
 
Posts: 24
Joined: July 15th, 2004, 7:56 am
Location: Washington, DC

Post Posted December 30th, 2006, 2:47 pm

Well, I've never been able to get junk mail controls to recognize the headers. Is this a bug/feature that just doesn't work, or am I doing something wrong?

Since I administer several dozen email accounts for folks who primarily use thunderbird, it'd be easier to tell them that if they want to use SpamAssassin (I have subject prefixes turned off in case they don't), they can just check a box, as opposed to walking them through setting up filters.

If it's a bug/nonworking feature, that's fine, but I'd rather know that for sure before going the filters route.

Thanks

wsmwk
 
Posts: 2632
Joined: December 7th, 2004, 6:52 am

Post Posted January 24th, 2007, 6:12 pm

whafro. do you have filters defined? "trust spamassasin" and junk is run AFTER other filters are done.
Thunderbird trunk (generally).
http://wiki.mozilla.org/Thunderbird:Testing

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 5 guests