MozillaZine

Tag and Move not working together in a message filter

Discussion about official Mozilla Thunderbird builds
guy.coleman
 
Posts: 2
Joined: February 6th, 2007, 6:36 am

Post Posted February 6th, 2007, 6:40 am

Using version 2 beta 2 (20070205) on Windows XP.

I have several filters that perform a Tag followed by a Move. The filter matches fine, and the email gets moved but the tag doesn't appear on it.

I have other filters that perform a Tag, Mark As Read, then a Move. These are working as expected and all the filtered mail has the correct tag.

Is this a known problem?

sjoerger
 
Posts: 45
Joined: May 27th, 2003, 3:21 pm

Post Posted February 7th, 2007, 8:20 pm

I have 1 filter set to tag all messages and other filters to move the messages. The move filters are working fine but none of the messages are being tagged.

mscott

User avatar
 
Posts: 2516
Joined: April 2nd, 2003, 4:10 pm
Location: Thunderbird Research Center, CA

Post Posted February 7th, 2007, 10:29 pm

are you using IMAP? is the filter moving to another imap folder or a local folder?
Thunderbirds are Go!

guy.coleman
 
Posts: 2
Joined: February 6th, 2007, 6:36 am

Post Posted February 8th, 2007, 1:08 am

I'm using POP3.

sjoerger
 
Posts: 45
Joined: May 27th, 2003, 3:21 pm

Post Posted February 8th, 2007, 6:18 am

I am using pop3 as well and all folders are local. Version 2 beta 2 (20070116) on WinXP.

sjoerger
 
Posts: 45
Joined: May 27th, 2003, 3:21 pm

Post Posted February 9th, 2007, 10:48 am

I did some more testing with my filters. Here are my results:

1. If I set a filter to 'Match all messages' with action 'Tag message' it does not work.
2. If I set a filter to 'Match any of the following' and use 'Date is after 1/1/2007' the action of 'Tag message' works.
3. If I set a filter to match a specific from address and both apply tag and move the message, the message is always moved but the tag is randomly applied.
4. I also noticed that my filter for tagging messages only does not make it into the filter log

Return to Thunderbird Builds


Who is online

Users browsing this forum: No registered users and 0 guests