MozillaZine

New Problem with McAfee and the Popup Blocker

User Help for Mozilla Firefox
Guest
Guest
 

Post Posted March 24th, 2007, 12:19 pm

Yes, McAfee is the culprit, and this solution works.

Keep in mind, though, that this solution is not entirely ideal. An issue would arise if a legitimate addition were made to the user.js file, because the BAT file would later overwrite it. But I don't know if a legitimate addition would ever occur anyway (I've never seen USER.JS being used for any reason other than McAfee hijacking my pop-up preferences, but I don't think that means it couldn't be).

Chris

Alice

User avatar
 
Posts: 2629
Joined: April 23rd, 2003, 11:47 am

Post Posted March 24th, 2007, 3:01 pm

Like you said, the user.js file is not used that much anymore, since about:config became available a number of years ago. Some people may still want a user.js file as a way to "lock in" certain preferences as well as make them portable, for example, to a new profile.
Ref:
http://kb.mozillazine.org/User.js_file# ... er.js_file

But, for those that still want a user.js file AND the BAT file workaround for the McAfee issue, all they need to do is to made any additions to the "myuser.js" file, since the .BAT file will use its contents to replace whatever is in the user.js file.
Alice Wyman

Guest
Guest
 

Post Posted April 1st, 2007, 12:13 am

This problem has been bugging me for weeks! Here's what I tried and it seems to be working.

I located the user.js file and noticed that folder also contained a user.js.bak file. I set both files to read:
user_pref("dom.disable_open_during_load", true);
instead of the existing "false" line.

Next both files were set to read-only and hidden. After re-starting my PC, I checked the folder and found a new file was created (McAfee?) called user.js.tmp. I set this one just like above and set it read-only.

So far the pop-up blocking option on Firefox is holding and no new files are being created by McAfee even after multiple re-starts of my PC.

Hope this helps everyone, and you don't have to go to the trouble of creating a BAT file.

steviex
Moderator

User avatar
 
Posts: 28902
Joined: August 12th, 2006, 8:27 am
Location: Middle England

Post Posted April 6th, 2007, 5:18 pm

Hmmm ... just FWIW .. I'm using McAfee, but it has not tried to disable my popup blocker, maybe I'm lucky ... but I have a years subscription that came with my Broadband package , so I'll review then.
Only two things are infinite, the universe and human stupidity, and I'm not sure about the former. -Albert Einstein

Please DO NOT PM me for support... Lets keep it on the board, so we can all learn.

billbill
Guest
 

Post Posted April 16th, 2007, 8:55 am

This seems to work so far:

Go into Mcafee Security Center, select 'internet and network', 'configure', 'web browsing protection', 'advanced'

-this contains boxes, including one to block pop-up ads

I selected this, then restarted computer.
Now, when I use Firefox, the 'block popups' box in Firefox IS checked.

Maybe this was just a matter of allowing the 'controlling' program, Mcafee, to do the honors of granting 'block pop-ups' priviliges.

BillBill

Alice

User avatar
 
Posts: 2629
Joined: April 23rd, 2003, 11:47 am

Post Posted April 16th, 2007, 1:26 pm

billbill wrote:Maybe this was just a matter of allowing the 'controlling' program, Mcafee, to do the honors of granting 'block pop-ups' priviliges.

Thanks, I added your solution to http://kb.mozillazine.org/Popups_not_blocked

chrisoxford
Guest
 

Post Posted April 17th, 2007, 2:45 pm

I was about to start a new thread, but this looks like it applies.

Like it says, the blocker won't stay checked. Firefox 2.0.0.3, windows xp pro sp2, anything else pertinent?

OK, help me out here. I looked for every .js file I could find, the only one [prefs.js] was not read only (should it be?)

This is all way over my head. I'm just a regular guy trying to get the damn blocker to work. I need a patch that fixes it for me.

I previously had McAffe, but it slowed my cpu with it's every 10 minute scan of some kind or other so I dumped it and now use AVG free.

tia

Alice

User avatar
 
Posts: 2629
Joined: April 23rd, 2003, 11:47 am

Post Posted April 18th, 2007, 1:02 pm

The "user.js" file is located in the Firefox profile folder, which may be hidden on Windows systems. If you no longer have McAfee installed you can delete the user.js file. See this article for help finding it:

http://kb.mozillazine.org/Profile_folder
Alice Wyman

gshall
 
Posts: 3
Joined: April 18th, 2007, 5:08 pm

Post Posted April 18th, 2007, 5:11 pm

I did try allowing McAfee to "do the honors" and it seemed to resolve the problem. I could thereafter keep "block popups" in the Firefox options.

Guest
Guest
 

Post Posted April 18th, 2007, 8:45 pm

woo hoo! it worked (deleted user.js and user.bak.js for the heck of it), and I'm only mildly 'putre savvy.

thanks a ton, that was really bothering me.

sure glad I dumped McAfee while still in the 30 day free trial.

can't this fix be made automatic somehow? can't mozilla get McAfee to clean up their mess better when uninstalling? I feel like the guy in the movie Brazil who had to hire an illegal vigilante repair man to actually get his apartment fixed. I mean who the heck are you people anyway, and why isn't this covered in the official Firefox help?

chrisoxford
Guest
 

Post Posted April 18th, 2007, 8:47 pm

Anonymous wrote:woo hoo! it worked...


uh, that was me, sorry I forgot to sign it.

Alice

User avatar
 
Posts: 2629
Joined: April 23rd, 2003, 11:47 am

Post Posted April 19th, 2007, 5:11 am

chrisoxford,
Glad you got if fixed.

We're only users here with no connection to Mozilla.org support except that they recognize us as a support resource and link to the MozillaZine forums and kb.

What you could do if you want to help is to go to https://bugzilla.mozilla.org/ and create an account and then file a bug report about the problem of "McAfee Privacy Service" or "McAfee Internet Security" adding a user.js file that locks in a preference setting, which isn't removed when the software is uninstalled.

Before filing a bug report, though, you may want to register a MozillaZine forum account, then bring this issue up in the Firefox Bugs forum with a link back to this topic or to http://kb.mozillazine.org/Popups_not_bl ... up_blocker to see if anyone there can give some help searching for a related bug report or writing one up. Here's a search result list of open bugs mentioning McAfee. Here's another list of duplicate or open Firefox bugs with McAfee in the summary. I also did a bugzilla query on resolved Firefox bugs with McAfee in the summary and came up with this list.
Alice Wyman

karaoke99
 
Posts: 1
Joined: June 3rd, 2007, 7:12 am

Post Posted June 3rd, 2007, 7:14 am

billbill wrote:This seems to work so far:

Go into Mcafee Security Center, select 'internet and network', 'configure', 'web browsing protection', 'advanced'

-this contains boxes, including one to block pop-up ads

I selected this, then restarted computer.
Now, when I use Firefox, the 'block popups' box in Firefox IS checked.

Maybe this was just a matter of allowing the 'controlling' program, Mcafee, to do the honors of granting 'block pop-ups' priviliges.

BillBill


This worked for me just now. Thank you, Billbill...this had been annoying the crap out of me.

Sparky12
Guest
 

Post Posted July 4th, 2007, 1:40 am

billbill wrote:This seems to work so far:

Go into Mcafee Security Center, select 'internet and network', 'configure', 'web browsing protection', 'advanced'

-this contains boxes, including one to block pop-up ads

I selected this, then restarted computer.
Now, when I use Firefox, the 'block popups' box in Firefox IS checked.

Maybe this was just a matter of allowing the 'controlling' program, Mcafee, to do the honors of granting 'block pop-ups' priviliges.

BillBill


Cheers for that billbill, been bugging the crap out of me for the last week. I should never have had McAfee on this PC anyway as I unchecked the option when ordering. But Dell obviously thought I was joking and pre installed the pile of garbage anyway! Will get round to the week long process of uninstalling it at some point, but as this is a work PC I need to find the time to do it.

Guest
Guest
 

Post Posted September 6th, 2007, 5:13 am

I may have a newer version of McAfee - I have the one provided by AOL for free.
There are two 'configures' on the Internet and network window.
I tried both and don't see'web browsing protection'
On the second 'configure', there is a list of techy terms but none contain the words 'pop-up'.
Has anyone had success blocking pop-ups with the AOL version?
TYIA

karaoke99 wrote:
billbill wrote:This seems to work so far:

Go into Mcafee Security Center, select 'internet and network', 'configure', 'web browsing protection', 'advanced'

-this contains boxes, including one to block pop-up ads

I selected this, then restarted computer.
Now, when I use Firefox, the 'block popups' box in Firefox IS checked.

Maybe this was just a matter of allowing the 'controlling' program, Mcafee, to do the honors of granting 'block pop-ups' priviliges.

BillBill


This worked for me just now. Thank you, Billbill...this had been annoying the crap out of me.

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot] and 12 guests