MozillaZine

Clicking a link in Firebird 0.7 opens it in IE

User Help for Mozilla Firefox
svenXY
Guest
 

Post Posted December 4th, 2003, 9:44 am

Hi All,

I have a Win2K machine at work and have to use IE5.5 for comptibility reasons as the default browser.

Since I changed to Firebird 0.7 today, when clicking a link in Firebird, it opens in IE!

Right-clicking and Open in new tab works fine.
When setting Firebird as the default browser, it also works fine.

What I want to have is:

- IE as default browser
- When using Firebird, links should also open in Firebird.

Any ideas?

Thanks,
Sven

CarLBanks
 
Posts: 140
Joined: December 3rd, 2003, 7:11 pm
Location: On a computer

Post Posted December 4th, 2003, 9:46 am

Impossible, it looks for default browser.

mezziah

User avatar
 
Posts: 1738
Joined: November 29th, 2002, 4:25 pm
Location: Central Europe

Post Posted December 4th, 2003, 9:53 am

You have to set Firebird as your default browser.

sveXY
Guest
 

Post Posted December 5th, 2003, 1:56 am

Hi guys,

thanks for your answers.

You're kidding.

It worked fine with 0.6 and before: IE opened links in IE and Firebird opened links in Firebird.

I see no good reason why this shouldn't work in 0.7. Do you?

Regards,
Sven

scratch

User avatar
 
Posts: 4942
Joined: November 6th, 2002, 1:27 am
Location: Massachusetts

Post Posted December 5th, 2003, 2:25 am

there's a hidden pref that tells it to use the default system browser for links. i don't remember what it is, but you need to take that out. i don't know how it got set.

svenXY
Guest
 

Post Posted December 5th, 2003, 2:51 am

OK, found it:

In the registry, under
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\http\shell\open

you need to delete the key and also the one under

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\http\shell\open\ddeexec\Application

Then firebird opens links in firebird and IE opens links in IE fine.

Thanks for your help!

Sven

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot] and 10 guests