MozillaZine

Thunderbird 1.5's default theme on Thunderbird 2

Discuss application theming and theme development.
VLsoft
 
Posts: 2
Joined: May 30th, 2007, 11:01 am

Post Posted May 30th, 2007, 11:20 am

Hi there!

I have registered here because I've made a theme for Thunderbird2, which looks like the 1.5's default theme.
After roaming the net for a day to find a theme like that, but I haven't found one, only requests here and there for this type of theme, I decided to create one.
It's mostly an image copy-paste job from the old theme into the new one. I haven't red licensing or other stuff, because I made it for myself, if someone founds it illegal or something, i'll delete it.
I have extracted the new theme, added some text files from different themes (the install rdf file for example), and done some work on the images with gimp and using the old 1.5's default theme images.
The theme is not complete, because I'm not a graphician or something; but I tried to replace as much images as possible (for example the forward and back buttons are from the new theme, but I don't use them, so it does not bother me).
Here's a link where you can find it:
http://www.freeweb.hu/vlsoft/thunderbird/index.html

I don't want to try submitting it onto the extensions page, because I haven't done much testing, and I don't have the time to try and comply with the requirements stated there.

I would like to ask You, to try it and give me some feedback (good or bad, it may make the theme better - or gets the theme dumped to trash because I maybe violated licensing or something).

Young Alex!
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted May 31st, 2007, 2:20 am

VLsoft wrote
I don't want to try submitting it onto the extensions page, because I haven't done much testing, and I don't have the time to try and comply with the requirements stated there




depending on whats happening i may be willing to help you test some for and give some feed back but maybe not :halfrobot:

Young Alex!
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted June 1st, 2007, 8:42 pm

alright ill give it a go

Regards Alex :D

pschroeter
 
Posts: 144
Joined: September 3rd, 2004, 1:19 pm

Post Posted June 3rd, 2007, 3:22 pm

I tried this theme and it has a problem with my menus. They now all have black backgrounds. Many of the commands are missing, and the ones that are there are rendered in a light gray that is hard read. Any command added by an extension is missing, but several standard TB commands are missing too. I can see the commands, in light gray, when I mouse over them and the dark blue highlight color takes over. Images that get overlaid in buttons in dialog boxes are missing too. The custom icons did show up in toolbars, but just about everything else has a problem.

I thought the problem might be caused by a conflict with the CuteMenus - Crystal SVG extension I was using, but the problem didn't go away after I disabled it.

Thank you for the effort, keep on trying.

VLsoft
 
Posts: 2
Joined: May 30th, 2007, 11:01 am

Post Posted June 6th, 2007, 6:56 am

pschroeter:
I use this theme under Linux, and I have the following extensions: Enigmail (plus a hu-HU language pack for it), ExternalTemplateLoader, and a global HU language pack.
The menus are just normal, I'm using IceWM as the window manager (although I have KDE, but I don't really use it; and the Gnome libraries are installed too, so I could run all Gnome apps).
This theme was created from the Linux default theme as a base, if you're using Windows, that might be a problem. Can you post a screenshot somewhere, so I could look at it?

andreas.arb
 
Posts: 4
Joined: July 21st, 2007, 6:03 am
Location: Koblenz, Germany

Post Posted July 21st, 2007, 6:23 am

VLsoft wrote:This theme was created from the Linux default theme as a base, if you're using Windows, that might be a problem. Can you post a screenshot somewhere, so I could look at it?

here's the screenshot requested:
<a href="http://www.vonarb.de/qute-on-windows.gif"><img src="http://www.vonarb.de/qute-on-windows.gif" width="257" height="190"></a>

if you could fix the black menu this would be very fine :-)

I think the 'previous' ('Zurück') and 'next' ('Vor') buttons are mixed up, is this be possible?

edit:
Another problem is e.g. in the "Save Message" Dialog. Icons for "Ok" and "Canel" are missing:
<a href="http://www.vonarb.de/save-msg-dialog.gif"><img src="http://www.vonarb.de/save-msg-dialog.gif" width="254" height="215"></a> <a href="http://www.vonarb.de/master-password.gif"><img src="http://www.vonarb.de/master-password.gif" width="200" height="107"></a>
Last edited by andreas.arb on March 6th, 2008, 5:04 am, edited 1 time in total.

JonCarter
 
Posts: 6
Joined: April 10th, 2004, 9:07 pm

Post Posted August 21st, 2007, 9:59 am

Anyone fixed this yet? The new 2.0 theme is crap, and I'd use this one if it wasn't for the black menu backgrounds.

tremex
 
Posts: 14
Joined: November 7th, 2005, 10:02 am

Post Posted August 22nd, 2007, 12:39 am

I can't stand the 2.0 theme, I need my little icons next to the messages!
Who had the idea of changing the theme ? It was great in 1.5! I had the same problem with Firefox 2, I had to download a classic theme conversion.

It would be great if you could fix the black menu backgrounds, and also the "All folders / Unread folders / ..." button, which doesn't go with the rest of your theme.

Why don't the developers put a "classic 1.5" theme by default in their new releases ?? I thought Thunderbird was about having "My mail, my way"....

andreas.arb
 
Posts: 4
Joined: July 21st, 2007, 6:03 am
Location: Koblenz, Germany

Post Posted September 1st, 2007, 8:29 am

Hello,

Here's a fixed version of VLSoft's theme for windows:
(still glitches e.g. the 'New tags' dialog)

http://ava089.com/files/classic15.jar

Mr. G
 
Posts: 1
Joined: September 4th, 2007, 11:32 am

Post Posted September 4th, 2007, 11:34 am

Wounderfull! Thanks! :)
Firefox lover :)

salnet
 
Posts: 2
Joined: March 4th, 2008, 2:32 pm
Location: Bonn, Germany

Post Posted March 4th, 2008, 2:43 pm

andreas.arb wrote:Hello,

Here's a fixed version of VLSoft's theme for windows:
(still glitches e.g. the 'New tags' dialog)

http://ava089.com/files/classic15.jar
Hello! I like that qute-Theme. I downloaded it from here 4-5 months ago. Now I lost my folder with themes and I wanted to download it again, but that file isn't available anymore.
Is someone out there who has that theme and can upload it for me?

andreas.arb
 
Posts: 4
Joined: July 21st, 2007, 6:03 am
Location: Koblenz, Germany

Post Posted March 6th, 2008, 5:00 am

salnet wrote:
andreas.arb wrote:Hello,

Here's a fixed version of VLSoft's theme for windows:
(still glitches e.g. the 'New tags' dialog)

http://ava089.com/files/classic15.jar
Hello! I like that qute-Theme. I downloaded it from here 4-5 months ago. Now I lost my folder with themes and I wanted to download it again, but that file isn't available anymore.
Is someone out there who has that theme and can upload it for me?

Theme has moved:
www.vonarb.de/files/classic15.jar

salnet
 
Posts: 2
Joined: March 4th, 2008, 2:32 pm
Location: Bonn, Germany

Post Posted March 6th, 2008, 5:01 am

Thanks a lot Andreas.

andreas.arb
 
Posts: 4
Joined: July 21st, 2007, 6:03 am
Location: Koblenz, Germany

Post Posted March 6th, 2008, 5:05 am

:-)

Return to Theme Development


Who is online

Users browsing this forum: No registered users and 0 guests