Software Update Failed

User Help for Mozilla Thunderbird
Wies Guy

Post Posted June 15th, 2007, 2:33 pm

Logitech Webcam software was the problem. If you go to the update log file in Thunderbird under your Local Setting directory under Documents and Settings it will show you what file (ie program) is causing the update failure.


Post Posted June 15th, 2007, 3:20 pm

I stopped the Quickcam10.exe process in the task manager and the update applied.


Post Posted June 15th, 2007, 3:31 pm

Anonymous wrote:I stopped the Quickcam10.exe process in the task manager and the update applied.

Same here, now all good.

Posts: 40
Joined: February 13th, 2005, 8:39 pm

Post Posted June 15th, 2007, 4:59 pm

Well, I already had TB installed, and have been using it for over a week. Today I got the notification that I needed to update to, and ran into the same problems as everyone posting on this topic. Endless failed installation loop. So, I exited the Logitech Webcam, and tried again. It downloaded and restarted TB, and said the update was successful. But --- After I went to Help/About and it said I was using, I went to Check for Updates, and it said was available for Update!!! This is maddening! Over and over, and it won't stop!

Posts: 3
Joined: May 30th, 2007, 2:28 pm

Post Posted June 15th, 2007, 5:25 pm

I'm running TB on windows XP, and after reading this thread went to the task manager and ended all processes the quickcam uses. TB update installed with no problem after that. Thanks to those of you who figured this out.

I also wanted to mention that I never had a problem with the program not starting up because it couldn't update. I got the same error message about the update as it seems you all did, but after I clicked OK then TB came right up...just not in its updated glory.

So, I never had to uninstall or reinstall TB, and I never had to uninstall the quickcam, either.

Thanks again for figuring this out and sharing!

Posts: 2
Joined: April 19th, 2007, 2:22 pm

Post Posted June 17th, 2007, 4:11 am

Quiting QuickCam in tray fixed my problem aswell.

Thunderbird was stuck in the update to Thunderbird Update, error, update, error..

Windows XP SP2

Posts: 70
Joined: June 28th, 2004, 12:35 pm
Location: portugal

Post Posted June 17th, 2007, 10:21 am


After the first problems related to the logitech webcam, I was finally able to install the update.

But now I was having exactly the same problem as zeicoman:
Although it says that version is it also says that there is an update that he tries to install but never succeeds.

I went to tools -> options -> update
and unchecked "automatically check for updates to: Thundebird"

Then it was a bit confusing because I tried a manual installation... And I guess it was yet in the middle of an automatic update. So it failed.
After opening TB I got a failure message.
I let it update again. After restarting I tried to manually check for updates and finally it recognized that there weren't any.
I re-enabled automatic updates.

I'd say that the manual installation isn't necessary.

So, you may try:
disable automatic updates
install and restart TB until you get no more warnings about available updates
check for updates manually to make sure it worked
re-enabled automatic updates
FF 2 | TB 2 | Win XP


Post Posted June 17th, 2007, 11:06 am

2nd time the auto update screwed up my computer. Once the auto update went into continuous loop mode, I was unable to uninstall or manually delete the Mozilla Thunderbird program files because of "mozMapi32.dll." I reinstalled the complete Thunderbird download in another directory "..\Mozilla\Thunderbird" and the program works fine and save all the old email, but lost a few preference. Once the new version was installed in a different directory, I was finally able to delete the old "mozMapi32.dll" file.
Really, whoever is programming the auto updates should program it so Windows XP will allow the update. I wasted 2.5 hours with unsuccessful auto installs, reinstalls, and program file deletes before I got this thing to work. I hate having this problem every time Thunderbird wants to update.


Post Posted June 20th, 2007, 9:15 am

I am getting a "Software update failed" message whenever I open Thunderbird on the non-administrative account of our computer (running on XP Pro). I get no error on Admin.

There is no Quickcam program running in the Processes list in Task Manager.
I have tried clearing the browser cache, Windows Temp folder and deleting the entire Thunderbird folder on the C drive and reinstalling it, but I am still getting the error.
I can't find a 0? folder.
Can anyone help me?


Post Posted June 23rd, 2007, 5:07 pm

You need permisision to modify files that non-admin acounts can't do in XP. I would suggest setting windows to migrate changes over all acounts and then re-installing thunderbird using the admin account.


Post Posted June 24th, 2007, 5:55 pm

What do you mean set it to migrate changes?
Thunderbird was installed from the Admin account, and it shares the profile with the non-admin.


Post Posted July 12th, 2007, 8:58 pm

Thunderbird update kept failing. Firefox would update fine.

This thread lead me to logitech being the culprit. I opened up the QuickCam software and changed my default email software From Windows Mail to Mozilla Thunderbird. Update worked fine.

Posts: 1
Joined: July 20th, 2007, 1:06 am
Location: Germany

Post Posted July 20th, 2007, 1:08 am

Thanks for pointing out that the Logitech QuickCam was the problem.

I disconnected it, but still got the error.
But when I right-clicked the QuickCam icon in the system tray and selected "Exit", the update succeeded. (meaning: I didn't need to uninstall Quickcam or go through all the processes in the task manager).

I'm relieved. Happy mailing! :)


User avatar
Posts: 7
Joined: May 4th, 2004, 6:59 am
Location: Southern England

Post Posted July 20th, 2007, 3:14 am

I have just taken action to update Thunderbird and Firefox to their latest versions, Firefox sweet as a nut, however T/B was another matter. After several attempts to install the update and just getting a rolling dialog box trying to reinstall again and again and again. I checked the Forum and surprise surprise there were posts very similar circumstances to my own. They were back in May. Same as the guest isaque I found that by stopping the Logitech Quick Cam prog that Version loaded in seconds and proceed to work as intended. Perhaps our fantastic programmers should look to see where the link is with this problem as it apparently has occurred with the 2 latest updates


Why is that whenever I was in trouble and I turned around I was all alone? Then I found Mozilla Forums.


Post Posted July 20th, 2007, 8:07 am

I managed to fix my problem by switching my regular account into Admin, letting the program update itself, and then turning it back again.
I have had turning admin on and off mess up other programs in past though, so I'd still like to know if there was an alternative solution should this come up again.

Return to Thunderbird Support

Who is online

Users browsing this forum: Google [Bot] and 3 guests