MozillaZine

"do this automatically ...." grayed out

User Help for Mozilla Thunderbird
Guest
Guest
 

Post Posted October 31st, 2007, 5:19 am

Using Thunderbird 2.0.0.6 on Windows Vista.
I have set the default file type associations for .doc files to OpenOffice swriter.exe in Windows.
When a .doc attachment is sent to me I always want to open it in swriter -- but T'bird still calls MSOffice Word the "default" for this filetype and to open in swriter I have to laboriously navigate to it under the "open with other" dialog.
I am prevented from setting this as default action because the "do this automatically for file of this type..." is grayed out for this and other MSOffice proprietary formats. For other formats, eg .rtf, it works. Is this Microsoft interfering with my right to choose non-MS programs for file formats they consider their property -- or a fault in T'bird? Is there I can do about it?

klassic
 
Posts: 37
Joined: November 8th, 2006, 1:23 pm

Post Posted October 31st, 2007, 5:39 am

It might have something to do with MSOffice Word being the default program in Windows to open .doc files. Find a .doc file on your computer and right click on it and go to properties. What program is next to "Opens with"? If its Word then you may have to click on "Change" and change it to the OpenOffice program.

Rod Whiteley

User avatar
 
Posts: 11480
Joined: December 6th, 2004, 3:41 am
Location: UK

Post Posted October 31st, 2007, 5:47 am

Also look at the message source to verify that the attachment's content type is: application/msword
Rod

Guest
Guest
 

Post Posted October 31st, 2007, 6:04 am

klassic wrote:It might have something to do with MSOffice Word being the default program in Windows to open .doc files. Find a .doc file on your computer and right click on it and go to properties. What program is next to "Opens with"? If its Word then you may have to click on "Change" and change it to the OpenOffice program.


No, it's type "OpenDocument text" and "opens with swriter.exe"

Guest
Guest
 

Post Posted October 31st, 2007, 6:07 am

Rod Whiteley wrote:Also look at the message source to verify that the attachment's content type is: application/msword


No, it isn't. It's "application/octet-stream"

Rod Whiteley

User avatar
 
Posts: 11480
Joined: December 6th, 2004, 3:41 am
Location: UK

Post Posted October 31st, 2007, 6:46 am

The type application/octet-stream means "type unknown". It makes no sense to associate an automatic action with files of unknown type, so Thunderbird does not allow it.

Word documents arrive as type unknown when the message was sent from a computer with faulty settings, or from a buggy mail program.
Rod

Guest
Guest
 

Post Posted October 31st, 2007, 8:10 am

Rod Whiteley wrote:The type application/octet-stream means "type unknown". It makes no sense to associate an automatic action with files of unknown type, so Thunderbird does not allow it.

Word documents arrive as type unknown when the message was sent from a computer with faulty settings, or from a buggy mail program.


OK, I guess, but T'bird for sure knows it's a Word document because it insists on using MSWord as the default application with which to open it, despite the fact that I have set swriter as the default to open .doc files, and everywhere else in Windows, including explorer, this is what happens. As fas I can tell T'bird is the only program which does not honor this default setting I have made, and insists on still using Word as the default. I can live without the automatic setting if I have to, if only I could get the 'bird to offer swriter as the default choice to open it.

Rod Whiteley

User avatar
 
Posts: 11480
Joined: December 6th, 2004, 3:41 am
Location: UK

Post Posted October 31st, 2007, 8:34 am

Perhaps you have an obsolete entry for .doc files in Tools – Options – Attachments – View & Edit Actions...
Rod

Guest
Guest
 

Post Posted October 31st, 2007, 9:12 am

Rod Whiteley wrote:Perhaps you have an obsolete entry for .doc files in Tools – Options – Attachments – View & Edit Actions...


No. That list contains only one entry, for .rtf to be opened with swriter, and that works properly.
It would be SO much easier if I could create a new entry there directly for .doc files and just have the program do what I tell it.

Guest
Guest
 

Post Posted November 1st, 2007, 12:05 am

Looks like I solved it. Here's how --
I SENT an attached .doc file, and then used the "open" dialog on the SENT attachment to set the default action as "open with swriter.exe" -- and this worked.
Previously I was trying to set the default by opening a RECEIVED .doc attachment.

The difference is that the mime type for sent attachment was correctly set by T'bird as application/ms.word whereas whatever POS mailer had been used to send one to me just set it as application/octet-stream.

Hope this helps somebody....

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 3 guests