MozillaZine

GrApple theme stuff ...

Discuss application theming and theme development.
Aronnax!
 
Posts: 1006
Joined: October 1st, 2004, 10:24 am
Location: Germany

Post Posted April 21st, 2008, 4:48 pm

upkeep wrote:Hello Aronnax!
I just had to register for this forum so I could personally thank you for such a fantastic theme. I'm using Yummy (BLUE) 0.9.9.8.1 and find it so completely refined with FF3v5b compared to other options available.

One question, though. When I have the Home button in the Bookmarks Bar, it appears as a fabulous outline. When I move it to the Toolbar, it appears as a large black solid object. Do you have any plans to to refine this to appear as an outline on the Toolbar? Today it is of no real concern, as I have the Home button in the Toolbar, but I think I heard it may get moved up?


Hi,
thanks
-----
the Home button on the Toolbar will be the FF 3.0 default setting, but the possibility to have a different icon style on the Bookmarks Bar will be not removed.

And every icon in my themes will be maybe still changed or maybe not,
but an outline style for the Home button on the Toolbar is very unlikely.

Cheers

Hidea
 
Posts: 231
Joined: June 18th, 2004, 2:35 pm
Location: Toronto, Canada

Post Posted April 24th, 2008, 1:53 pm

Aronnax!,

I think the latest nightlies added a very ugly white bar at the bottom of the download window?
That, and the clear list button doesn't match feel of the rest of the theme?

Aronnax!
 
Posts: 1006
Joined: October 1st, 2004, 10:24 am
Location: Germany

Post Posted April 24th, 2008, 2:22 pm

Hidea wrote:Aronnax!,

I think the latest nightlies added a very ugly white bar at the bottom of the download window?
That, and the clear list button doesn't match feel of the rest of the theme?


it is already changed, but the next versions depend on new possibilities from https://bugzilla.mozilla.org/show_bug.cgi?id=406730
and until this is not included in the nighties will be no new theme versions released
(they looks now completely broken without Bug 406730)
and apart from the support for Bug 406730 will they have by the way many many other changes

Cheers

Hidea
 
Posts: 231
Joined: June 18th, 2004, 2:35 pm
Location: Toronto, Canada

Post Posted April 25th, 2008, 7:35 am

Cheers Aronnax!

I can't wait for Bug 406730 to be fixed in the nightlies!

remain
 
Posts: 64
Joined: March 14th, 2007, 12:05 am

Post Posted April 25th, 2008, 11:39 pm

Hello, Aronnax.

I'm a big fan of your GrApple themes. I used GrApple (Eos) for Firefox 2, and I find your new GrApple Delicious (blue) and GrApple Yummy (blue) themes for Firefox 3 absolutely brilliant.

However, I noticed that the GrApple themes have some problems when put together with the popular extension Tab Mix Plus by CPU and onemen.

Latest version of Tab Mix Plus for Firefox 3: http://tmp.garyr.net/forum/viewtopic.php?t=7031


I've let the developers of Tab Mix Plus know in their forums:

http://tmp.garyr.net/forum/viewtopic.php?t=8798

^ I've shown the problems in that thread, along with pictures.
(I won't repost the pictures here for the sake of not stretching the page.)


Perhaps you could work together with the developers of Tab Mix Plus to solve these problems.

Honestly, I really love both the GrApple themes and Tab Mix Plus, so I truly hope these issues could be resolved.

Thank you very much for your time and effort!

Aronnax!
 
Posts: 1006
Joined: October 1st, 2004, 10:24 am
Location: Germany

Post Posted April 26th, 2008, 7:09 am

Hi,
you can expect that the next theme versions will work much, much better together with Tab Mix Plus

Cheers

remain
 
Posts: 64
Joined: March 14th, 2007, 12:05 am

Post Posted April 26th, 2008, 5:00 pm

Thanks a lot, Aronnax!


BTW, here's some stuff that one of TMP's developers said. (dunno if you already fixed it)


onemen wrote:for the centered tab add this to your userChrome.css

.tabbrowser-tabs {
text-align: start !important;
}

remain wrote:Ah, thank you.

Any chance there could be a way this can be fixed by default without having to resort to userChrome.css?
(Well, it'd be nice, but at least there is a way to fix this.)

onemen wrote:the fix for centered tab

.tabbrowser-tabs {
text-align: start !important;
}

is needed only because in the theme there is

.tabbrowser-tabs {
text-align: center;
}

ask the theme developer to fix this.

i'v found the problem with close button on GrApple Yummy (blue) there is display: -moz-box !important; for the .tab-close-button

ask the developer to drop the !important



Once again, thank you very much for your efforts!

It's awesome that I will be able to use both GrApple and TMP with no compromises.

eap
 
Posts: 173
Joined: July 5th, 2004, 9:05 pm

Post Posted April 27th, 2008, 9:47 pm

I want to take a few minutes to add my thanks for this wonderful set of themes as well. I am not sure I'd even use the Betas if I didn't have access to a GrApple theme. Great stuff.

Aronnax!
 
Posts: 1006
Joined: October 1st, 2004, 10:24 am
Location: Germany

Post Posted May 2nd, 2008, 8:06 am

Hi,
the patches for BUG: Correctly style unfocused window on OS X
https://bugzilla.mozilla.org/show_bug.cgi?id=406730
are now in the hourly builds and tomorrow in the nighties

When someone want to try it.
Use these themes:
GrApple Delicious (blue)
http://www.takebacktheweb.org/themes/fi ... .9.9.3.jar
or
GrApple Yummy (blue)
http://www.takebacktheweb.org/themes/fi ... .9.9.3.jar

together with a build from here:
http://hourly-archive.localgho.st/mac.html
tomorrow then as well from here:
http://ftp.mozilla.org/pub/mozilla.org/ ... est-trunk/

it looks:

Image

and a note from a core FF developer:
"It would help a lot if you could get your users testing builds with the change, especially with activities that switch between windows and tabs. Take note of when focus breaks, and let us know if it's more or less frequently than before."
----

Please help and report every theme bug here
and a window focus bug here: https://bugzilla.mozilla.org/show_bug.cgi?id=406730

Cheers
Last edited by Aronnax! on May 9th, 2008, 7:27 pm, edited 3 times in total.

beltzner

User avatar
 
Posts: 58
Joined: July 30th, 2003, 9:16 pm
Location: Toronto, ON

Post Posted May 2nd, 2008, 9:14 am

Hi everyone - while I wouldn't call myself a "core" Firefox developer, I was the one who Aronnax spoke of in the previous post.

The fix for the window styling issue relied on a bug (https://bugzilla.mozilla.org/show_bug.cgi?id=428071) which required that we alter the way window focus is communicated to all objects in the chrome DOM. This is a bit nerve wracking, as it can have unintended side effects. As Aronnax mentions, if you could use those builds and make sure that you don't see any unexpected behaviour with your caret focus (where you can type, whether keys work):

* when switching between windows
* when switching between tabs
* when using plugins like Flash or Java
* when using add-ons

And report back, that would be great.
Mike Beltzner / Director of Firefox Development / beltzner@mozilla.com

isleofjib
 
Posts: 84
Joined: February 1st, 2006, 5:40 am

Post Posted May 2nd, 2008, 9:41 am

Looks good. so far in very limited use seems to change as it should. and best of all, the triple close buttons on each tab is fixed with yummy! thx for that aronnax!

wtmcgee
 
Posts: 395
Joined: November 28th, 2002, 6:45 am
Location: Atlanta, GA USA

Post Posted May 2nd, 2008, 10:45 am

This makes FF3 much more useable as my OS X browser at work, thank you!

Disgustipated
 
Posts: 5
Joined: February 12th, 2008, 1:44 pm

Post Posted May 2nd, 2008, 12:14 pm

Working well so far. Looks fantastic. :)

isleofjib
 
Posts: 84
Joined: February 1st, 2006, 5:40 am

Post Posted May 2nd, 2008, 1:18 pm

i'm getting really high CPU usage with either theme in place. anywhere from 20-70% of cpu. when i switched to the default theme, that dropped to 5-7% (which is still a bit high from my normal 3-5%). not sure what is going on, but if i can provide any info, let me know what you need.

Aronnax!
 
Posts: 1006
Joined: October 1st, 2004, 10:24 am
Location: Germany

Post Posted May 2nd, 2008, 2:47 pm

isleofjib wrote:i'm getting really high CPU usage with either theme in place. anywhere from 20-70% of cpu. when i switched to the default theme, that dropped to 5-7% (which is still a bit high from my normal 3-5%). not sure what is going on, but if i can provide any info, let me know what you need.


Thanks for the report
There was a theme bug which cause a CPU problem and it had nothing to do with Bug= 406730

Please downland the new 0.9.9.9.1 versions and try it again ;-)

Cheers

Return to Theme Development


Who is online

Users browsing this forum: No registered users and 0 guests