MozillaZine


Mozilla 1.6: quoting problem

User Help for Seamonkey and Mozilla Suite
Bartosz
Guest
 

Post Posted February 12th, 2004, 9:20 pm

Mozilla (1.6) quotes every line with ">" when replying but it works correctly only for newsgroups.

When the text is quoted for the first time Mozilla adds ">[space]" and next time it adds only ">" (without a space). So it produces something like this ">>[space]text". But when quoting emails (plain text) Mozilla never adds the first space so it produces something like this: ">>text" which looks ugly and is inconvenient to read.

Why doesn't it work the same way in newsgroups and emails?

Guest
Guest
 

Post Posted February 13th, 2004, 7:43 am

hen quoting emails (plain text) Mozilla never adds the first space so it produces something like this: ">>text" which looks ugly and is inconvenient to read.
Works for me. I get '>>[space]text'. Using Moz 1.6 on WinXP Pro.

It happens every time?

Guest
Guest
 

Post Posted February 13th, 2004, 7:44 am

Maybe it depends on who is sending you the e-mail? Send yourself a message and reply.

Phil Tilson
Guest
 

Post Posted February 14th, 2004, 10:13 am

Can I ask a follow-on question?

I am new to Mozilla and I am also a member of several 'chat-groups' for which I get a daily digest - which can be quite long. When I want to reply to one of these messages, I only get the first few pages 'quoted' in my reply. If I am trying to reply to something well down the message, it doesn't appear on my reply, even if I delete what is above it.

Anyone know why this should be so? And is there anything I can do about it?

Phil

guanxi
 
Posts: 399
Joined: April 6th, 2003, 11:15 am

Post Posted February 14th, 2004, 12:03 pm

Phil - Feel free to ask questions. You might want to start a new topic for a new question, so it's easier to find and so the conversation doesn't get confused.

Look at the original e-mail. Just below where it's cut off, do you see the following?

--[space]

That is, two dashes then a space?

Phil Tilson
Guest
 

Post Posted February 14th, 2004, 4:22 pm

Hi Guanxi - you're right, I probably should have done!

However, no - the text just ends. It is 'sidebarred' as you would expect for a reply, but there are no characters after the last line of text.

I don't know if it's significant, but I pasted what was transferred into Word and checked how much text - lines, words, characters etc - had been quoted. I then tried it with a different message but the figures were completely different, so it doesn't seem to be a 'quantity of data' type problem. All I know is, I only get half my message!

Phil

guanxi
 
Posts: 399
Joined: April 6th, 2003, 11:15 am

Post Posted February 15th, 2004, 9:39 am

the text just ends. It is 'sidebarred' as you would expect for a reply, but there are no characters after the last line of text.
I mean, do you see it in the ORIGINAL, not the REPLY.

Find, in the ORIGINAL, the spot where the REPLY cuts off. After that spot, in the ORIGINAL, do you see "-- "?

Phil Tilson
Guest
 

Post Posted February 15th, 2004, 11:09 am

Yes! Indeed there is. And, in the original, the text at that point becomes grey rather than black. I was going to get onto this one later!

I am now full of anticipation for the blockbusting answer that you are about to unleash on me! Or maybe I'm just going to feel a dork because I've done something silly!

Phil

guanxi
 
Posts: 399
Joined: April 6th, 2003, 11:15 am

Post Posted February 16th, 2004, 8:15 am

Well, the blockbusting answer is ... are you ready? ... it's a known bug with no fix as of yet.

Here's what's happening: "-- " technically marks the beginning of a signature or 'sig' at the end of an e-mail. For example, your sig might be,
--
Phil Tilson
ptilson@example.com
800-555-5555
Mozilla does two things with sigs:
- It makes them grey
- It cuts them from replies

You can see the potential problems with this arrangement: In your case, Mozilla thinks the rest of the digest is one long sig, and helpfully cuts it from the reply. Others have noticed: There are a few registered bugs with potential solutions, but there's no agreement yet on fixing it.

What can you do? Mozilla is free software put together by volunteers (and programmers paid by donations). Feel free to chip in -- I do, in part, by supporting users here. If you are a programmer, you could contribute a solution. Or, you could offer to (partly) fund someone else to fix it. I'd guess it would be easy to at least offer the option of telling Mozilla to treat sigs as merely more text.

A workaround, by the way: Use Forward, not Reply, and just edit the Subject. In a brief test here, it worked.

Phil Tilson
Guest
 

Post Posted February 16th, 2004, 3:34 pm

Thanks for a very comprehensive and helpful reply.

It may not directly solve my problem (though the workaround might), but if this is an example of the kind of advice and assistance available on this forum, then I'm glad I switched to Mozilla!

Phil

Return to SeaMonkey Support


Who is online

Users browsing this forum: No registered users and 0 guests