MozillaZine

Edit > Preferences > Applications - empty (Kubuntu 8.4)

User Help for Mozilla Firefox
tinkerbelle
 
Posts: 7
Joined: August 11th, 2008, 6:46 am

Post Posted August 11th, 2008, 7:02 am

I am using Kubuntu 8.4 with FF 3.0.1 and I am having a problem in getting several applications to run correctly. When I went to Edit > Preferences > Applications to see what was there the page is empty, which seems strange to say the least.

Entering anything in the search box causes the preferences window to close.

Even stranger perhaps is that some things, like flash work ok, pdf opening sometimes works but it seems only once a day, and java apps do not run at all. (Java 6 is installed and enabled)

I could really use some help in solving this one.

Grumpus

User avatar
 
Posts: 12077
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted August 11th, 2008, 7:34 am

You should be going to /Edit/Preferences/Content/File Types/Manage Button. This should reveal a panel which has a text input area at the top and a panel below with the various files types. You should be able to make changes by highlighting the file type and hitting the "Remove Action" or "Change Action" buttons.

tinkerbelle
 
Posts: 7
Joined: August 11th, 2008, 6:46 am

Post Posted August 11th, 2008, 8:05 am

Mmmm I do not have anything about File Types or a manage button under /Edit/Preferences/Content/ nor is it on any other tab. I do seem to rember seeing it in an earlier version

frcan

User avatar
 
Posts: 3305
Joined: January 23rd, 2007, 11:15 am

Post Posted August 11th, 2008, 8:09 am

^^ mmmm.... Here what I see in FF3. No File Types>Manage button that I can see.
Image

Image

tinkerbelle
 
Posts: 7
Joined: August 11th, 2008, 6:46 am

Post Posted August 11th, 2008, 8:16 am

Content page is exactly as I have it. Applications with me is, as I said, completely empty.

frcan

User avatar
 
Posts: 3305
Joined: January 23rd, 2007, 11:15 am

Post Posted August 11th, 2008, 8:20 am

See if something can help understand the way it works in FF3 http://kb.mozillazine.org/File_types_an ... _Firefox_3

Grumpus

User avatar
 
Posts: 12077
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted August 11th, 2008, 8:29 am

Sorry for the misleading post Tinkerbelle. Looks like there's been some chnages.
Thanks for the link Frcan.
Powssibly if you install Evince or XPDF from the repositories and you should get some internal change in Ubuntu which should prompt the download panel for PDF files.

tinkerbelle
 
Posts: 7
Joined: August 11th, 2008, 6:46 am

Post Posted August 11th, 2008, 8:39 am

This is exactly what is not working for me.
An example-
I visit a site with a pdf file available to view, I click the link and get a choice of opening the file with KPDF or downloading, I select open with kpdf and ensure the do this always box is ticked. The file d/l and opens OK, although nothing is added to the applications list. Next time I want to read a pdf i get the open with... or d/l choice, even if it is the same file I just read with kpdf. The open with.. dialog opens my home folder and I have to go searching through /usr to find the kpdf binary. The first time I do this on each session it works correctly, every subsequent try and FF has forgotten the association.
Another example
On any page with flash content I see the flash content, that works OK even though there is no application in the list to display flash files.
Third example
Any java app I try to run fails to load or gives an error app not started, the only controls I have are the Java and Java script check boxes under /content which are both checked.

dickvl

User avatar
 
Posts: 52466
Joined: July 18th, 2005, 3:25 am

Post Posted August 11th, 2008, 9:44 am

Try to delete mimeTypes.rdf in the Profile Folder

Do you see plugins on the about:plugins page and in Tools > Add-ons > Plugins ?
Those plugins entries should also have MIME types.

You can start Firefox in Safe mode to check if your problem is caused by an extension or theme (try the default theme).
If starting in Safe-mode works then disable your extensions (Tools > Add-ons > Extensions or use the option in the Safe-mode window) and re-enable them one by one until you find which one is causing it.
Close and restart Firefox after each change.

You can try to create a new (test) profile to check if it is caused by your current profile.
See Standard diagnostic: Profile issues (MozillaZine KB)
First test the new profile without making changes and if that works then you can transfer some files to the new profile.
See Transferring data to a new profile (MozillaZine KB)
(first test the new profile without modifications and be careful not to copy corrupted files to the new profile)

tinkerbelle
 
Posts: 7
Joined: August 11th, 2008, 6:46 am

Post Posted August 12th, 2008, 1:39 am

dickvl wrote:Try to delete mimeTypes.rdf in the Profile Folder

Do you see plugins on the about:plugins page and in Tools > Add-ons > Plugins ?
Those plugins entries should also have MIME types.

You can start Firefox in Safe mode to check if your problem is caused by an extension or theme (try the default theme).
If starting in Safe-mode works then disable your extensions (Tools > Add-ons > Extensions or use the option in the Safe-mode window) and re-enable them one by one until you find which one is causing it.
Close and restart Firefox after each change.

You can try to create a new (test) profile to check if it is caused by your current profile.
See Standard diagnostic: Profile issues (MozillaZine KB)
First test the new profile without making changes and if that works then you can transfer some files to the new profile.
See Transferring data to a new profile (MozillaZine KB)
(first test the new profile without modifications and be careful not to copy corrupted files to the new profile)


Deleting mimeTypes.rdf does nothing to improve matters, I understood that a new version of the file would be created by FF but it is not.

The about:plugins page does show some add-ons with mime types associated. The default plugin is disabled on this page but is shown as enabled on the tools/plugins page.

Safe mode and a new test profile with no added extensions etc, work just the same as my normal profile at least on the things I tried. Java test from Sun site shows 'start app not initialised' and d/l of a pdf file works the first time by opening it in kpdf, selecting the same or any other pdf to d/l gives the error message pdf could not be opened because the helper application does not exist. Change the association in your preferences.

In all the variations I tried the Applications list is empty ands any attempt to do anything on that page closes it.

Grumpus

User avatar
 
Posts: 12077
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted August 12th, 2008, 7:41 am

Tinkerbelle - IF your main tab under /Edit/Preferences/Main has a Downloads section you may want to check the "Save files to" box and then the route to the folder for the file in the text input block. It may be if the download is set to "ask always where to save files" ( is checked) it abrogates the automatic condition. You may also want to either show or not show the "Downloads Window" under the same section.
I also do not show PDF as a file type but have opted for a different condition and prefer more control with less automatic response.

There may also be some restricted issues with KPDF which would not normally exist with Adobe or the Firefox Adobe pluggin.

tinkerbelle
 
Posts: 7
Joined: August 11th, 2008, 6:46 am

Post Posted August 12th, 2008, 10:35 am

This would not really explain why the first time of a session it d/l and opens the pdf the the next time it claims the helper app is missing.

The show downloads window is off as I use d/l status bar extension, and always ask is on as that is the way I need it.

KillingTime
 
Posts: 158
Joined: November 1st, 2003, 10:46 am

Post Posted August 12th, 2008, 10:37 am

I'm running Kubuntu 8.04 as well, and had exactly the same problem. Installing the firefox-gnome-support package from the Kubuntu repositories fixes it. Installing a gnome support package under KDE may not be very intuitive, but it gets the job done in this case!
A society that gets rid of all its troublemakers goes downhill. - Robert A. Heinlein

tinkerbelle
 
Posts: 7
Joined: August 11th, 2008, 6:46 am

Post Posted August 13th, 2008, 12:24 am

Killing Time

YES - as you say a totally counter intuitive thing to do but it worked. Applications tab is fully populated and the pdf problem is solved, got to check on tother things yet but it looking good.

Thank you very much.

Cant see a way to add solved to the thread title.

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot], malliz and 8 guests