MozillaZine


[ext] FlashGot 1.0 - Lord of the Links

Announce and Discuss the Latest Theme and Extension Releases.
bart5986
 
Posts: 13
Joined: December 3rd, 2004, 2:11 am

Post Posted August 19th, 2008, 1:33 am

I'm pretty sure this is a flashgot bug....

If I open Free Download Manager by itself I get access to a completly different download list then if I open it by flashgotting something.

So basically what has been happening is I've flashgotted something, then the next day when I open FDM by itself its not there and I have to go and flashgot something else to bring up the old download list.

Running Vista 64bit with the latest FDM.

Giorgio Maone

User avatar
 
Posts: 3516
Joined: September 21st, 2004, 12:05 am
Location: Palermo - Italy

Post Posted August 19th, 2008, 10:16 am

@BobbyBrown:
Fixed in 1.0.5.5, thanks.

@unholy:
How was so much convinced disabling Wine support by default was a good idea that I did it in 1.0.5, or so I did believe: in facts, the change apparently slipped out at the last moment, after the changelog had been already updated.
It's disabled by default since 1.0.5.5, for real this time ;)

@bart5986:
it sounds like a FDM bug, actually, because FlashGot just sends the links to FDM and has no say in its internal list management.
Could you try uninstalling and reinstalling FDM?

BobbyBrown
 
Posts: 5
Joined: August 18th, 2008, 9:33 am

Post Posted August 19th, 2008, 12:57 pm

Hi again to all,

Thanks for your quick answer. I tried the 1.0.5.5 version and both "DTA" and "DTA (Turbo)" selections work well but another little bug is appeared (it also occured in the 1.5.0.4 version):
The "(Built In)" name is replaced by "???" as shown on the following picture but the function works correctly. I changed the values from "???" to "(Built In)" in the 'about:config' but without any success, they are automatically reset to their default settings (???).

Image

Thanks again for your help!

PS: The link to the "flashgot-1.0.5.5.xpi" file on the official FlashGot website has not been updated yet. Although the file is on the server, it still redirects to the 1.0.5.4 release.

The right link to FlashGot 1.0.5.5 Development Build: flashgot-1.0.5.5.xpi

See You soon!

bart5986
 
Posts: 13
Joined: December 3rd, 2004, 2:11 am

Post Posted August 19th, 2008, 5:29 pm

Giorgio Maone wrote:@bart5986:
it sounds like a FDM bug, actually, because FlashGot just sends the links to FDM and has no say in its internal list management.
Could you try uninstalling and reinstalling FDM?


I thought it might have something to do with a command line flashgot is using as its clearly opening differently then clicking on it yourself.

I'll reinstall FDM tonight or tommorow and report back :)

Angst
 
Posts: 3
Joined: May 11th, 2008, 3:32 am
Location: Cape Town, South Africa

Post Posted August 20th, 2008, 1:33 am

Hi Giorgio

As always, thanks for a great extension, and your continued assistance/support/attitude towards the Firefox community.

A request for a small enhancement: Can you please add "http://anony.110mb.com/" to the list of anonymizer services which Flashgot will 'parse' out and remove from the link (selection).
(i.e. http://anony.110mb.com/?http://rapidsha ... xxxxxx.xxx)

Once again, thanks for the assistance and willingness to listen and help. :wink:

Kind regards

~Angst~

ghost_zero5
 
Posts: 28
Joined: October 23rd, 2004, 11:23 am

Post Posted August 20th, 2008, 5:22 am

Giorgio Maone wrote:@ghost_zero5:
shift+alt+click not working sounds like an extension conflict.
Could you try Standard Diagnostic?
However you can use alt+click in place of alt+shift+click by setting the flashgot.invertAltShiftClick about:config preference to true.


I had done that already. I disabled all plugins instead of Flashgot. The point it that Firefox just seems to mark the link to the download file instead of clicking it.
Btw.: I now tried the inversion: The link still got marked instead of clicked.
I now tried the development version 1.0.5.5 and there it works again. Though strangley some links (I believe if they are images) they also get marked if you Alt+Click (used the invert option) still but the download at least starts too.
However, it still would be nice to have some option to set the combination of what to press itself too.

Giorgio Maone

User avatar
 
Posts: 3516
Joined: September 21st, 2004, 12:05 am
Location: Palermo - Italy

Post Posted August 20th, 2008, 9:26 am

@BobbyBrown:
that's a localization (language) problem, since "Built In" now can be translated but there's no French translation yet.
It will be fixed in next release.

@Angst:
http://anony.110mb.com/ does already work, as far as I can see (it's matched by the "generic" redirection processor).

therube

User avatar
 
Posts: 21288
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted August 20th, 2008, 10:26 am

FlashGot 1.0.5.5. not installing into SeaMonkey 1.1. (It does install into SeaMonkey 2.0.)

Error console:
Code: Select all
Error: missing ] after element list
Source File:
Line: 23, Column: 2
Source Code:
  "en-US"


install.log:
Code: Select all
-------------------------------------------------------------------------------
file:///C:/WLIB/LeechFTP/LEECHTMP/not-Sysinternals/flashgot-1.0.5.5-dev.xpi  --  2008-08-20 10:32:50
-------------------------------------------------------------------------------

     ** Line: 23   missing ] after element list

     Install **FAILED** with error -229  --  2008-08-20 10:32:50


Ah, looks like install.js is missing a comma after this line:
"mn-MN","vi-VN","gl-ES"
Should be:
"mn-MN","vi-VN","gl-ES",

Let me see ...

Going to be more to it then just that, cause now I get (a more typical) -239 error message, but my typical fix (deleting flashgot.jar from /chrome/ directory) does not work?

Code: Select all
Error: no element found
Source File: jar:resource:///USERS/dumy/chrome/flashgot.jar!/locale/gl-ES/flashgot/manifest.rdf
Line: 1, Column: 1
Source Code:
^

Code: Select all
-------------------------------------------------------------------------------
file:///L:/LIB/NETT/Mozilla/flashgot-1.0.5.5-dev-239.xpi  --  2008-08-20 13:55:11
-------------------------------------------------------------------------------

     flashgot (version 1.0.5.5)
     --------

     ** ERROR (-214): Remove Folder: C:\WLIB\Mozilla\USERS\dumy\chrome\flashgot.jar
     ** ERROR (-214): Remove Folder: C:\WLIB\Mozilla\chrome\flashgot.jar
     ** Adding defaults/preferences/flashgot.js in C:\WLIB\Mozilla\defaults\pref\: exit code = 0
     ** Adding defaults/preferences/flashgot.js in C:\WLIB\Mozilla\USERS\dumy\pref\: exit code = 0
     [1/55]   Installing: C:\WLIB\Mozilla\USERS\dumy\chrome\flashgot.jar
     [2/55]   Replacing: C:\WLIB\Mozilla\defaults\pref\flashgot.js
     [3/55]   Installing: C:\WLIB\Mozilla\USERS\dumy\pref\flashgot.js
     [4/55]   Register Content: jar:resource:/USERS/dumy/chrome/flashgot.jar!/content/flashgot/
     [5/55]   Register Locale: jar:resource:/USERS/dumy/chrome/flashgot.jar!/content/flashgot/en-US/
     [6/55]   Register Locale: jar:resource:/USERS/dumy/chrome/flashgot.jar!/locale/gl-ES/flashgot/
     ** InstallLocale() failed. - nsresult code: 0x80004005
     ** InstallPackage() failed. - nsresult code: 0x80004005
     ** Failed to register chrome. - nsresult code: 0x80004005
     flashgot (version 1.0.5.5)
     --------

     ** Adding defaults/preferences/flashgot.js in C:\WLIB\Mozilla\defaults\pref\: exit code = 0
     ** Adding defaults/preferences/flashgot.js in C:\WLIB\Mozilla\USERS\dumy\pref\: exit code = 0
     [1/55]   Replacing: C:\WLIB\Mozilla\USERS\dumy\chrome\flashgot.jar
     [2/55]   Replacing: C:\WLIB\Mozilla\defaults\pref\flashgot.js
     [3/55]   Installing: C:\WLIB\Mozilla\USERS\dumy\pref\flashgot.js
     [4/55]   Register Content: jar:resource:/USERS/dumy/chrome/flashgot.jar!/content/flashgot/
     [5/55]   Register Locale: jar:resource:/USERS/dumy/chrome/flashgot.jar!/content/flashgot/en-US/
     [6/55]   Register Locale: jar:resource:/USERS/dumy/chrome/flashgot.jar!/locale/gl-ES/flashgot/
     ** InstallLocale() failed. - nsresult code: 0x80004005
     ** InstallPackage() failed. - nsresult code: 0x80004005
     ** Failed to register chrome. - nsresult code: 0x80004005

     Install **FAILED** with error -239  --  2008-08-20 13:55:16

Note the local /gl-ES/, so maybe its just a locale snafu.
Also the -214 error mentions removing a Folder. Is that generic Folder = File? Anything to that?

chrome.manifest may be wrong too?

Change from
locale flashgot gl-ES jar:chrome/flashgot.jar!/content/flashgot/gl-ES/
to
locale flashgot gl-ES jar:chrome/flashgot.jar!/locale/gl-ES/flashgot/

But then I get:
Code: Select all
Error: no element found
Source File: jar:resource:///USERS/dumy/chrome/flashgot.jar!/locale/gl-ES/flashgot/manifest.rdf
Line: 1, Column: 1
Source Code:
^
[code]
     ** Adding defaults/preferences/flashgot.js in C:\WLIB\Mozilla\defaults\pref\: exit code = 0
     ** Adding defaults/preferences/flashgot.js in C:\WLIB\Mozilla\USERS\dumy\pref\: exit code = 0
     [1/55]   Replacing: C:\WLIB\Mozilla\USERS\dumy\chrome\flashgot.jar
     [2/55]   Replacing: C:\WLIB\Mozilla\defaults\pref\flashgot.js
     [3/55]   Installing: C:\WLIB\Mozilla\USERS\dumy\pref\flashgot.js
     [4/55]   Register Content: jar:resource:/USERS/dumy/chrome/flashgot.jar!/content/flashgot/
     [5/55]   Register Locale: jar:resource:/USERS/dumy/chrome/flashgot.jar!/content/flashgot/en-US/
     [6/55]   Register Locale: jar:resource:/USERS/dumy/chrome/flashgot.jar!/locale/gl-ES/flashgot/
     ** InstallLocale() failed. - nsresult code: 0x80004005
     ** InstallPackage() failed. - nsresult code: 0x80004005
     ** Failed to register chrome. - nsresult code: 0x80004005

     Install **FAILED** with error -239  --  2008-08-20 14:09:27

Thinking that in flashgot.jar, in local/gl-ES/, contents.rdf is foobar'd.

So now that I've removed references to /gl-ES/ in both install.js & chrome.manifest, FlashGot 1.0.5.5 installs.

(Also someone mentioned a dialog that jumped or otherwise appeared away from the cursor? Was that FlashGot or NoScript. Anyhow, I just saw that in FlashGot.)

It was NoScript, viewtopic.php?p=4195525#p4195525.

Somewhat different circumstances for me (as there is no notification bar in SeaMonkey 1), but rather it happened when the FlashGot page was loaded (upon restart). Could have just been a quirk based on my right-click timing & the funky way the page loads the ads that changed the location of the right-click dialog.
Fire 750, bring back 250.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Giorgio Maone

User avatar
 
Posts: 3516
Joined: September 21st, 2004, 12:05 am
Location: Palermo - Italy

Post Posted August 20th, 2008, 1:38 pm

@therube:
yes, you're right on gl-ES' contents.rdf being screwed, thanks for noticing.
Babelzilla is apparently doing that for any new locale, I guess lots of other extensions are gonna have this problem with SeaMonkey 1.* (not any other browser, though, because contents.rdf is unused since chrome.manifest's appearance).
Will be fixed in next build.

guestlogin
 
Posts: 30
Joined: September 3rd, 2006, 11:57 am

Post Posted August 21st, 2008, 7:50 am

I reinstalled Firefox and FlashGot still won't recognize FlashGet. Is there something missing in the FlashGet program that it can't find?

Giorgio Maone

User avatar
 
Posts: 3516
Joined: September 21st, 2004, 12:05 am
Location: Palermo - Italy

Post Posted August 21st, 2008, 8:42 am

@guestlogin:
please try to reinstall FlashGet, paying attention that the Internet Explorer integration is enabled.
Please check if the Internet Explorer "Download with FlashGet" menus work.
If they do, Firefox+FlashGot should work as well. Otherwise something is breaking during installation (e.g. you've got no Administrator rights when you install FlashGet)

guestlogin
 
Posts: 30
Joined: September 3rd, 2006, 11:57 am

Post Posted August 21st, 2008, 9:01 am

The reinstall for FlashGet resolved it finally.

BobbyBrown
 
Posts: 5
Joined: August 18th, 2008, 9:33 am

Post Posted August 21st, 2008, 11:02 pm

Hi again and thank You for your explanation, I'll wait for the next release, but for now, I have modified some files to fix this:

I added these two missing lines into the "flashgot.dtd" file:
Code: Select all
<!ENTITY flashgotOverwrite "Ecraser">
<!ENTITY flashgotMedia "Télécharger le(s) média(s) avec FlashGot">

and this one into "flashgot.properties":
Code: Select all
dm.builtIn=(Intégré au navigateur)

Then I replaced old ones into "flashgot.jar" (\chrome\flashgot.jar / locale\fr-FR\flashgot)

I also changed the DTA and DTA (Turbo) names to their new labels (dTa! & dTa OneClick!) in "flashgotService.js" (\components)
The line before modification:
Code: Select all
for each (dm in [new FlashGotDM("DTA"), new FlashGotDM("DTA (Turbo)")]) {

and after:
Code: Select all
for each (dm in [new FlashGotDM("dTa!"), new FlashGotDM("dTa OneClick!")]) {

Image

That solves the "(Browser Built In) localization" bug (fr-FR only) and "Overwrite" and "FlashGot Media" are now correctly translated to the local language (fr-FR only).

Image

The fixed files ("flashgot.dtd", "flashgot.properties" and "flashgotService.js") can be downloaded here.


Some questions to ask You:

Is there any difference between to use "like-Anony" websites and the "Use always this Referrer URL" option ?
Do both methods only change the referrer (the first to anony.110mb.com or others, and the second to the URL set in the option menu) or is one better than the other ?

If You use a site like KeepVid You can also (but not always) download other video file versions.
On the following picture, two links are available but both are differents from the one directly catched by FlashGot Media on the Dailymotion website.
So, will the "FlashGot Media" function be able to do the same in order to get all available files ?
Image
URL of the video:
http://www.dailymotion.com/video/x623o5_otage-liberee-cookie-sarko_fun

URL through KeepVid site:
http://keepvid.com/?url=http%3A//www.dailymotion.com/video/x623o5_otage-liberee-cookie-sarko_fun

Last thing, can You check this link please, because it is "protected" (not pausable very long time, no resume after an internet disconnection...) and I'd like to know if there is a way to make this kind of link correctly "catchable" by FlashGot or if it's technically impossible.

Thanks again for your responses and for the time You waste to help others.

See You soon!

Giorgio Maone

User avatar
 
Posts: 3516
Joined: September 21st, 2004, 12:05 am
Location: Palermo - Italy

Post Posted August 22nd, 2008, 12:59 pm

@BobbyBrown:
I don't know how KeepVid work, but "FlashGot Media" intercepts the streams as they're playing.
I've been able to collect two links from that page by switching the video quality from the player menu, but they were both "flv" (one about 9MB and the other 16MB) and I couldn't see any mp4.

cdrfirefox
 
Posts: 3
Joined: July 23rd, 2007, 5:02 pm

Post Posted August 22nd, 2008, 5:12 pm

I installed Firefox 3.01 and am trying to install Flashgot. I keep getting the following errors:
Firefox gives a -203
The Error Console gives
Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsISafeOutputStream.finish]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Firefox/components/nsExtensionManager.js :: closeSafeFileOutputStream :: line 508" data: no]
Source File: file:///C:/Program%20Files/Mozilla%20Firefox/components/nsExtensionManager.js
Line: 508.

What could be wrong? What settings am I probably missing? Looking forward to using the application to extract audio and video.
Thanks
cdridgley
Last edited by LoudNoise on August 22nd, 2008, 5:28 pm, edited 1 time in total.
Reason: Removed email addy

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 1 guest