MozillaZine

The Official Win32 20080903 [Trunk] build is out.

Discussion about official Mozilla Firefox builds
smsmith
Moderator

User avatar
 
Posts: 19831
Joined: December 7th, 2004, 8:51 pm
Location: Indiana

Post Posted September 2nd, 2008, 10:02 pm

I'll give it a go tomorrow then! Thanks for the info!

:D
Give a man a fish, and he eats for a day. Teach a man to fish, and he eats for a lifetime.
I like poetry, long walks on the beach and poking dead things with a stick.
Please do not PM me for personal support. Keep posts here in the Forums instead and we all learn.

Cyberbeing
 
Posts: 107
Joined: May 21st, 2008, 10:47 pm

Post Posted September 2nd, 2008, 10:24 pm

Here are some SunSpider tests with Build 20080902191608 and it looks like 3.1 /w Jit wins over Chrome
Firefox 3.1 Jit ON (1725.8ms Total)
Firefox 3.1 Jit OFF (3558.8ms Total)
Google Chrome (2192.0ms Total)

On Dromaeo though, Chrome wins by a large margin. From left to right, Firefox Jit OFF (1859.40ms), Firefox Jit ON (1247.80ms), Google Chrome (463.40ms). It makes me wonder if WebKit/Google cheated and optimized just so it destroyed Mozilla's javascript benchmark considering there are a few inconsistencies between the its Sunspider and Dromaeo benchmarks. If everything was equal, Google Chrome should have won all the tests it did in Dromaeo in Sunspider as well, but on some it does and others it doesn't. Maybe it just goes back to SunSpider being affected by rendering speed and Chrome is just really slow in that respect at the moment even though its javascript engine is much faster.

Tolien
 
Posts: 206
Joined: October 26th, 2005, 4:16 pm
Location: UK

Post Posted September 3rd, 2008, 3:09 am

Trying Chrome's V8 Benchmark (here), I get

3.1b1pre (20080902232545) with JIT on - 109 (79/95/67/141/220)
3.1b1pre (20080902232545) with JIT off - 121 (100/110/73/133/236)
3.0.3pre (2008090206) - 130 (123/143/70/155/194)
Chrome - 1026 (1205/1125/872/680/1412) :shock:

So it seems JIT's regressed performance by ~10%, and 3.1's regressed by about 7%, which doesn't match up with Sunspider, Dromaeo et al :?

Ted Mielczarek
 
Posts: 1269
Joined: November 5th, 2002, 7:32 am
Location: PA

Post Posted September 3rd, 2008, 4:03 am

Tolien: keep in mind that that's Google's benchmark, so they've probably optimized heavily for it. Much like how WebKit had a commanding lead in SunSpider performance when they first released the benchmark. It's not that hard to find cases that other JS engines perform poorly on, and then optimize your own performance so you look much better in those particular cases.

Tolien
 
Posts: 206
Joined: October 26th, 2005, 4:16 pm
Location: UK

Post Posted September 3rd, 2008, 4:10 am

Yeah, I was more thinking about the 3.1b1pre with/without JIT and 3.0.3pre comparison than with Chrome. I guess it's something that'll get picked up down the line.

A`ja

User avatar
 
Posts: 607
Joined: April 20th, 2005, 8:44 am
Location: St. Louis, MO, USA

Post Posted September 3rd, 2008, 4:14 am

With nightly containing latest merge of tracemonkey to mozilla-central
451865 TM: startup crash, with Operator extension and content jit enabled @isPromoteInt(nanojit::LIns*)
is fixed.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b1pre) Gecko/20080903020504 Minefield/3.1b1pre ID:20080903020504

You might want to check if TM-related bugs you've filed are still broken, too.

ltsnow

User avatar
 
Posts: 1107
Joined: March 23rd, 2006, 1:49 pm
Location: Valdosta, GA

Post Posted September 3rd, 2008, 4:20 am

Things are improving. ESPN works now with both JITs enabled and TV Guide doesn't crash. It still can't load the grid though.

a;skdjfajf;ak

User avatar
 
Posts: 17002
Joined: July 10th, 2004, 8:44 am

Post Posted September 3rd, 2008, 4:56 am

Build is out:

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b1pre) Gecko/20080903034741 Minefield/3.1b1pre Firefox/3.0 ID:20080903034741

a;skdjfajf;ak

User avatar
 
Posts: 17002
Joined: July 10th, 2004, 8:44 am

Post Posted September 3rd, 2008, 5:12 am

Bug https://bugzilla.mozilla.org/show_bug.cgi?id=451986 opening Bookmarks Organizer with JIT Chrome enabled no longer is crashing. Will mark fixed shortly.

EDIT: Reopening - still crashes after a restart of the browser, apparently you have to restart the browser to enable JIT changes..

a;skdjfajf;ak

User avatar
 
Posts: 17002
Joined: July 10th, 2004, 8:44 am

Post Posted September 3rd, 2008, 6:14 am

Was anyone else getting crashes on Google Docs with JIT enabled besides me ? I'm no longer crashing, even with both Chrome & Content enabled.

https://bugzilla.mozilla.org/show_bug.cgi?id=451984

I'm not going to be so hasty to close this yet :)

polidobj

User avatar
 
Posts: 3147
Joined: March 31st, 2004, 9:10 am
Location: Maryland USA - im in ur tinderbox, crashtesting ur firefox

Post Posted September 3rd, 2008, 6:23 am

Well this bug was thought to be fixed by that TM merge but it wasn't: #451666[Core:JavaScript Engine]-TM: Null-deref crash [@ TraceRecorder::stack] opening DOM inspector (2 cx / 1 thread&tm) [All]
At least it's already fixed in the TM tree.
Brian J Polidoro - Today's bugs brought to you by Raid. :P
Windows7 - Firefox user since ~Feb 2002

A`ja

User avatar
 
Posts: 607
Joined: April 20th, 2005, 8:44 am
Location: St. Louis, MO, USA

Post Posted September 3rd, 2008, 6:25 am

Littlemutt wrote:Was anyone else getting crashes on Google Docs with JIT enabled besides me ? I'm no longer crashing, even with both Chrome & Content enabled.


WFM....was able to create a new document with no trouble.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080903034741 Minefield/3.1b1pre ID:20080903034741
Chrome & Content JIT enabled

diegoliz
 
Posts: 17
Joined: June 4th, 2006, 2:25 pm

Post Posted September 3rd, 2008, 6:47 am

I'm not able to select "Operating System" in litmus with the last nightly (it worked with 5 days ago nightly).
Tested with both jit enabled/disabled.
Anyone here is having the same trouble?


The last working nightly is:
30 Aug Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080830031750 Minefield/3.1b1pre

And the first that has this issue is:
31 Aug Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080831162801 Minefield/3.1b1pre

Any hint on how to find to which check-in this regression can be related?

wgianopoulos

User avatar
 
Posts: 1736
Joined: July 23rd, 2003, 8:15 am

Post Posted September 3rd, 2008, 6:57 am

diegoliz wrote:
I'm not able to select "Operating System" in litmus with the last nightly (it worked with 5 days ago nightly).
Tested with both jit enabled/disabled.
Anyone here is having the same trouble?


The last working nightly is:
30 Aug Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080830031750 Minefield/3.1b1pre

And the first that has this issue is:
31 Aug Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080831162801 Minefield/3.1b1pre

Any hint on how to find to which check-in this regression can be related?

Hard to tell without a URL, but this sounds like bug 453105.

smsmith
Moderator

User avatar
 
Posts: 19831
Joined: December 7th, 2004, 8:51 pm
Location: Indiana

Post Posted September 3rd, 2008, 7:05 am

Give a man a fish, and he eats for a day. Teach a man to fish, and he eats for a lifetime.
I like poetry, long walks on the beach and poking dead things with a stick.
Please do not PM me for personal support. Keep posts here in the Forums instead and we all learn.

Return to Firefox Builds


Who is online

Users browsing this forum: No registered users and 0 guests