MozillaZine


SessionSaver extension problem

Talk about add-ons and extension development.
iamjijav
 
Posts: 10
Joined: June 1st, 2004, 3:50 pm

Post Posted June 1st, 2004, 4:02 pm

I have the SessionSaver extension installed, but it has stopped working for whatever reason.

The moment it stopped working I think was a couple of days ago... The session recovery process kept crashing FireFox, and to fix it I renamed the sessionsaver JAR file, fired up FireFox and then renamed back the JAR file. Not sure why but this has caused the plugin to stop working. Actually this is only my guess for the reason - I'm not exactly sure.

I tried reinstalling it (the sessionsaver), removing all references to it from chrome.rdf and installed-chrome.txt and installing it on what I imagine is a clean-of-sessionsaver-firefox, but it still won't work.

What am I doing wrong?

Sorry if I'm posting in the wrong forum. ;)

AnonEmoose
 
Posts: 2031
Joined: February 6th, 2004, 11:59 am

Post Posted June 1st, 2004, 4:06 pm

u probably messed up your overlays.rdf in your overlayinfo folder...or perhaps u've disabled it from the Extension manager Options pane...

iamjijav
 
Posts: 10
Joined: June 1st, 2004, 3:50 pm

Post Posted June 1st, 2004, 4:13 pm

Nope. Enabled. Actually several times. Each time restarting FireFox to test it...

About the ovarlays.rdf - that's one thing I didn't touch. Perhaps I should've cleared the sessionsaver reference there too? Sorry if those are completely retarded questions but I'm not exactly knowledgable when it comes to manually fixing software :)

iamjijav
 
Posts: 10
Joined: June 1st, 2004, 3:50 pm

Post Posted June 1st, 2004, 11:21 pm

Bump for help.

lid2000

User avatar
 
Posts: 174
Joined: April 6th, 2004, 11:49 pm
Location: Australia

Post Posted June 1st, 2004, 11:48 pm

Try deleting your overlayinfo folders, and the XUL.mfl file. Then edit installed-chrome.txt (just put a space then delete then save it so the time its been edited changes), and give that a go.

Rowne Mastaile

User avatar
 
Posts: 1434
Joined: December 21st, 2003, 3:05 pm
Location: Housed in a swirling neosma of scintillating thought and turgid ideas.

Post Posted June 2nd, 2004, 12:43 am

It's possible you've missed some entries, in the chrome.rdf most likely, somewhere. The best course of action would probably be something along these lines. First of all, hop over to Sboulema's Extension Mirror and install from there, he has the latest publically available Session Saver.

Once you have that, install one of the good extension uninstallers out there. Such as Configuration Mania, moz_jg's (I think) or Chris Pedrick's (again, I think). You can get those from this forum or Sboulema's mirror, respectively.

Try using the uninstaller extension itself to remove Session Saver, then install Session Saver again. It should work. If it doesn't, hop back here and explain how exactly it's not working. For example: Do you have the SS File menu entries? Is it listed in your Tools > Options > Extensions pane?

iamjijav
 
Posts: 10
Joined: June 1st, 2004, 3:50 pm

Post Posted June 2nd, 2004, 3:21 pm

Roan - I'll have to check out that extension uninstaller, thanks!

I fixed it. Uninstalled FireFox, renamed the Phoenix dir in Docs and Settings, made a clean install of FireFox and then got to the extensions. I'm glad it worked.. I tried reinstalling it earlier today and it didn't work - turns out I had kept the Phoenix dir and it was like if I never got rid of it.

Thanks for the help guys!

Return to Extension Development


Who is online

Users browsing this forum: No registered users and 1 guest