MozillaZine

Multiple windows from outside links (Thunderbird, etc)

User Help for Mozilla Firefox
CritterNYC
 
Posts: 970
Joined: August 27th, 2003, 12:27 am
Location: Astoria, NY

Post Posted June 15th, 2004, 4:16 pm

Firefox will launch multiple windows when an outside link is clicked (within Thunderbird or Windows, for example) or will launch one window and an error message.

<u><b>--== UPDATE / WORKAROUND FOR WINDOWS 95/98/ME/2000/XP ==--</b></u>
This is now a known bug in bugtraq. It appears that Firefox 0.9 doesn't register itself correctly as the default browser in some cases. The bug can be found here:
http://bugzilla.mozilla.org/show_bug.cgi?id=246078

I have a workaround in the form of a .REG file that should fix Firefox handling http, https, ftp and gopher links from external programs here:
http://johnhaller.com/jh/mozilla/firefox_bug_246078.asp

Please respond to this thread with any questions or comments to keep them in one place and to keep this thread visible for others.


--== Original Message ==--
After installing the new Firefox 0.9, clicking links in email messages within Thunderbird yields 2 windows launched. The first window is a normal one pointing to the standard URL location. The second appears that Thunderbird is saving the file to the temp directory and then calling Firefox with the result.

This behavior did not exist with Firefox 0.8 and does not occur if I change the default browser to IE6 or Opera 7.5. Anyone else seen this?

Windows XP Pro (Fully patched)
Thunderbird 0.6 (20040502)
Firefox 0.9 (Windows Installer)
Last edited by CritterNYC on July 7th, 2004, 9:00 am, edited 9 times in total.

Somebody
Guest
 

Post Posted June 15th, 2004, 4:32 pm

I am having the same issue except that I am running Outlook 2003 in Windows XP Pro.

os2
 
Posts: 2
Joined: September 17th, 2003, 7:01 pm
Location: Canada

Post Posted June 15th, 2004, 4:48 pm

i have the same problem (CritterNYC )

i use thunderbird 0.6.... same thing

CritterNYC
 
Posts: 970
Joined: August 27th, 2003, 12:27 am
Location: Astoria, NY

Post Posted June 15th, 2004, 5:06 pm

Looks like their may be a problem with the way Firefox registers itself to handle urls in Windows or an issue with DDE messaging. A workaround for now:

1. Open Explorer
2. Select Tools and then Folder Options
3. Select the File Types tab
4. Select Extension: (NONE), File Type: HyperText Transfer Protocol
5. Click Advanced toward the bottom of the window
6. In the Edit File Type window, select open and click Edit
7. Clear the DDE message box (which should contain "%1")
8. Click OK, Click OK
9. Repeat for File Type: HyperText Transfer Protocol with Privacy
Take your browser, email, office suite, instant messenger, image editor and more with you...
Get portable versions of Firefox, Thunderbird, OpenOffice.org, Pidgin, GIMP and more at PortableApps.com

CritterNYC
 
Posts: 970
Joined: August 27th, 2003, 12:27 am
Location: Astoria, NY

Post Posted June 15th, 2004, 5:12 pm

There appears to be a bug filed, but it was with Firefox 0.8, where I didn't see this behavior. I'm using a new profile, so that isn't the issue. How many folks are seeing this?

http://bugzilla.mozilla.org/show_bug.cgi?id=246164
Take your browser, email, office suite, instant messenger, image editor and more with you...
Get portable versions of Firefox, Thunderbird, OpenOffice.org, Pidgin, GIMP and more at PortableApps.com

Guest
Guest
 

Post Posted June 15th, 2004, 5:35 pm

I am having the same problem with 0.9, outlook 2003, WinXP, didn't have problem with 0.8.

I uninstalled 0.8, installed 0.9. During install, set 0.9 as default browser.

When I first clicked on a link in Outlook, one 0.9 window opened fine, but along with an outlook dialog box asking for the location of the executable. If i hit cancel, this happened every time.
Now I pointed the dialog box to the .exe and I get 2 windows.

Guest
Guest
 

Post Posted June 15th, 2004, 5:39 pm

I forgot to add:
If firefox 0.9 is already open, outlook 2003 opens 2 new windows

Guest
Guest
 

Post Posted June 15th, 2004, 5:44 pm

the workaround CritterNYC posted above worked for outlook 2003 & 0.9
thanks

CritterNYC
 
Posts: 970
Joined: August 27th, 2003, 12:27 am
Location: Astoria, NY

Post Posted June 15th, 2004, 8:00 pm

I've filed a bug regarding this:
http://bugzilla.mozilla.org/show_bug.cgi?id=246979

While there were other instances of multiple window bugs, none qualify as a duplicate of this behaviour.

Somebody
Guest
 

Post Posted June 15th, 2004, 8:22 pm

Hmmm... My system had ""%1",,-1,0,,,," in the DDE field. When I removed the entire thing the problem was resolved. It also resolved the problem when you opened a IE favorite and it opened the page and then stated that the program "url address" was not found.

InvisiBill

User avatar
 
Posts: 1632
Joined: August 27th, 2003, 1:42 pm
Location: Michigan

Post Posted June 15th, 2004, 10:21 pm

I'm getting this with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040603 Firefox/0.8.0+ (BlueFyre) too, if that helps locate the source of hte problem...

Removing "%1",,-1,0,,,, from the DDE Message box seems to have fixed it. Can anyone provide the data that was in this field with a working copy of 0.8?

Guest
Guest
 

Post Posted June 16th, 2004, 5:38 am

up

very important question (multiple windows)

Kind regards

Guest
Guest
 

Post Posted June 16th, 2004, 6:42 am

Rather than remove "%1",,-1,0,,,,
I just unticked the - "Use DDE" Box for the "URL:HyperText Transfer Protocol". That seems to do the job. All ok for now.

Thanks for the workaround.

Pegus
 
Posts: 11
Joined: June 4th, 2004, 6:54 am

Post Posted June 16th, 2004, 7:37 am

CritterNYC wrote:Looks like their may be a problem with the way Firefox registers itself to handle urls in Windows or an issue with DDE messaging. A workaround for now:

1. Open Explorer
2. Select Tools and then Folder Options
3. Select the File Types tab
4. Select Extension: (NONE), File Type: HyperText Transfer Protocol
5. Click Advanced toward the bottom of the window
6. In the Edit File Type window, select open and click Edit
7. Clear the DDE message box (which should contain "%1")
8. Click OK, Click OK
9. Repeat for File Type: HyperText Transfer Protocol with Privacy


Cheers mate! Worked like a treat! =) Even works with TabBrowser Extensions!

CritterNYC
 
Posts: 970
Joined: August 27th, 2003, 12:27 am
Location: Astoria, NY

Post Posted June 16th, 2004, 7:47 am

This appears to be a bug with the way Firefox registers as the default browser within Windows. There is an existing bug (which I have marked my bug a duplicate of) here:
http://bugzilla.mozilla.org/show_bug.cgi?id=246078

It should be a 1.0 blocker.
Take your browser, email, office suite, instant messenger, image editor and more with you...
Get portable versions of Firefox, Thunderbird, OpenOffice.org, Pidgin, GIMP and more at PortableApps.com

Return to Firefox Support


Who is online

Users browsing this forum: Google Adsense [Bot] and 29 guests