MozillaZine

Display signature (sigdash and below) greyed out?

Discussion of general topics about Mozilla Thunderbird
James M. Prange
 
Posts: 113
Joined: March 11th, 2004, 1:06 pm

Post Posted March 20th, 2004, 5:45 pm

On Netscape mail/news, the sigdash line (<CR><LF>-- <CR><LF>) and
below in a message was displayed greyed out. Does anyone know of a way
to get Thunderbird to do the same?
Regards,
James

Old Ausdilecce
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted March 21st, 2004, 12:06 am

James, My TB *does* grey out the sig lines and the "-- " marker

Do you have any extensions installed ? (they could be messing with colors or something)

When you click reply on a message that has the sigdash line and sig, does the sig show up in the quoted text in the reply ? ( TB doesn't include the message sig in your reply ) .. Just trying to get a handle on what could be wrong.

James M. Prange
 
Posts: 113
Joined: March 11th, 2004, 1:06 pm

Post Posted March 21st, 2004, 12:23 am

Yes, I have a number of extensions installed, and in particular I've been using the "MicroThunderbird" theme. Switching back to the "Mozilla Thunderbird" theme brings back the greyed-out signatures.

Even with the MicroThunderbird theme active, (proper) signatures aren't included in the quoted text.

Thanks for the inspiration, at least now I know that Thunderbird itself can treat signatures as I expected.
Regards,
James

Jeroen p

User avatar
 
Posts: 3763
Joined: January 29th, 2004, 7:17 am
Location: The Netherlands

Post Posted March 21st, 2004, 2:59 am

If you want to overrule the color of your signature as set by your theme put this in your userContent.css:
Code: Select all
.moz-txt-sig { color: gray !important; }

You can find (or create as a text file) your userContent.css in the chrome folder of your profile (see http://texturizer.net/thunderbird/edit.html)

James M. Prange
 
Posts: 113
Joined: March 11th, 2004, 1:06 pm

Post Posted March 21st, 2004, 4:18 am

Thanks! Now I have my preferred theme with the signatures displayed as I like. Now if there were just a way to get more people to actually use a sigdash line....
Regards,
James

Sean O'Hara
 
Posts: 53
Joined: October 25th, 2003, 4:44 pm

Post Posted March 21st, 2004, 4:44 pm

While we're on the subject, is there a way to get TB to snip .sigs? It seems rather silly for it to create sigdashes if it doesn't use them for what they were intended.

Jeroen p

User avatar
 
Posts: 3763
Joined: January 29th, 2004, 7:17 am
Location: The Netherlands

Post Posted March 21st, 2004, 4:55 pm

You mean your Thunderbird does not cut of signatures when you reply to a message?
Extensions for Thunderbird: <a href="http://jpeters.no-ip.com/extensions/?page=tb_cs">Contacts Sidebar</a>, <a href="http://jpeters.no-ip.com/extensions/?page=tb_ts">Timestamp</a> and <a href="http://jpeters.no-ip.com/extensions/?page=tb_aes">Allow Empty Subject</a>

Old Ausdilecce
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted March 21st, 2004, 5:02 pm

Sean,

Please explain what you are saying. From where I sit, TB *does* use them for what they were intended for. OE and Outlook do NOT insert sigdashes and I am forced to manually snip the friggin disclaimer text from mail that I receive from companies that put this disclaimer text in the sig when I reply to them.

My wife works for one of these companies that use outlook (aka offenders) and I've told her to manually insert the sigtext at the bottom of her messages so that her company's disclaimer text does not come back to her in a reply to her message (the replier obviously didn't snip the disclaimer).. Now all of her collegues are doing it. They use outlook ( Big f*ing surprise ).

Funny thing is that her outlook *does* respect the sigdashes when she replies to my mail. (my sig does not come back to me, she does NOT snip my sig, Outlook does it for her)

James M. Prange
 
Posts: 113
Joined: March 11th, 2004, 1:06 pm

Post Posted March 21st, 2004, 7:52 pm

Sean,

For me, Thunderbird does snip signatures that begin with a *proper* sigdash. But the sigdash line is supposed to be two dashes followed by one space on a line by itself, in other words, the sequence:
<CR><LF>-- <CR><LF>
I've often seen attempts at sigdashes where the sender left off the single space, or even added something else on the same line; I don't know of any mail/news application that treats these as sigdashes. The sigdash sequence is intentionally something fairly simple and very specific that you wouldn't be likely to want to put in a message for any other reason.

Note that my text editor can be configured to automatically delete any trailing whitespace (space characters or tab codes) from lines, and if I recall correctly, Outlook Express's editor would delete any trailing whitespace if I stored the message as a draft and then re-opened it, so the space had to be added back in before sending the message.

ausdilecce,

It's been a while since I used Outlook Express, but I do remember that although it respected a sigdash when quoting a message, it failed to insert it automatically when attaching a signature. It seems to me that I worked around that by including the sigdash as the first line of my stored signature. If your wife's software is set up so that she can have her own signature above the company's disclaimer, that may make things a bit easier for her and her colleagues.

I understand the CYA policy of including a disclaimer with any company mail, but I do wish that they'd always start the disclaimer with a sigdash.
Regards,
James

Old Ausdilecce
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted March 21st, 2004, 8:21 pm

James,

Thanks for explaining but I did know that. ( maybe others did not, so thanks for that ) Unfortunately, my wife (or her colleages) does not have 'authorization' to change the sig . ( Authorization in this case means technical, political, etc authorization. )

James M. Prange wrote:I understand the CYA policy of including a disclaimer with any company mail, but I do wish that they'd always start the disclaimer with a sigdash.

Tell me about it mate. PITA

anyway cheers

X5-452
 
Posts: 136
Joined: July 26th, 2003, 9:29 am

Post Posted July 17th, 2004, 8:04 am

Ok, I'm totally lost, here. I created a userContent.css with .moz-txt-sig { color: gray !important; } as stated above, but it didn't work. What am I doing wrong? How do I get my sig to show with the font & color that I want? If you can explain this to me in simple terms, step by step, I'd appreciate the help!

PACE
 
Posts: 5
Joined: July 28th, 2004, 4:48 am

Post Posted July 28th, 2004, 4:50 am

I created a HTML signature, so I can use my font and color by formatting with explicit html tags.
Just save the signature with a html extension, then it's inserted as html.

Benjamin

frgregory2004
 
Posts: 28
Joined: July 15th, 2004, 3:14 pm

Post Posted September 24th, 2004, 2:27 am

I have tried Jeroen's advice about putting the code he gave in his post (with gray or black ... tried both???) into the correct chrome folder (root of chrome folder) and it has had absolutely no impact after reinitialising Thunderbird 0.8 whatsoever. Any ideas please. (I presume that this code is the only code to put in the css file?) .... the last suggestion about using an html file didn't work either. The gray setting overules everything.

Jeroen p

User avatar
 
Posts: 3763
Joined: January 29th, 2004, 7:17 am
Location: The Netherlands

Post Posted September 24th, 2004, 3:47 am

You better use this code, because the other code I gave was only for plain text messages. This works for plain text and HTML messages:
Code: Select all
/*
 * Change color of text and links in signature (Thunderbird display only)
 */
.moz-txt-sig, .moz-signature {
  color: black !important;
}
.moz-txt-sig > a, .moz-signature > a {
  color: #0000FF !important;
}
Extensions for Thunderbird: <a href="http://jpeters.no-ip.com/extensions/?page=tb_cs">Contacts Sidebar</a>, <a href="http://jpeters.no-ip.com/extensions/?page=tb_ts">Timestamp</a> and <a href="http://jpeters.no-ip.com/extensions/?page=tb_aes">Allow Empty Subject</a>

frgregory2004
 
Posts: 28
Joined: July 15th, 2004, 3:14 pm

Post Posted September 24th, 2004, 5:31 am

Thanks Jeroen. That worked. Unfortunately I have now lost my Vcard. Any ideas?

Return to Thunderbird General


Who is online

Users browsing this forum: No registered users and 1 guest