MozillaZine

0.6 Xft build

Discussion about official Mozilla Firefox builds
Laurentbon

User avatar
 
Posts: 225
Joined: December 8th, 2002, 9:39 am
Location: UK - French

Post Posted May 17th, 2003, 7:12 am

Has someone already come with a linux xft build of 0.6? I can't wait to update my linux build!
I will take any available link!

Ploum

User avatar
 
Posts: 245
Joined: November 11th, 2002, 3:14 am

Post Posted May 17th, 2003, 7:34 am

Is Xft the anti-aliased font ? If it is, I will also take any link ;)
Image

ferret
 
Posts: 33
Joined: April 21st, 2003, 4:32 am
Location: Swindon/Oxford, UK

Post Posted May 17th, 2003, 8:51 am

First person to make one gets a cookie...

Laurentbon

User avatar
 
Posts: 225
Joined: December 8th, 2002, 9:39 am
Location: UK - French

Post Posted May 17th, 2003, 9:03 am

A cookie, I don't know, but the privilege to be the first linux-xft firebird 0.6 creator! There seems to be an empty folder 'contrib' here...
http://ftp.mozilla.org/pub/firebird/releases/0.6/

iarnell

User avatar
 
Posts: 784
Joined: February 1st, 2003, 4:26 pm
Location: Netherlands

Post Posted May 17th, 2003, 9:21 am

Here you go...
http://www.xs4all.nl/~iarnell/phoenix-xft/MozillaFirebird-xft-0.6.tar.bz2
Sould also be available here soon
http://pryan.org/phoenix/iarnell/MozillaFirebird-xft-0.6.tar.bz2

Edit: This is built on RedHat 9, using gcc 3.2 and glibc 2.3.2. No guarantees that it will work on other systems.
Last edited by iarnell on May 17th, 2003, 10:22 am, edited 1 time in total.

Laurentbon

User avatar
 
Posts: 225
Joined: December 8th, 2002, 9:39 am
Location: UK - French

Post Posted May 17th, 2003, 10:02 am

This is great, thanks!
However, when I run the executable, I have the following error:

./MozillaFirebird-bin: /lib/libpthread.so.0: version `GLIBC_2.3.2' not found (required by /root/Downloaded/MozillaFirebird/libnspr4.so)

I never had any problems with your builds before iarnell... Sorry, but have you got any idea of how I can sort that out?
Cheers for the help..

pr0c
 
Posts: 58
Joined: March 14th, 2003, 10:18 am

Post Posted May 17th, 2003, 10:03 am

Oddly i cannot get the java plugin to be reconized at all with this XFT build. Anyone having problems?

iarnell

User avatar
 
Posts: 784
Joined: February 1st, 2003, 4:26 pm
Location: Netherlands

Post Posted May 17th, 2003, 10:18 am

Sorry, I should have mentioned that it's built on RedHat 9 with glibc-2.3.2. You can probably expect problems on other systems.
To use the java plugin, you can either download the gcc3.2 build of 1.4.1 from Blackdown, or grab the J2SE 1.4.2 beta from Sun.

pr0c
 
Posts: 58
Joined: March 14th, 2003, 10:18 am

Post Posted May 17th, 2003, 10:24 am

Ohhhh! Thanks :) I'd rather use suns latest beta anyway. I don't feel right running non-beta software hehe

iarnell

User avatar
 
Posts: 784
Joined: February 1st, 2003, 4:26 pm
Location: Netherlands

Post Posted May 17th, 2003, 10:29 am

Laurentbon wrote:This is great, thanks!
However, when I run the executable, I have the following error:

./MozillaFirebird-bin: /lib/libpthread.so.0: version `GLIBC_2.3.2' not found (required by /root/Downloaded/MozillaFirebird/libnspr4.so)

I never had any problems with your builds before iarnell... Sorry, but have you got any idea of how I can sort that out?
Cheers for the help..

Ooops. My bad. In my rush to get it built, I used the standard mozconfig (from the old Phoenix readme + xft). I'm rebuilding it now --without-system-nspr, et al.

pr0c
 
Posts: 58
Joined: March 14th, 2003, 10:18 am

Post Posted May 17th, 2003, 10:53 am

if you don't mind will you please post your .mozconfig file?

iarnell

User avatar
 
Posts: 784
Joined: February 1st, 2003, 4:26 pm
Location: Netherlands

Post Posted May 17th, 2003, 11:38 am

I've just uploaded the correct build. Here's the mozconfig
Code: Select all
export MOZ_PHOENIX=1
mk_add_options MOZ_PHOENIX=1
export MOZILLA_OFFICIAL=1
mk_add_options MOZILLA_OFFICIAL=1
export BUILD_OFFICIAL=1
mk_add_options BUILD_OFFICIAL=1
ac_add_options --enable-crypto
ac_add_options --disable-tests
ac_add_options --disable-debug
ac_add_options --disable-mailnews
ac_add_options --disable-composer
ac_add_options --enable-optimize=-O2
ac_add_options --disable-ldap
ac_add_options --disable-mailnews
ac_add_options --enable-extensions=default,-inspector,-irc,-venkman,-content-packs,-help
ac_add_options --enable-plaintext-editor-only
ac_add_options --enable-xft
ac_add_options --without-system-nspr
ac_add_options --without-system-zlib
ac_add_options --without-system-jpeg
ac_add_options --without-system-png
ac_add_options --without-system-mng

mpierce
 
Posts: 43
Joined: December 8th, 2002, 6:19 am

Post Posted May 17th, 2003, 2:52 pm

What is necessary to compile an xft build on a system as I am using a Debian Sarge system with glib 2.2.1-3

Laurentbon

User avatar
 
Posts: 225
Joined: December 8th, 2002, 9:39 am
Location: UK - French

Post Posted May 17th, 2003, 4:29 pm

iarnell wrote:Ooops. My bad. In my rush to get it built, I used the standard mozconfig (from the old Phoenix readme + xft). I'm rebuilding it now --without-system-nspr, et al.


I can't run your new build either. I guess it is because you use glibc-2.3.2 on your RH9. My distro, slackware 9, probably uses an older version of glibc... I will see if I can upgrade, otherwise, I will have to stick with an older firebird for the time being...

Edited: confirm, slackware 9 uses glibc 2.3.1 and I can't find a slackware package to update to 2.3.2. Not to worry, will think about it!

iarnell

User avatar
 
Posts: 784
Joined: February 1st, 2003, 4:26 pm
Location: Netherlands

Post Posted May 17th, 2003, 4:47 pm

That's strange. My earlier builds were RH9 too - you should have had a problem with them as well.

Of course, you don't have to stick with the milestone. guidob is making daily builds on Slackware 9. You can always grab his 20030517 build.

Return to Firefox Builds


Who is online

Users browsing this forum: No registered users and 5 guests