MozillaZine

The folder is being processed. Please wait until processing

Discussion of bugs in Mozilla Thunderbird
nunomira
 
Posts: 70
Joined: June 28th, 2004, 12:35 pm
Location: portugal

Post Posted September 15th, 2004, 9:28 am


The folder is being processed. Please wait until processing is complete to get messages.

This is the message I get everytime I open TB.

If I uncheck check for new messages at startup, I don't get this message, but I have to check my email manually.

StormFX
 
Posts: 178
Joined: August 12th, 2004, 5:54 pm

Post Posted September 15th, 2004, 10:01 am

Same here. It only happens if you have multiple accounts in the "Local Folders" group assigned to get messages at startup. Anyone know a work around? (Besides having only one account check at startup)

StormFX
 
Posts: 178
Joined: August 12th, 2004, 5:54 pm

Post Posted September 15th, 2004, 10:25 am

Update: This is quite weird. I have 7 accounts set up at the moment. I ONLY get the error if I have the second account I added set to receive mail at startup. I can set the others to get mail at startup and everything works fine.

Gerwin
 
Posts: 8
Joined: July 5th, 2004, 1:48 am
Location: Amsterdam

Post Posted September 15th, 2004, 10:47 am

Same here. It dissapears if I disable *all* spamfilters, so apparently TB tries to process moving messages to "local folder" and junk mail at the same time.
It only appears when I check all accounts at the same time.

cageyjames
 
Posts: 1
Joined: September 15th, 2004, 12:46 pm
Location: Arizona

Post Posted September 15th, 2004, 12:47 pm

I'm getting the message too and have the same setup as you guys.

StormFX
 
Posts: 178
Joined: August 12th, 2004, 5:54 pm

Post Posted September 15th, 2004, 4:24 pm


Gerwin
 
Posts: 8
Joined: July 5th, 2004, 1:48 am
Location: Amsterdam

Post Posted September 16th, 2004, 1:34 am

Storm FX wrote:http://forums.mozillazine.org/viewtopic.php?t=127500

No, doesn't help.

ke.han
 
Posts: 4
Joined: September 16th, 2004, 2:26 am

Post Posted September 16th, 2004, 4:23 am

I do not have any accounts set to check on startup and I am still having trouble. I cannot download any of my POP mail. I have no IMAP accounts.

StormFX
 
Posts: 178
Joined: August 12th, 2004, 5:54 pm

Post Posted September 16th, 2004, 9:01 am

Gerwin, try turning the automatic downloading of messages at startup off for all your accounts, then restart TBird and turn them on one by one, restarting it after each one. Wait for the first (default) account until last. An install all on another PC required me to do that, too.

clay ruby
 
Posts: 5
Joined: September 15th, 2004, 3:55 pm

Post Posted September 16th, 2004, 11:19 am

i tried this process with my single account. turned off 'downloading messages at startup', hit ok, restarted TBird, turned it back on, restarted again. Still no email.

Gerwin
 
Posts: 8
Joined: July 5th, 2004, 1:48 am
Location: Amsterdam

Post Posted September 16th, 2004, 2:48 pm

Storm FX wrote:Gerwin, try turning the automatic downloading of messages at startup off for all your accounts, then restart TBird and turn them on one by one, restarting it after each one. Wait for the first (default) account until last. An install all on another PC required me to do that, too.

Sorry, but it doesn't have anything to do with collectiing mail at startup, it does it when I collect mail from all mailboxes with "Get all new messages".
I allready tried all that you suggested, and with all possible combinations of filters on/off, junk mail controls off/on, and it happens as soon as 3 conditions are met:
1. Multiple mailaccounts gathered in 1 single mailbox.
2. Junk mail control switched on for 1 or more accounts.
3. You collect the mail for more than 1 account at the same time, either at startup or manually.
There are workarounds, like collecting mail for 1 account at the time, but this is just a bug, a genuine reproducable bug :)

StormFX
 
Posts: 178
Joined: August 12th, 2004, 5:54 pm

Post Posted September 17th, 2004, 12:39 am

Clay, your problem is slightly different. You might try seeing if setting the "Use Authentication" option helps.

The issue at hand does have something to do with collecting mail at startup, the Global Inbox and/or the collection/downloading of mail at startup. I even uninstalled and reinstalled Thunderbird a few times to test it. Perhaps it may be different per user, but what I did was this:

First I set up my pop accounts (7 of them). Each one was set to check for new mail messages at startup and to automatically download them and were all pointed to the Global Inbox. The primary had its own SMTP seperate from the rest. With it set up that way, I got the error. So then I set them all to be seperate from the Global Inbox, but still checking and downloading messages at start up with the primary on its own SMTP sttil. No error. When I then moved all of them to the Global Inbox except for the primary, which was still on its own SMTP, I still got no error. So I tried moving the primary to the Global Inbox and sure enough I got an error again. Then I set the primary to use the same SMTP as the others and left it in the Global Inbox. Restart - no error. There maybe something totally unrelated causing the error where certain conditions have to be met, but you are right in it being a reproducable error. Who knows WTH is going on :/

wintogreen
 
Posts: 3891
Joined: October 31st, 2003, 8:38 pm

Post Posted September 17th, 2004, 4:25 am

Storm FX wrote:The issue at hand does have something to do with collecting mail at startup, the Global Inbox and/or the collection/downloading of mail at startup.

This "folder being processed" error has been around for a long time, and there can be various causes. See this knowledge base article:
http://kb.mozillazine.org/index.phtml?t ... _Processed

In the case at hand, I think the issue is two or more accounts trying to write to the same mail file (e.g., the global Inbox in Local Folders) at the same time. When the Inbox is being written to by one account, another account can't write to the same Inbox at the same time because it's currently being "processed". I found this same problem when trying out a couple of the nightly builds prior to the 0.8 release.

It obviously needs to be fixed before the Global Inbox feature can be effective, but try to be patient if you can. T'bird is still very much in development -- the Global Inbox is a brand new feature and some of the kinks still need to be worked out.

bubblevision
 
Posts: 41
Joined: October 12th, 2003, 1:20 am

Post Posted September 17th, 2004, 5:25 am

I have the same problem. I have 6 email accounts all going into the global inbox. My primary account has a genuine SMTP address. My other 5 have SMTP set to "rubbish" to stop me accidentally replying using those addresses because I only want to reply from my primary account. By the way I'm also collecting email via Spampal and AVG virus scanner.

Although this should be fixed, in my case I would love to see an option in Tbird to only reply with one account. I think Outlook has this.

Xiabelle
 
Posts: 6
Joined: September 19th, 2004, 6:57 am

Post Posted September 19th, 2004, 7:11 am

I'm pretty sure, like wintogreen said, that the issue is caused by filters trying to process into the global inbox. I love the global inbox -- I hated having to go to all my email address boxes to confirm there was no useful mail in them.

I'm running about 6 email accounts with the global inbox too, and at least three of them have filters. However, not all do; I suspect part of it is the email trying to write to it at all while downloaded. At least two of them are purely spamtraps. I generally get the message no matter if I click on the get mail button or not.

Eudora did this for me by running all filters after email was downloaded and it utilized a global inbox. It would pull all the email in, then run filters; I remember noticing that Thunderbird ran them during download when I first got it. So I suppose that could be a bix, albeit a bit kludgy.

Return to Thunderbird Bugs


Who is online

Users browsing this forum: No registered users and 1 guest