MozillaZine

Got Touchpad scrolling working in Firebird!

Discussion of features in Mozilla Firefox
gids
 
Posts: 546
Joined: March 28th, 2003, 6:59 am
Location: Falmouth, UK

Post Posted June 12th, 2003, 1:17 pm

I was just browsing mozilla.org when I came across the solution to this problem, using the very cool touchpad scrolling feature of Synaptics Touchpad with Firebird.
Just paste the following in your
c:\program files\synaptics\syntp\syntpenh.ini file.
[Mozilla]
FC = "MozillaWindowClass"
SF = 0x10000000
SF |= 0x00004000
Or, update you driver version to the latest offered on the Synaptics
website.

tira
 
Posts: 1
Joined: December 7th, 2005, 6:37 am

Post Posted December 7th, 2005, 6:45 am

Symptom: Firefox 1.5 will not allow scrolling for Notebooks w/ synaptics touchpad

Solutions: Download the latest drivers (tried solution w/o it first), it is always a good thing

1. goto control panel-> Mouse (u should c the synaptic picture, if not select from dropdown list)
2. Select the Hardware Tab
3. Select Advanced Setting Tab
4. Make sure that "Wheel Detection" is set to "Look for Wheel" from the dropdown list.
5. Reboot

Good Luck

N.B. The driver version I'm using is V. 8.1.2.0 using a Gateway Conertible Notebook

Vexo
 
Posts: 1
Joined: January 26th, 2006, 11:36 am

Post Posted January 26th, 2006, 11:40 am

tira's solution works perfectly, for any other people with the same problem. Thanks much for posting it.

I have a (Brand new) Gateway Convertible, and had the same problem. For some reason they ship with an outdated driver. Despite what Synaptics' website warns, you will not lose any functionality by upgrading. Web browsing without scrolling is pure pain!

mcspewak
 
Posts: 1
Joined: March 24th, 2006, 6:48 am
Location: NYC

Post Posted March 24th, 2006, 6:53 am

gids wrote:I was just browsing mozilla.org when I came across the solution to this problem, using the very cool touchpad scrolling feature of Synaptics Touchpad with Firebird.
Just paste the following in your
c:\program files\synaptics\syntp\syntpenh.ini file.
[Mozilla]
FC = "MozillaWindowClass"
SF = 0x10000000
SF |= 0x00004000
Or, update you driver version to the latest offered on the Synaptics
website.


Thanks so much! This worked like a charm. I tried tira's solution first but there is no advanced settings in my version. I'm using version 6.3.3.0 because that's the last version that works well on my Toshiba Satellite S901. I had tried newer versions but lost the functionality of the special features on the touchpad. So if you are using an older version too, enter the above text in the ini file and restart!

krmathis

User avatar
 
Posts: 4699
Joined: May 24th, 2004, 9:40 pm
Location: Oslo, Norway

Post Posted March 24th, 2006, 9:42 am

gids. Any special reason you stay with Firebird (last build in january 2004)?
You will certainly have better luck with a recent Firefox build, either 1.5.0.1 or 1.0.7! ;)

Thumper

User avatar
 
Posts: 8037
Joined: November 4th, 2002, 5:42 pm
Location: Linlithgow, Scotland

Post Posted March 24th, 2006, 10:05 am

Probably because that post was made in 2003, if you look at the date on it.

- Chris

krmathis

User avatar
 
Posts: 4699
Joined: May 24th, 2004, 9:40 pm
Location: Oslo, Norway

Post Posted March 24th, 2006, 10:13 am

Thumper wrote:Probably because that post was made in 2003, if you look at the date on it.

- Chris
Ooops. :blush:
But grrrrr to those who bump such old treads!

Return to Firefox Features


Who is online

Users browsing this forum: No registered users and 1 guest