Making Firefox the default browser

User Help for Mozilla Firefox

Post Posted November 11th, 2004, 7:13 am

I checked the Firefox setting, which says it's "already" the default browser. But when I connect, IE still comes up as the default. How do I correct that?

Posts: 14
Joined: November 10th, 2004, 5:24 am

Post Posted November 11th, 2004, 7:20 am

How do you "connect"?..

do you open up the browser by clicking the blue "e" logo which links to Internet Explorer?..
Or do you just open up a page which you have on your desktop
Or do you open up "Run" and write the web-address?

If you click the blue "e", it will always open up Internet Explorer, as the icon is a shortcut, not to the internet, but to the browser which is installed on your computer.
To use Firefox as your default, and make it open up as the browser you want, you have to click on the shortcut icon that represents the Firefox browser (it has the appearance of the Firefox logo)

If you could supply us with more information, we would be able to help you easier


User avatar
Posts: 6318
Joined: August 2nd, 2004, 5:06 pm
Location: Raleigh, NC USA

Post Posted November 11th, 2004, 7:24 am

goldlizsts wrote:I checked the Firefox setting, which says it's "already" the default browser. But when I connect, IE still comes up as the default. How do I correct that?

Some ISP (Juno, Netzero) or software (window update, M$ Office, software update functions) are hardcoded to use IE as your browser ... but ... if this is not the case.....

to make firefox and thunderbird your defaults:

(1a) --- >>> for Firefox:
tools -> options -> general -> default browser -> place a check in the box to the left of "Firefox should check....." -> then press "check now" -> then "ok"
(1b) --- >>> for Thunderbird:
tools -> option -> general -> general setting -> place a check in the box to the left of "Use thunderbird as your default email ......" and /or -> place a check in the box to the left of "Use thunderbird as your default news ......" -> then "ok"

(2) --- Use "internet options" and/or winXP "set program access and defaults".

(3) --- In "internet options" make sure that the box does not have a check for "IE should check to see whether it is the default browser".

(4) --- If this does not fix the problem, see: Setting your Default Browser

FYI - The utility SetBrowser 1.4 - Set default Windows web browser A very simple program that lets you set the default web browser in Windows. Select the browser you want, and the program will modify the required registry settings. Can now also automatically locate the browser.

FYI - The utility DefaultBrowser allows you set the default web browser for your user profile in Windows XP, without affecting the other users.

To make IE or Outlook Express your default again:

- (a) Do (1) and uncheck the boxes in Firefox and/or Thunderbird.
- (b) To make IE your default Browser.... open IE: tools -> internet options -> programs -> place a check in the box to the left of "IE should check to see whether it is the default browser" -> ok
- (c) To make OE your default email ....... open OE: tools -> options -> General -> Default Messaging Programs -> choose email/newsreader -> make default -> ok

if that does not do it, go on to (2), (3) and (4) ....

later, Richard
Last edited by rtmjr50 on September 4th, 2005, 5:15 am, edited 9 times in total.
Rule #1: My computer is always right, the human is always the problem .. RULE #2: See Rule #1
using Win XP/SP2 (home) FF1.5.0.9 FF2.0.0.1 FF3a1 Tbird1.5.0.9 ==> Press for More Answers <==
No colours in sig please.


Post Posted November 11th, 2004, 7:24 am

goldlizsts wrote:I checked the Firefox setting, which says it's "already" the default browser. But when I connect, IE still comes up as the default. How do I correct that?

Go to 'start > Control Panel > Internet Options > Programs and at the bottom of that window UNCHECK the box 'IE should check it's the default browser on stsrt up'

Also, if you have WinXP go to 'Set Program Access and Defaults' bring the 'custom' pull down and click on Firefox as the 'default browser' - make sure FF is completely closed if doing this last setting.

Posts: 779
Joined: September 24th, 2004, 11:27 am

Post Posted November 11th, 2004, 7:25 am

Do you mean it is *opening* when you connect? My guess would be that you're connecting with some "connection" software provided by your ISP and that that automatically opens IE for you. That type of software tends to do that. If you had originally made the connection manually (say, by using the "Connect to the Internet" wizard) then no browser would open when you connected. Better way to do it - maybe you only connected to read mail, not to browse, after all.

If that's the scenario, uninstall the connection software and set the connection manually yourself - if it's possible to do that.

Otherwise, simply close IE after it opens, making the appropriate answer in the "Do you want to disconnect" dialog box, if it pops up.

Posts: 2
Joined: March 4th, 2005, 9:02 am

Post Posted March 4th, 2005, 9:36 am

I'm not sure I read all these posts correctly so I'm going to ask my question here and hopefully someone will see it and help a new user.
I use McAffee Virus Protection and had it set for automatic updates but with FF as the default browser it never works. Even if I tell it to check manually it doesn't work - says it requires IE. So how do you get automatic updates for Microsoft and other software like McAfee that require IE?


Post Posted July 10th, 2005, 5:59 pm

<bump>> Is it possible to update Mcafee antivirus w/ ff 1.0.4? ActiveX control that nds to be dwnlded or some s@$#? If i rem correctly i used older v. ff to update mcafee but now wont work w/ 1.0.4.


Post Posted July 11th, 2005, 6:17 pm

I've just switched to Firefox from IE, maily 'cause I use a Mac and IE doesn't seem to like Mac users all that much. I'd really like to make Firefox my default but all the advice I've found here doesn't seem to work for me, can anyone help. Is there a way for Mac users to make Firefox the default?


Post Posted July 11th, 2005, 6:24 pm

I've just discovered and downloaded RCDefaultApp which has fixed the problem, thanks.

Posts: 1167
Joined: March 5th, 2005, 6:55 pm
Location: California

Post Posted July 11th, 2005, 6:39 pm

You might find something in this thread for Mac users: ... 15&start=0
Windows 7 Home SP2


Post Posted January 25th, 2006, 3:26 pm

"From the Start button Firefox & Thunderbird are the 2 options below my user name but I then had a bash using 'Set Program Access and Defaults' and now when I click on a link it uses Firefox and not IE - problem sorted "

This was from a firefox 'Internet related' thread, regarding Firefox not being selected by some links. Thought it was sorted, and posted accordingly. Now I'm trying here because it's an XP program which I can't get to work... hope that's OK?

Signed on today, but a link took me to IE to view the page. Checked back on 'program access & defaults' and something had switched them back the way they were??

Worse still, now when I try and change them back, selecting Firefox and unselecting the make available tick on IE, the window pops up to say it's doing it, but stops less than half way through and just stalls until I press cancel

Tried a few times, both at once (F/fox & T'Bird) one at a time, not de-selecting OE or IE but nothing!!

What now

The original post had a screen shot attached to the last post here if it's any further help -

I've also read the help pages here and done the whole Assign the following filetypes to Mozilla or Firefox bit -

* URL:HyperText Transfer Protocol
* URL:HyperText Transfer Protocol with Privacy
* URL:File Transfer Protocol
* HTML File
* HTM File (optional)

But I'm still stuck??

Any other thoughts - sorry post is so long, trying to answer with all the info I can but a bit of a newbie and brand new to Firefox.



User avatar
Posts: 2
Joined: January 25th, 2006, 3:30 pm
Location: Glencoe, Highlands of Scotland

Post Posted January 25th, 2006, 3:35 pm

I am the 'guest' above (just registered) and thought a final paragraph might help...

As far as I can tell everything is now as it should be, but program access & defaults still won't play, and when I restared the system both Firefox & Thunderbird asked if they were to be the default browser/mail client despite the changed I made. Also if I open Firefox first I can't click on the mail icon - nothing happens - I have to do start / Thunderbird to get it going, and that used to be OK too?


User avatar
Posts: 2
Joined: January 25th, 2006, 3:30 pm
Location: Glencoe, Highlands of Scotland

Post Posted January 26th, 2006, 1:37 pm

Maybe I should have started a new thread... down on page 7 already?? What a busy forum!!


Post Posted October 5th, 2006, 8:26 pm

Is there anyway to edit the registry or something like that, and FORCE Juno to use Firefox?

Posts: 1
Joined: June 1st, 2010, 12:41 pm

Post Posted July 8th, 2010, 2:13 am

I don't know if this is the appropriate thread, but I wanted to alert to a serious problem with the Maxthon 2 brower in regard to the status as default browser.

For many years, Maxthon 2 was, in fact, my default browser. Over time, I had often switched between Firefox, Maxthon and Opera. Currently, Firefox is my default browser. But, I still like to have other browsers available for use and I try to keep them updated so that the installed version is the latest.

On the most recent update of Maxthon 2, I expected to see an installation option asking if I wanted Maxthon 2 to become the new default browser. I was surprised not to see this but found out afterward that it HAD become the default browser. I just did not see the hidden option. You have to select the not obvious option to "Customize" the installation to locate the check-box which must be unchecked to deselect the default browser option.

If only this were the only problem. I uninstalled Maxthon and repeated the installation unchecking the default browser option. To the extent that it did not become the default browser, it was successful. However, it still managed to dethrone Firefox from default browser status. I reset Firefox as default. And here is where it gets really insidious. URL links in my email client (The Bat) still got directed to the non-default browser Maxthon 2. I found the startup message from Maxthon 2 to be mocking in its tone asking if I wanted it to become the default, after it nonetheless managed to divert these URLs to itself. Firefox was still set as default browser. It just was not being invoked for URLs from email messages. I don't understand this. But, even if there is a workaround so that the URLs can be once again sent to Firefox, the actions of the Maxthon 2 to cause these URLs to be diverted during the Maxthon 2 installation is underhanded.

I recommend that Maxthon 2 be avoided. It does not play well with other browsers if it is not allowed to be the default.

Return to Firefox Support

Who is online

Users browsing this forum: Google [Bot] and 14 guests