MozillaZine

problems when I try to export my addressbook from MAS 1.7.5.

User Help for Mozilla Thunderbird
gagliaudo

User avatar
 
Posts: 45
Joined: June 26th, 2003, 1:58 am
Location: Italia

Post Posted December 23rd, 2004, 2:35 am

Dear Friends,
I have MAS 1.7.5. [Mozilla/5.0 (Windows; U; Windows NT 5.1; it-IT; rv:1.7.5) Gecko/20041217].
I have successfully imported in MAS Mail my TB 1.0 address book (ldif file); then I have tried to export my new MAS addressbook within MAS Mail folder
This is the result:
Image
is there anyone who can tell me what does this message mean ???
Thanks a lot !!!
Paolo :x-mas:
Last edited by gagliaudo on March 21st, 2005, 7:51 am, edited 1 time in total.
--
Paolo M. Grossholz
Mozilla Firefox 3.6.9, Mozilla Thunderbird 3.1.3, SeaMonkey 2.0.7, Open Office 3.2.1

Mike Novack
Guest
 

Post Posted December 23rd, 2004, 7:21 am

Unclear.

When you did the "export" command there were three things specified? A "which" address book and a "to" file name and a "fromat"? If only one or two, that might explain a "too few arguemnts" error.

Question --- why are you trying to do this? For what purpose are you exporting/importing between different versions of Mozilla "relatives". Usually you can move user data between just by copying files since they all use the same formats << note: you might have to FIRST create the association between name and file name giving you an empty file which you then overlay with the copy that has the data you want -- in other words, to bring over a non-default address book (an additional book you created yourself) you would first create a book of that name on the destination system and THEN copy over the corresponding file >>

beoenduser

User avatar
 
Posts: 276
Joined: November 26th, 2002, 2:50 pm

Post Posted December 29th, 2004, 10:12 am

I have Mozilla 1.7.5.
I too am having the same problem with the address book. All I did was to select Export from the tools menu and I automatically got that error message, Not Enough Arguments. There were no choices to specify File Format, To, nor which address book.

I'm trying to export my address book for backups. I used to be able to do this before Moz 1.7.5 but not now.

Is this some sort of bug?

shrink

User avatar
 
Posts: 226
Joined: August 2nd, 2004, 9:22 am
Location: Down the Shore

Post Posted December 29th, 2004, 5:27 pm

Same error message here!
alan
Alan B.

shrink

User avatar
 
Posts: 226
Joined: August 2nd, 2004, 9:22 am
Location: Down the Shore

Post Posted December 30th, 2004, 5:29 am

No one else?
UhOh
alan
Alan B.

Mike Novack
Guest
 

Post Posted December 30th, 2004, 7:49 am

I will repeat my question. That doesn't address the export problem, but WHY are you exporting? Why do you want the data in a file of DIFFERENT format than it is in right now?

Do you understand? Telling me "so I can have a backup" is not a sensible answer. The files in you directory ending with extension .mab are "mozilla address books" and just like any other file you can make copies of them (backups) wherever you please. < and then copy them back for a "restore" >

In fact, unless you are short of space on the backup device, you would be better off copying the entire .../Mozilla DATA directory (file folder) to the backup device and thus have a backup of ALL your Mozilla data in one fell swoop <takes several minutes for our montly backup but you don't have to sit there watching>

beoenduser

User avatar
 
Posts: 276
Joined: November 26th, 2002, 2:50 pm

Post Posted December 30th, 2004, 10:03 am

I need to export my address book as .csv so that another program like OpenOffice can read the file so I can use it for a database. Unfortunately, OpenOffice cannot read .mab nor .ldif as far as I can see but it does read .csv. Otherwise I'm going to have to retype all those 204 addresses by hand so that I can save it in a format that OpenOffice can read and I'd rather not have to do it that way.

I've also encountered problems with dragging and dropping some files for mozilla before and the import command worked much better for me.

What I don't understand is why was I able to export when I had Moz 1.7.3 but now that I have 1.7.5 I can't?

Mike Novack
Guest
 

Post Posted December 30th, 2004, 10:46 am

While it is possible "export" is broken in 1.7.5 more likely is that you are trying to do the export in exactly the same way as you did (and works) in 1.7.3 only the way you are supposed to do it for 1.7.5 has SOME possibly minor but critical difference.

Since I don't have 1.7.5 here I can't look at the help documentation under the topic of exporting address book data. Not meaning to embarrass anybody having this problem, but you looked, yes? Didn't simply assume that you were supposed to do EXACTLY what you did in 1.7.3. That assumption was initially OK (worth a first try) but once you had the error, no longer a good assumption.

beoenduser

User avatar
 
Posts: 276
Joined: November 26th, 2002, 2:50 pm

Post Posted December 30th, 2004, 11:19 am

Thank you very much for your reply.
In the help section under exporting address books it says:

"To export an address book, begin from the Address Book window:

1. Select the address book that you want to export.
2. Open the Tools menu, and choose Export.
3. In the Export Address Book dialog box, browse to the location where you want to save the address book file.
4. Choose the file format for the exported address book (.ldif, comma-separated, or tab-delimited).
5. Enter a name for the address book file. Be sure to include the appropriate file extension (.ldif, .csv, .tab, or .txt).
6. Click Save. "

I do not get a dialog box of any sort, I only get that error message as was mentioned earlier. I did everything the way they said to in the help file. So I can only assume it's broken somehow in this addition like you said it could be.

I hope this gets fixed in the next edition or that someone will be able to tell me how to turn it back on (if there's no incompatibility issues with this feature -- which is the only reason I can think of for it to be turned off).

I wonder if anyone reported this as a bug.

Guest
Guest
 

Post Posted December 30th, 2004, 12:24 pm


danielwang
 
Posts: 386
Joined: July 30th, 2003, 9:28 am

Post Posted December 30th, 2004, 1:22 pm

Nice bug link. Are you a QA?
mozilla.org is an volunteer-driven community. Its success depends on help from users like you. Please consider contributing to the good cause. -- danielwang@mozillanews.org

beoenduser

User avatar
 
Posts: 276
Joined: November 26th, 2002, 2:50 pm

Post Posted December 30th, 2004, 1:25 pm

Thanks!

shrink

User avatar
 
Posts: 226
Joined: August 2nd, 2004, 9:22 am
Location: Down the Shore

Post Posted December 30th, 2004, 1:43 pm

Anonymous wrote:https://bugzilla.mozilla.org/show_bug.cgi?id=271895


I followed the link but can't see the patch to download.
alan
Alan B.

Guest
Guest
 

Post Posted December 30th, 2004, 3:18 pm

danielwang wrote:Nice bug link. Are you a QA?


No, just someone else who encountered the bug; I just went ahead and searched bugzilla for it instead of just 'wondering'. :-)

beoenduser

User avatar
 
Posts: 276
Joined: November 26th, 2002, 2:50 pm

Post Posted December 30th, 2004, 4:59 pm

I tired searching bugzilla once...we just confused each other. :)

Return to Thunderbird Support


Who is online

Users browsing this forum: Google [Bot] and 4 guests