MozillaZine


Unofficial Win32 2003-08-19 optimised for P4/AthlonXP w/SSE

Discussion about official Mozilla Firefox builds
aebrahim
 
Posts: 1234
Joined: November 10th, 2002, 2:47 am
Location: Hong Kong

Post Posted August 19th, 2003, 5:41 am

I built Mozilla Firebird today from CVS with MSVC++ .NET 2003 using some optimisations for Pentium 4/Athlon XP as well as SSE optimisations. This build is not 100% identical to CVS, because I've changed a few lines in mozilla/configure.in and mozilla/configure, and I've also changed a few makefiles. I've also applied a somewhat dirty trick with my VS.NET 2003 install, where I'm using some libraries from VS.NET 2002. However, it's using the VS.NET 2003 compilers and linkers, so it should fully benefit from the new optimisations. I've posted the build here:

http://pryan.org/firebird/aebrahim/Mozi ... G7-SSE.zip (6.07MB - zip)
http://pryan.org/firebird/aebrahim/Mozi ... G7-SSE.exe (4.76MB - 7z sfx)

This build will work on processors that support the SSE instruction set ONLY.

You can find a copy of these builds (and my older builds) on pryan's mirror:
http://pryan.org/firebird/aebrahim
(I only have space for my latest builds on my webspace, so for older ones you will have to check the mirror. Thanks to pryan!)

My .mozconfig is as follows:

export MOZ_PHOENIX=1
mk_add_options MOZ_PHOENIX=1
ac_add_options --enable-crypto
ac_add_options --disable-tests
ac_add_options --disable-debug
ac_add_options --disable-mailnews
ac_add_options --disable-composer
ac_add_options --enable-optimize="-O1 -G7 -arch:SSE"
ac_add_options --disable-ldap
ac_add_options --enable-extensions=cookie,xml-rpc,xmlextras,p3p,pref,transformiix,universalchardet,typeaheadfind,webservices
ac_add_options --enable-static
ac_add_options --disable-shared

I've included a copy of my .mozconfig in the build folder itself. For more on what the O1 and G7 switches do see this link:
http://www.msdnaa.net/Resources/display.aspx?ResID=1972

If you're using this on an Athlon XP, and it doesn't work, you may need a BIOS update. I did a bit of research and I came up with these two links that might explain better:

http://mail-index.netbsd.org/port-i386/ ... /0014.html
http://mail-index.netbsd.org/port-i386/ ... /0018.html

It seems that sometimes motherboard code does not correctly detect SSE in Athlon XPs (even though all have it). So by updating the BIOS, you may get a fix for this problem. Its worked for at least one person.

JPS
 
Posts: 115
Joined: January 28th, 2003, 10:31 pm

Post Posted August 19th, 2003, 5:49 am

This will be up on mirror in about 2 minutes.
The mirror is here: http://copperdog.org/firebird/builds

Great build again - thanks aebrahim!

Two problems I have seen:
1) the forward and backward nav buttons disappear in non-default themes (very minor annoyance)
2) No vertical or horizontal scroll bars in non-default themes (bigger annoyance)
Last edited by JPS on August 19th, 2003, 7:27 am, edited 3 times in total.

ercan

User avatar
 
Posts: 54
Joined: May 30th, 2003, 1:23 pm
Location: Berlin | Cairo | Alexandria | Kayseri

Post Posted August 19th, 2003, 7:04 am

The "OK" Button in "Fonts & Colors" does not work. :-(

Skatz[i]

User avatar
 
Posts: 64
Joined: July 18th, 2003, 1:30 pm
Location: Good ol' Germany

Post Posted August 19th, 2003, 7:29 am

I can't add new Favorites cuz the Pulldown menu doesn't work (to choose a "folder")....
The buggiest build i've seen since a long time.

Skatz

edit: One of the best features seems to be gone - if u clicked on the bottom left corner in your FB u could choose wich theme (for the website that u r viewing right now) u want to choose - now it is gone, it is really gone or can i find it somewhere in my FB?!
Last edited by Skatz[i] on August 19th, 2003, 7:40 am, edited 1 time in total.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030919 Firebird/0.7

JPS
 
Posts: 115
Joined: January 28th, 2003, 10:31 pm

Post Posted August 19th, 2003, 7:31 am

Skatz[i]

Yep - I see that one as well. Might want to knock back to the 20030816 builds...

TeddyBerlin

User avatar
 
Posts: 340
Joined: August 10th, 2003, 9:53 am
Location: Berlin(Germany)

Post Posted August 19th, 2003, 7:34 am

This build don't work on my computer.
In TTLO:Mousewheel i became a XML-Parsing-Error.
I can't see the srollbar.
I can't add ne Favorits.
I reinstall the build 20030817.
Heinrich Witt

aebrahim
 
Posts: 1234
Joined: November 10th, 2002, 2:47 am
Location: Hong Kong

Post Posted August 19th, 2003, 7:55 am

Skatz[i] wrote:I can't add new Favorites cuz the Pulldown menu doesn't work (to choose a "folder")....
The buggiest build i've seen since a long time.

Skatz

edit: One of the best features seems to be gone - if u clicked on the bottom left corner in your FB u could choose wich theme (for the website that u r viewing right now) u want to choose - now it is gone, it is really gone or can i find it somewhere in my FB?!

Both WFM. The drop down menu works fine and I can add bookmarks in a folder, and also the alternate stylesheet selector WFM at http://texturizer.net/firebird and http://mozillazine.org . Maybe a new profile is in order?

Aye75
 
Posts: 4
Joined: August 19th, 2003, 8:25 am

Post Posted August 19th, 2003, 8:27 am

TeddyBerlin wrote:This build don't work on my computer.
In TTLO:Mousewheel i became a XML-Parsing-Error.
I can't see the srollbar.
I can't add ne Favorits.
I reinstall the build 20030817.
Heinrich Witt


I was experiencing the same thing....Until I noticed one thing... It's because of the themes

Try use the default one and everything is back to normal

JPS
 
Posts: 115
Joined: January 28th, 2003, 10:31 pm

Post Posted August 19th, 2003, 8:31 am

Much of this already on the radar:
http://bugzilla.mozilla.org/show_bug.cgi?id=216602

And yes, using default themes cures all woes on these latest builds

Skatz[i]

User avatar
 
Posts: 64
Joined: July 18th, 2003, 1:30 pm
Location: Good ol' Germany

Post Posted August 19th, 2003, 8:47 am

aebrahim wrote:
Skatz[i] wrote:I can't add new Favorites cuz the Pulldown menu doesn't work (to choose a "folder")....
The buggiest build i've seen since a long time.

Skatz

edit: One of the best features seems to be gone - if u clicked on the bottom left corner in your FB u could choose wich theme (for the website that u r viewing right now) u want to choose - now it is gone, it is really gone or can i find it somewhere in my FB?!

Both WFM. The drop down menu works fine and I can add bookmarks in a folder, and also the alternate stylesheet selector WFM at http://texturizer.net/firebird and http://mozillazine.org . Maybe a new profile is in order?


Hmm, ok will try it now

-Skatz

edit:
jep everything seems to be fine again :)
thx
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030919 Firebird/0.7

SilentJ
 
Posts: 251
Joined: November 8th, 2002, 6:42 am

Post Posted August 19th, 2003, 8:54 am

all working fine here, good stuff

JPS
 
Posts: 115
Joined: January 28th, 2003, 10:31 pm

Post Posted August 19th, 2003, 8:58 am

theboyjenkins
Are you using any non-default themes?

SilentJ
 
Posts: 251
Joined: November 8th, 2002, 6:42 am

Post Posted August 19th, 2003, 9:08 am

sorry, no, all working fine with the default theme is what i should of said :oops:

TeddyBerlin

User avatar
 
Posts: 340
Joined: August 10th, 2003, 9:53 am
Location: Berlin(Germany)

Post Posted August 19th, 2003, 9:18 am

Why the new Builds(20030818 + 20030819) not work with themes like pinball and with TTLO???
Heinrich Witt

SwampFan

User avatar
 
Posts: 178
Joined: February 25th, 2003, 9:40 am
Location: Atlanta, GA

Post Posted August 19th, 2003, 9:47 am

Appears as if the password manager is still not working correctly, although bug 216587 was fixed yesterday. Has the dialog box which appears when using multiple passwords been removed or is it also busted?

Return to Firefox Builds


Who is online

Users browsing this forum: No registered users and 0 guests