MozillaZine

attaching PDF sends it inline

User Help for Mozilla Thunderbird
kh
 
Posts: 5
Joined: April 23rd, 2004, 7:44 pm

Post Posted February 4th, 2005, 10:35 pm

I have a work colleague who uses Thunderbird on a MacOSX powerbook. When he attaches a PDF file Thunderbird marks it as a text/plain MIME type and does not encode it. The result is the file is sent as binary and Outlook among other programs barf. I imagine some mail servers will strip the high bits and do line wrapping. Maybe thunderbird wraps the line. Wrapping the lines for a binary file is a bad thing.

So my question is how to get his Thunderbird to recognise this is not a text file and encode it with base64 or some such.

Where does Thunderbird get it's MIME magic from?
Life is complex - It has real and imaginary parts.
Andrea Leistra (rec.arts.sf.written.Robert-jordan)

Guest
Guest
 

Post Posted February 5th, 2005, 9:58 am

Try these settings (either create/add them into user.js or use the aboutconfig extension at http://aboutconfig.mozdev.org ):
Code: Select all
user_pref("mail.content_disposition_type", 1);
user_pref("mail.file_attach_binary", true);


HTH....

kh
 
Posts: 5
Joined: April 23rd, 2004, 7:44 pm

Post Posted February 5th, 2005, 1:31 pm

Is there a reason why this is not the default?

Guest
Guest
 

Post Posted February 5th, 2005, 3:33 pm

In Mozilla Application Suite (not Thuderbird), this happened when an improper configuration appeared for PDFs (or any other file type) in the 'helper applications' in Preferences.

The problem was caused, at least sometimes, when a user would try to send attachments via Netscape or certain other webmail programs.

I'm not sure how that would relate to TB, but try looking to Tools >> Options >> Attachments. If you see an entry for PDF, delete it.

kh
 
Posts: 5
Joined: April 23rd, 2004, 7:44 pm

Post Posted February 5th, 2005, 6:01 pm

In my colleague's case there is no entry for PDFs. In my Thuderbird there is but my system handles attachments OK.

I just can't understand why you would ever want binary files inline, or any files really. If you want text you can cut and paste.

Also what is the difference between:

user_pref("mail.content_disposition_type", 1);
user_pref("mail.file_attach_binary", true);
and
user_pref("mail.inline_attachments", false);
user_pref("mail.content_disposition_type", 1);

Guest
Guest
 

Post Posted February 5th, 2005, 9:21 pm

The other Guest also has a point. The way I understand it is that TB looks at the mime-types to determine which are binary and which are textual. The settings above force it to treat everything as binary (even txt attachments will go as encoded!). As a sider - I think that also increases the size of the mail a little bit.

The content_disposition_type = 0/1 toggles whether attachments go inline or as attachments. I have no clue as to why the default for attachments is not attachment!

The third one - mail.inline_attachment is for viewing messages as opposed to sending them. This is the pref that gets changed when you use View>Display_Attachmnets_Inline.

HTH.....

guanxi
 
Posts: 399
Joined: April 6th, 2003, 11:15 am

Post Posted February 6th, 2005, 8:43 am

To the other Guest:

If you could create a brief Knowledge Base wiki page (see link in right column) regarding what you know about attachment settings, it would be a big help!

You'd only have to write an accurate, complete answer once, instead of every time someone asks; many people would find it on their own; and other support techs (or whatever we are) could provide the answer, even if they don't have your expertise, by pointing the user to your page.

To create a new wiki page, add a link on another wiki page (Thunderbird FAQs, Tips, and/or Issues), then just click the link.

michelleskdavis
 
Posts: 2
Joined: December 29th, 2004, 7:35 pm

Post Posted August 29th, 2005, 2:32 am

Hi all, I know this is an old post, but in case anyone is still having this problem (as we were) and the mods above don't help here are two hints:

First of all you need to put any of these changes in the user.js file (not the prefs.js file). If the user.js doesn't exist then you need to create it. This is because everytime you change your account settings it updates prefs.js and may remove your changes. This is implied but not stated above. For more information on user.js go to: http://www.mozilla.org/support/thunderbird/edit

Secondly despite this we still had problems, the pdfs were being attached as text/plain instead of application/pdf. This meant that many email programs put them inline instead of treating the attachment. The problem turned out to be in the mimeTypes.rdf file which had a definition set for pdf files as text/plain. It seems someone tried to open a pdf with Word and this caused Thunderbird to change the mime type for pdfs. Removing all definitions from this file for pdfs (making Thunderbird rely on the system mime type for pdfs) fixed the problem. For more information on editing this file (as you need to get it right) search the forum. There are several ways to do this. You can also change the name of this file (so it is there as a backup) and then just run Thunderbird, this will mean that you have to recreate all your file opening assocations but should fix the problem.

Guest
Guest
 

Post Posted November 11th, 2005, 8:31 am

thank you michelleskdavis... for me deleting the mimetypes.rdf file did the job :-)

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot] and 3 guests