MozillaZine

How to set enableIDN to false?

User Help for Mozilla Firefox
cviniciusm

User avatar
 
Posts: 9
Joined: February 7th, 2005, 9:13 am

Post Posted February 7th, 2005, 9:16 am

Hello,

the "Mozilla / Firefox / Camino IDN Spoofing Security Issue" (http://secunia.com/advisories/14163/) said to set enableIDN to false, how to do this, please?

TIA,
Vinicius.

Jack
 
Posts: 6859
Joined: December 26th, 2002, 4:53 pm

Post Posted February 7th, 2005, 9:18 am

cviniciusm wrote:Hello,

the "Mozilla / Firefox / Camino IDN Spoofing Security Issue" (http://secunia.com/advisories/14163/) said to set enableIDN to false, how to do this, please?

TIA,
Vinicius.


Don't bother. From everything I've read so far, the setting doesn't work. If and when you restart Firefox, the setting would still be set to false, but it's really back on and the vulnerability still works.
Last edited by Jack on February 7th, 2005, 9:20 am, edited 1 time in total.

Guest
Guest
 

Post Posted February 7th, 2005, 9:19 am

Type:
about:config
in the URL bar

Type:
IDN in the search bar

Double click the network.enableIDN line to change the value to false.

Guest
Guest
 

Post Posted February 7th, 2005, 9:21 am

Right you are. Well, that sucks.

cviniciusm

User avatar
 
Posts: 9
Joined: February 7th, 2005, 9:13 am

Post Posted February 7th, 2005, 9:27 am

Anonymous wrote:Type:
about:config
in the URL bar

Type:
IDN in the search bar

Double click the network.enableIDN line to change the value to false.
Thanks a lot.

My Firefox shows that network.enableIDN is false, but it continues to fail on the test.

Well, I did do my best,
Vinicius.

schapel
 
Posts: 3483
Joined: November 4th, 2002, 10:47 pm
Location: Ann Arbor, Michigan

Post Posted February 7th, 2005, 9:28 am

WFM after restart using a Mozilla nightly trunk build on Windows XP.

cviniciusm

User avatar
 
Posts: 9
Joined: February 7th, 2005, 9:13 am

Post Posted February 7th, 2005, 9:32 am

schapel wrote:WFM after restart using a Mozilla nightly trunk build on Windows XP.
Unfortunely, didn't WFM, my OS is Fedora Core 3.

schapel
 
Posts: 3483
Joined: November 4th, 2002, 10:47 pm
Location: Ann Arbor, Michigan

Post Posted February 7th, 2005, 9:33 am

cviniciusm wrote:Unfortunely, didn't WFM, my OS is Fedora Core 3.


Sounds like time to submit a bug report!

cviniciusm

User avatar
 
Posts: 9
Joined: February 7th, 2005, 9:13 am

Post Posted February 7th, 2005, 9:36 am

schapel wrote:
cviniciusm wrote:Unfortunely, didn't WFM, my OS is Fedora Core 3.


Sounds like time to submit a bug report!
My English is not good enough for this.

smith at canada com
Guest
 

Post Posted February 7th, 2005, 9:37 am

Is network.enableIDN being set to 'true' in every startup by an entry in all.js ?

Would this override a setting anywhere else?

Guest
Guest
 

Post Posted February 7th, 2005, 9:49 am

Anonymous wrote:Is network.enableIDN being set to 'true' in every startup by an entry in all.js ?

Would this override a setting anywhere else?
I don't have all.js only prefs.js.
I have restarted the Firefox, the network.enableIDN continues to false, and the test continues to fail.

hawkinsdale
 
Posts: 2
Joined: May 18th, 2004, 6:47 pm

Post Posted February 7th, 2005, 9:51 am

It's defnintely being reset to true for me. Dunno how. I'd sure like to know.

cviniciusm

User avatar
 
Posts: 9
Joined: February 7th, 2005, 9:13 am

Post Posted February 7th, 2005, 9:52 am

Anonymous wrote:
Anonymous wrote:Is network.enableIDN being set to 'true' in every startup by an entry in all.js ?

Would this override a setting anywhere else?
I don't have all.js only prefs.js.
I have restarted the Firefox, the network.enableIDN continues to false, and the test continues to fail.
This reply belongs to me, now I'm logged.

monkeyman
 
Posts: 1183
Joined: April 2nd, 2003, 11:07 pm

Post Posted February 7th, 2005, 9:53 am

smith at canada com wrote:Is network.enableIDN being set to 'true' in every startup by an entry in all.js ?

Would this override a setting anywhere else?


Changing the value in ..\Mozilla Firefox\greprefs\all.js didn't work.

schapel
 
Posts: 3483
Joined: November 4th, 2002, 10:47 pm
Location: Ann Arbor, Michigan

Post Posted February 7th, 2005, 9:54 am

The problem with setting network.enableIDN to false been reported as <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=281377">bug 281377</a>.

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 9 guests