MozillaZine

Email link starts profilemanager instead of Firefox new tab

User Help for Mozilla Firefox
steve1000
 
Posts: 73
Joined: February 3rd, 2005, 2:40 am
Location: Melbourne, Australia

Post Posted February 22nd, 2005, 2:11 pm

I tried using profilemanager to set up a second Firefox profile

[ For reasons why I tried this see:
http://forums.mozillazine.org/viewtopic.php?t=211311
http://forums.mozillazine.org/viewtopic.php?t=185983 ]

But having a second profile made Firefox much slower to load, so I used profilemanager again to delete the second profile. I now only have the original "default" profile.

But now:

with Firefox ALREADY running,
if I click on a web link in an email ,

Firefox does not, as before, start a new tab for that link; instead the profilemanager starts...offering the default Firefox profile that is already running.

In the profilemanager, if I click "Start Firefox", I am told I cannot because the default profile is already in use. If I exit the profilemanager, I have failed to open the link from the email.

It seems that by having used profile manager I have changed system behaviour so that profile manager now intervenes instead of having FF simply start a new tab for the link.

How do I reverse this change?
How do I stop profile manager intervening and go back to starting a new tab in Ff when I click on an email link?

Thanks for your help

steve1000
 
Posts: 73
Joined: February 3rd, 2005, 2:40 am
Location: Melbourne, Australia

Post Posted February 25th, 2005, 2:46 pm

steve1000 wrote:I tried using profilemanager to set up a second Firefox profile

[ For reasons why I tried this see:
http://forums.mozillazine.org/viewtopic.php?t=211311
http://forums.mozillazine.org/viewtopic.php?t=185983 ]

But having a second profile made Firefox much slower to load, so I used profilemanager again to delete the second profile. I now only have the original "default" profile.

But now:

with Firefox ALREADY running,
if I click on a web link in an email ,

Firefox does not, as before, start a new tab for that link; instead the profilemanager starts...offering the default Firefox profile that is already running.

In the profilemanager, if I click "Start Firefox", I am told I cannot because the default profile is already in use. If I exit the profilemanager, I have failed to open the link from the email.

It seems that by having used profile manager I have changed system behaviour so that profile manager now intervenes instead of having FF simply start a new tab for the link.

How do I reverse this change?
How do I stop profile manager intervening and go back to starting a new tab in Ff when I click on an email link?

Thanks for your help


Found it, with prompt from reading about profiles at:
http://the-edmeister.home.comcast.net/a ... sions.html

I had set up the new profile following the instructions at:
http://forums.mozillazine.org/viewtopic.php?t=185983

i.e.,
Go to Control Panel > System > Advanced > Environment Variables > System Variables > New
Variable Name: MOZ_NO_REMOTE
Variable Value: 1
Click OK, OK, OK

If you leave the MOZ_NO_REMOTE environment variable in the OS after you delete the second Ff profile, you get the changed system behaviour I describe above.

(Also the behaviour extends to Thunderbird email, if in Ff you click on a contact email address, instead of that loading an email composition page in Thunderbird, you get the profilemanager with the same impasse described above)

If you delete the MOZ_NO_REMOTE environment variable , the problems are all fixed.

steve1000
 
Posts: 73
Joined: February 3rd, 2005, 2:40 am
Location: Melbourne, Australia

Post Posted February 26th, 2005, 5:03 pm

I was contacted by Vectorspace, User Support Moderator. He pointed to:

http://forums.mozillazine.org/viewtopic.php?t=215734

This thread explains a method to set MOZ_NO_REMOTE, start an application with profile manager, then set MOZ_NO_REMOTE back, all with a single batch file/shortcut;

e.g., MOZ_NO_REMOTE=1 lets you start an application with the profilemanager:

@echo off
set MOZ_NO_REMOTE=1
start firefox.exe -p "profile name"
set MOZ_NO_REMOTE=0

A great virtue of this is that the change to MOZ_NO_REMOTE is transitory...so normal use goes back to the default profile without profilemanager intervening.

max1million
 
Posts: 2810
Joined: November 15th, 2004, 5:03 am

Post Posted September 28th, 2005, 5:51 am

steve1000 wrote:...with Firefox ALREADY running,
if I click on a web link in an email ,
Firefox does not, as before, start a new tab for that link; instead the profilemanager starts...

...Also the behaviour extends to Thunderbird email, if in Ff you click on a contact email address, instead of that loading an email composition page in Thunderbird, you get the profilemanager with the same impasse described above...

I was playing with Firefox and found if it is started with set MOZ_NO_REMOTE=1, when I try to open a .htm file it will start the profile manager, unless 1st instance was opened without set MOZ_NO_REMOTE=1. My guess it will do same in Thunderbird. Firefox is default browser.

In any case try opening 1st instance of both FF and TB normally without MOZ_NO_REMOTE=1. And MOZ_NO_REMOTE=1 is not set in "Environment Variable". The external program should then a call for browser/mail open in the 1st instance FF/TB.

fivestones
 
Posts: 0
Joined: July 26th, 2005, 11:09 pm

Post Posted September 13th, 2007, 5:44 pm

i'm having essentially this same problem. my story:

1. i made 4 or 5 profiles for different uses, using -no-remote in the shortcuts to these profiles so i could run them concurrently
2. the last one that i made (called 'MSU proxy') started being the default profile loaded when firefox was started (without any command line additions--this is the link that used to load the 'default' profile) (no profile manager was coming up)
2. i thought maybe there was some problem with having a space in the name so i renamed 'MSU proxy' to 'proxy'
3. still had the same problem so as a temporary fix i added "-p 'default' -no-remote" to my link that i wanted to be running the default profile
3. that fixed the problem, but i noticed that external links (from google talk instant messages) to web pages were still loading in the 'proxy' profile
4. i tried deleting the proxy profile to fix it, but then external links (or just typing "firefox" in a command line) then started loading the profile manager
5. i tried adding a system environment variable of moz_no_remote=1, but still had the same problem
6. i rebooted, still the same problem
7. deleted the moz_no_remote environment var
8. rebooted, still the same problem

so now, when i start my link, which still includes " -p default -no-remote" after firefox.exe, it works, but when i click a link from an external source, or when i type firefox into a cmd window, i get the profile manager. i want it to go to the 'default' profile. is there a way to choose which profile is loaded by default when firefox is run? i've looked around at a lot of threads online but can't find anything that tells me anything i haven't already tried. (as above)

running vista and firefox 2.0.0.6

the-edmeister

User avatar
 
Posts: 32205
Joined: February 25th, 2003, 12:51 am
Location: Chicago, IL, USA

Post Posted September 13th, 2007, 7:40 pm

A. You are using old information - this thread is from 2005. If you read my webpage completely you'll see that information is for older versions of Firefox - Firefox 2.0 has the new -no-remote Command Line parameter; forget about using the MOZ_NO_REMOTE Environment Variable, that isn't necessary any longer and may screw things up.
B. Open the profiles.ini file in a Text Editor and edit that file to make the "default" Profile the one with the line that says Default=1 as the last line for that Profile.


Ed
A mind is a terrible thing to waste. Mine has wandered off and I'm out looking for it.

fivestones
 
Posts: 0
Joined: July 26th, 2005, 11:09 pm

Post Posted September 13th, 2007, 8:15 pm

yey! it worked perfectly. thanks a lot for the help :-)

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot] and 8 guests