MozillaZine

firefox freezes for 10 seconds at a time

User Help for Mozilla Firefox
plafee
 
Posts: 2
Joined: March 5th, 2005, 7:39 pm

Post Posted March 5th, 2005, 7:51 pm

When I start firefox 1.0 or 1.0.1 it freezes (only firefox I can work in any other program) after few seconds it unfreezes only to freeze again in a short while
My system p4 intel 3 giga wxp pro
If I force it to close with winxp I get the following error to be sent to microsoft:
szAppName : firefox.exe szAppVer : 1.0.0.0 szModName : hungapp
szModVer : 0.0.0.0 offset : 00000000
I would really like to solve this problem IE really sucks.
Many thanks in advance

Guest
Guest
 

Post Posted March 6th, 2005, 1:31 pm

Yup - I get exactly the same thing with both firefox 1.0.1 and 1.0. My system: p4 intel MSI 865PE mboard, 512meg RAM, WinXP home - identical error message as above. Same thing with Netscape bizarrely, but IE works fine :-(

venus_de_mpls

User avatar
 
Posts: 1059
Joined: December 23rd, 2004, 3:43 pm
Location: Minneapolis, MN, USA, Earth

Post Posted March 6th, 2005, 1:44 pm

Have you checked out the sticky at the top of the forum? http://forums.mozillazine.org/viewtopic.php?t=225310
Win XP Pro SP1
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Thunderbird version 2.0.0.0 (20070326)

Guest
Guest
 

Post Posted March 6th, 2005, 2:14 pm

Thanks, but I've tried that thread and nothing there makes a difference, much the same experience as the last people on that thread. Presumably there must be some local setting problem as I've got it working perfectly fine on another p4 and on a pIII too ...

Jadugar
 
Posts: 1774
Joined: April 18th, 2004, 3:27 pm

Post Posted March 6th, 2005, 2:27 pm

Try reading this, especially the last few pages which contain a few posts by me:

http://forums.mozillazine.org/viewtopic ... 15&start=0

Guest
Guest
 

Post Posted March 6th, 2005, 4:09 pm

Brilliant! That's precisely the problem. In short, I'd done a new build with a P4 3.0Mhz Prescott processor - all was well until at some point I turned on hyperthreading and subsequently Firefox went bad. Setting it to run on one processor alone stopped the freezing. Many thanks Jadugar!

The relevant bit is on http://forums.mozillazine.org/viewtopic ... 5&start=45

Jadugar
 
Posts: 1774
Joined: April 18th, 2004, 3:27 pm

Post Posted March 6th, 2005, 8:06 pm

Your Welcome. I just happened upon this solution to another program (non firefox) when HT tech first came out as I was considering upgrading my computer and was, therefore, trying to read up on everything HT and ended up not upgrading. Hopefully this will help others as well.

plafee
 
Posts: 2
Joined: March 5th, 2005, 7:39 pm

Post Posted March 10th, 2005, 8:05 pm

Many thanks
The problem in my computer was Hypertading if any of you have ff and HT procesors and experience this problem this should fix it.
you guys are the greatest!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Quote from other tread:
i fixed my problem, it was the result of hyperthreading. this thread was a lot of help:
http://forums.mozillazine.org/viewtopic.php?t=152545

i used imagecfg to permanently set firefox's processor affinity to cpu0. here's a quick way to see if you're having the same problem:

hit CTL+ALT+DEL while running firefox to open up the task manager.
select the "Processes" tab.
right click "firefox.exe" and select "set affinity".
if there is more than one processor select, set the affinity to a single processor.
see if firefox runs without freezing.

if that fixes your problems temporarily, then google "download imagecfg.exe". quit firefox and copy imagecfg to your imagecfg to C:\WINDOWS\system32. open up a cmd window and type:

imagecfg -u 0x1 "C:\Program Files\Mozilla Firefox\firefox.exe"

then

imagecfg -a 0x1 "C:\Program Files\Mozilla Firefox\firefox.exe"

this should allow firefox to retain its processor affinity.

Guest
Guest
 

Post Posted March 11th, 2005, 1:53 am

seems the culprit is the prescott, I have (or had) the same problem and it was after I got a p4 3.0 prescott.

drhaze
 
Posts: 80
Joined: April 2nd, 2005, 7:57 am

Post Posted April 7th, 2005, 4:50 pm

http://forums.mozillazine.org/viewtopic.php?t=247580
the problem with the prescott's and the hyperthreading is a bios microcode problem.
the newest E0 stepping is not supported by many motherboards. maybe even d0
i have been on the phone with intel and abit.. and it's definately bios!
the prescott is not flawed it's your bios!
it can be fixed it's not firefox and this affinty 0 is just a temp fix. i have been on their backs. abit says new bios in a week or so

Nechasin
 
Posts: 6
Joined: April 13th, 2005, 6:50 pm

Post Posted April 13th, 2005, 7:14 pm

MSI motherboards do have a Bios update that fixes the problem.

Guest
Guest
 

Post Posted April 14th, 2005, 3:29 pm

still having the same problem after bios update, and seting affinity using imagecfg

Guest
Guest
 

Post Posted May 13th, 2005, 12:06 pm

thank you Jadugar! you solved my problem too!

btw, shouldn't this thread be sticky'ed?

byez
logiq

craigevil

User avatar
 
Posts: 3102
Joined: February 20th, 2005, 2:12 pm
Location: OZ

Post Posted May 23rd, 2005, 4:11 pm

Hyperthreading P4 causing Firefox to Freeze:
On some systems with an Hyper Threading CPU (Pentium 4 for example), Firefox will freeze.

This workaround is recommended:
1.When Firefox is started,launch the Windows Task Manager (press CTRL+ALT+DEL,
or right click the clock display on the Windows Taskbar and select Task Manager)
2.Select the process tab
3.Locate and right-click on the Firefox process
4.Select the set affinity option from the popup menu
5.Uncheck CPU 1 and validate with OK.
6.You can go back to Firefox.
It is essential to change this affinity setting before loading Firefox.

If that fixes your problems temporarily, Then you need to download "ImageCFG.exe".
Quit firefox and copy imagecfg to C:\WINDOWS\system32. Open up a cmd window and type:
imagecfg -u 0x1 "C:\Program Files\Mozilla Firefox\firefox.exe" then
imagecfg -a 0x1 "C:\Program Files\Mozilla Firefox\firefox.exe"
this should allow firefox to retain its processor affinity.

Another workaround is to completely disable Hyper Threading from your motherboard BIOS settings.
Make sure to consult your motherboard user's manual to change its settings.

cgm707
 
Posts: 270
Joined: October 18th, 2004, 9:54 am

Post Posted June 13th, 2005, 8:42 am

Are there instructions for us non-technical users? My browser has slowed down considerably.

Chip

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot] and 9 guests