MozillaZine


aebrahim: W32 2003-09-18 optimised for P3/P4/Athlon/AthlonXP

Discussion about official Mozilla Firefox builds
aebrahim
 
Posts: 1234
Joined: November 10th, 2002, 2:47 am
Location: Hong Kong

Post Posted September 18th, 2003, 5:35 am

I built Mozilla Firebird today from CVS with MSVC++ .NET 2003 using some optimisations. These builds are not 100% identical to CVS, because I've changed a few lines in mozilla/configure.in and mozilla/configure, and I've also changed a few makefiles. I've also applied a somewhat dirty trick with my VS.NET 2003 install, where I'm using some libraries from VS.NET 2002. However, it's using the VS.NET 2003 compilers and linkers, so it should fully benefit from the new optimisations. I've posted the builds here:

Optimised for Pentium 4, Pentium M and Celeron 1.7GHz+ with SSE2 (-O1 -G7 -arch:SSE2):
http://pryan.org/firebird/aebrahim/Mozi ... 7-SSE2.zip (6.04MB - zip)
http://pryan.org/firebird/aebrahim/Mozi ... 7-SSE2.exe (4.74MB - 7z sfx)
The above build will work on Pentium 4, Pentium M and Celeron 1.7 GHz and above systems ONLY.

Optimised for Athlon XP and some newer Durons with SSE (-O1 -G7 -arch:SSE):
http://pryan.org/firebird/aebrahim/Mozi ... G7-SSE.zip (6.04MB - zip)
http://pryan.org/firebird/aebrahim/Mozi ... G7-SSE.exe (4.74MB - 7z sfx)
The above build will work on systems that support the SSE instruction set ONLY.

Optimised for Pentium III and Pentium III based Celerons with SSE (-O1 -G6 -arch:SSE):
http://pryan.org/firebird/aebrahim/Mozi ... G6-SSE.zip (6.04MB - zip)
http://pryan.org/firebird/aebrahim/Mozi ... G6-SSE.exe (4.75MB - 7z sfx)
The above build will work on systems that support the SSE instruction set ONLY.

Optimised for non-SSE Athlons (-O1 -G7):
http://pryan.org/firebird/aebrahim/Mozi ... -O1-G7.zip (6.04MB - zip)
http://pryan.org/firebird/aebrahim/Mozi ... -O1-G7.exe (4.74MB - 7z sfx)

You can find a copy of these builds (and my older builds) on pryan's mirror:
http://pryan.org/firebird/aebrahim
(I only have space for my latest builds on my webspace, so for older ones you will have to check the mirror. Thanks pryan!)

My .mozconfig is as follows:

export MOZ_PHOENIX=1
mk_add_options MOZ_PHOENIX=1
ac_add_options --enable-crypto
ac_add_options --disable-tests
ac_add_options --disable-debug
ac_add_options --disable-mailnews
ac_add_options --disable-composer
ac_add_options --enable-optimize="see build info"
ac_add_options --disable-ldap
ac_add_options --enable-extensions=cookie,xml-rpc,xmlextras,p3p,pref,transformiix,universalchardet,typeaheadfind,webservices
ac_add_options --enable-static
ac_add_options --disable-shared
ac_add_options --disable-profilesharing
ac_add_options --disable-installer

I've included a copy of my .mozconfig in the build folder itself. For more on what the optimisation switches do see this link:
http://www.msdnaa.net/Resources/display.aspx?ResID=1972

Zandramas

User avatar
 
Posts: 13
Joined: July 23rd, 2003, 7:12 pm

Post Posted September 18th, 2003, 5:45 am

Welcome back man!!! I was in withdrawl. But a new SSE2 build has surfaced....YAHOO!! :)

sharkius

User avatar
 
Posts: 2664
Joined: May 26th, 2003, 6:20 pm
Location: PA, USA

Post Posted September 18th, 2003, 6:06 am

yay! I've been waiting for another aebrahim build. Always love em. Great to see you back!
Das beste für die Leute. Das beste für die Masse. Das beste für die Welt.
<a href="http://www.sharkshack.tk">The Shark Shack</a>
My butt is lumpy. How 'bout yours?

Old Nehemoth
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted September 18th, 2003, 6:08 am

sharkius wrote:yay! I've been waiting for another aebrahim build. Always love em. Great to see you back!



me tooo

RivanG
 
Posts: 71
Joined: April 16th, 2003, 7:52 am
Location: Elkview, WV

Post Posted September 18th, 2003, 6:11 am

Was looking forward to another aebrahim build, but I am on a proxy server at this office so I am seeing the proxy bug that appeared in the 091703 Official build...

http://bugzilla.mozilla.org/show_bug.cgi?id=219456

so I am reverting back to 091603 here at the office.

Welcome back Aebrahim...

lwells

User avatar
 
Posts: 33
Joined: August 8th, 2003, 8:12 am
Location: Sydney.Au

Post Posted September 18th, 2003, 6:18 am

These builds are like crack -- highly addictive! :D

Welcome back aebrahim, your hard work has been sorely missed!

Cheers,
Lucien.

Skatz[i]

User avatar
 
Posts: 64
Joined: July 18th, 2003, 1:30 pm
Location: Good ol' Germany

Post Posted September 18th, 2003, 6:36 am

welcome back aebrahim
Your builds are always great and i "love" them :)

-Skatz

edit: Bug 219150 seems to be still there - this suxx hard... :(
Last edited by Skatz[i] on September 18th, 2003, 8:16 am, edited 1 time in total.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030919 Firebird/0.7

hussam
 
Posts: 616
Joined: August 22nd, 2003, 11:49 am

Post Posted September 18th, 2003, 7:34 am

RivanG wrote:Was looking forward to another aebrahim build, but I am on a proxy server at this office so I am seeing the proxy bug that appeared in the 091703 Official build...

http://bugzilla.mozilla.org/show_bug.cgi?id=219456

so I am reverting back to 091603 here at the office.

Welcome back Aebrahim...



I guess it's back to 091603 for me too. It's my home PC but i have a cable modem so i'm using a proxy. Hope they fix that soon.

Archangel

User avatar
 
Posts: 73
Joined: August 16th, 2003, 9:35 pm
Location: Texas, USA

Post Posted September 18th, 2003, 7:36 am

lwells wrote:These builds are like crack -- highly addictive!


Maybe even more so, all I know is that I was in desparate need of a fix. Thanks Aebrahim!!! Man, I'm so glad you're back. So far, no problems with this build.

alanjstr
Moderator

User avatar
 
Posts: 9100
Joined: November 5th, 2002, 4:43 pm
Location: Anywhere but here

Post Posted September 18th, 2003, 7:38 am

How about including Chatzilla, Venkman, DOMI, and Calendar once a week? Wait, then this would just be Mozilla :-D
Former UMO Admin, Former MozillaZine General Mod
I am rarely on mozillaZine, so please do not send me a private message.
My Old Firefox config files

pdzierza
 
Posts: 4
Joined: September 18th, 2003, 8:01 am

Post Posted September 18th, 2003, 8:11 am

I found that mouse gestures options window is broken. It just displays this text instead of options:

--
XML Parsing Error: undefined entity
Location: chrome://mozgest/content/pref/pref-mozgest.xul
Line Number 51, Column 1:
<page xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"
--

and this was in your previous build 20030903 too.

works fine in official 0.6.1

bloodfish
 
Posts: 1
Joined: September 18th, 2003, 8:16 am

Post Posted September 18th, 2003, 8:20 am

This build wouldn't work on my P4 SSE2. I have a Toshiba Satelllite P25-S607 P4 2.8 GHz. The application would load, but would not display any sites. I did get one error message when I tried to access a site that said I needed to install the PSM (Personal Security Manager). I had to reload another build to get everything working again... :cry: All of your earlier builds that I installed have worked great.

My Yute
 
Posts: 895
Joined: June 5th, 2003, 1:19 am
Location: Kingston, Jamaica

Post Posted September 18th, 2003, 8:35 am

pdzierza wrote:I found that mouse gestures options window is broken. It just displays this text instead of options:

--
XML Parsing Error: undefined entity
Location: chrome://mozgest/content/pref/pref-mozgest.xul
Line Number 51, Column 1:
<page xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"
--

and this was in your previous build 20030903 too.

works fine in official 0.6.1


It's been broken for a while now. If you use an existing proflie your options will carry over, if not copy the mousegestures.rdf file from your profile folder to get ur existing settings back.

Kasteo

User avatar
 
Posts: 670
Joined: August 24th, 2003, 9:16 am
Location: Thailand

Post Posted September 18th, 2003, 8:37 am

Using PIII Optimized.... work wonder. Thanks.

alanjstr
Moderator

User avatar
 
Posts: 9100
Joined: November 5th, 2002, 4:43 pm
Location: Anywhere but here

Post Posted September 18th, 2003, 8:44 am

bloodfish wrote:This build wouldn't work on my P4 SSE2. I have a Toshiba Satelllite P25-S607 P4 2.8 GHz. The application would load, but would not display any sites. I did get one error message when I tried to access a site that said I needed to install the PSM (Personal Security Manager). I had to reload another build to get everything working again... :cry: All of your earlier builds that I installed have worked great.


ac_add_options --enable-crypto
should have included the appropriate modules.
Former UMO Admin, Former MozillaZine General Mod
I am rarely on mozillaZine, so please do not send me a private message.
My Old Firefox config files

Return to Firefox Builds


Who is online

Users browsing this forum: No registered users and 0 guests