MozillaZine


Unofficial 2003-09-19 (Linux; XFT+GTK2; P4/SSE)

Discussion about official Mozilla Firefox builds
daihard
Folder@Home

User avatar
 
Posts: 16633
Joined: November 17th, 2002, 6:27 pm
Location: Lynnwood, WA

Post Posted September 19th, 2003, 2:29 pm

Two versions are available on http://pryan.org/firebird/daihard for download. Requires PIII or newer processor w/ SSE support.

1. non-XFT, GTK1.2 build
Platform: Red Hat 7.3
Compiler: GCC 3.2.3
GLIBC: 2.2.5
Vendor Comment: "daihard; optimized for P4/SSE"

2. XFT+GTK2 build
Platform: Red Hat 8
Compiler: GCC 3.2
GLIBC: 2.3.2
Vendor Comment: "daihard; XFT+GTK2; optimized for P4/SSE"
Kubuntu 8.04 (kernel 2.6.24-25-generic) / KDE 3.5.10
CentOS 4.8 (kernel 2.6.9-78.0.22.ELsmp) / KDE 3.5.10
Mac OS X 10.6.1 (Snow Leopard) / iPhone 3GS (32GB black)

Benjamin Lebsanft
 
Posts: 31
Joined: November 9th, 2002, 4:04 am

Post Posted September 20th, 2003, 3:08 am

is it just me or is the location bar inaccessible ? i can't write adresses into it as well as i can't set the startpage, cache amount etc. all is tiny, hard too be seen at all

Schizoid
 
Posts: 26
Joined: August 5th, 2003, 6:20 pm

Post Posted September 20th, 2003, 9:11 am

I just installed the XFT+GTK2 SSE build and it is wonderful as usual.

One thing that is a bit odd though is when I am at about:config changes I make do not appear until after I refresh the page. So if I change a value from false to true it will still say false and will not be bold until I refresh the page.

So the values do get changed, it just doesn't look like it at first.

I have to admit the build I had before this was your 9/9 build so for all I know this is an old porblem but it is not listed on http://www.squarefree.com/burningedge/ as far as I can tell.

daihard
Folder@Home

User avatar
 
Posts: 16633
Joined: November 17th, 2002, 6:27 pm
Location: Lynnwood, WA

Post Posted September 20th, 2003, 11:02 am

Schizoid wrote:One thing that is a bit odd though is when I am at about:config changes I make do not appear until after I refresh the page. So if I change a value from false to true it will still say false and will not be bold until I refresh the page.

So the values do get changed, it just doesn't look like it at first.

I have to admit the build I had before this was your 9/9 build so for all I know this is an old porblem but it is not listed on http://www.squarefree.com/burningedge/ as far as I can tell.

Thank you for using my build. I get the same problem using my non-XFT 2003-09-19 build. The value doesn't change on the screen until I refresh. I will see if the official build exhibits the same problem.

Dai
Kubuntu 8.04 (kernel 2.6.24-25-generic) / KDE 3.5.10
CentOS 4.8 (kernel 2.6.9-78.0.22.ELsmp) / KDE 3.5.10
Mac OS X 10.6.1 (Snow Leopard) / iPhone 3GS (32GB black)

drdanny_orig

User avatar
 
Posts: 12
Joined: April 6th, 2003, 3:46 pm

Post Posted September 20th, 2003, 3:02 pm

Benjamin Lebsanft wrote:is it just me or is the location bar inaccessible ? i can't write adresses into it as well as i can't set the startpage, cache amount etc. all is tiny, hard too be seen at all
<br>I think it's just you.
WFM, in other words.

daihard
Folder@Home

User avatar
 
Posts: 16633
Joined: November 17th, 2002, 6:27 pm
Location: Lynnwood, WA

Post Posted September 20th, 2003, 3:14 pm

Benjamin Lebsanft wrote:is it just me or is the location bar inaccessible ? i can't write adresses into it as well as i can't set the startpage, cache amount etc. all is tiny, hard too be seen at all

Are you using the XFT+GTK2 build or the other?
Kubuntu 8.04 (kernel 2.6.24-25-generic) / KDE 3.5.10
CentOS 4.8 (kernel 2.6.9-78.0.22.ELsmp) / KDE 3.5.10
Mac OS X 10.6.1 (Snow Leopard) / iPhone 3GS (32GB black)

edcatmur

User avatar
 
Posts: 88
Joined: November 12th, 2002, 1:42 pm

Post Posted September 20th, 2003, 5:17 pm

Schizoid wrote:When I am at about:config changes I make do not appear until after I refresh the page. So if I change a value from false to true it will still say false and will not be bold until I refresh the page.

So the values do get changed, it just doesn't look like it at first.

Indeed... why haven't I noticed this yet?

I've tracked it to between 2003091601 and 2003091707 (both BST timezone - UTC+01:00); if you want to confirm this both builds are available at http://catmur.co.uk/downloads/mozilla/ as tar.bz2 GTK2+XFT.

I'll search Bugzilla and Bonsai.

edcatmur

User avatar
 
Posts: 88
Joined: November 12th, 2002, 1:42 pm

Post Posted September 20th, 2003, 5:22 pm


Benjamin Lebsanft
 
Posts: 31
Joined: November 9th, 2002, 4:04 am

Post Posted September 20th, 2003, 11:08 pm

Sorry for such a lousy bugreport :)

I'm using mdk9.2rc2 and the XFT+GTK2 build. I think it worked some time ago, maybe the problem is rc2. I'll have to wait until 9.2 final is released to see if the bug persists. Deleting my profile doesn't help either.

edit:
After deleting my MF folder AND my old profile everything is working now. Strange but good :D

daihard
Folder@Home

User avatar
 
Posts: 16633
Joined: November 17th, 2002, 6:27 pm
Location: Lynnwood, WA

Post Posted September 20th, 2003, 11:59 pm


Thanks! I've CC'ed myself.
Kubuntu 8.04 (kernel 2.6.24-25-generic) / KDE 3.5.10
CentOS 4.8 (kernel 2.6.9-78.0.22.ELsmp) / KDE 3.5.10
Mac OS X 10.6.1 (Snow Leopard) / iPhone 3GS (32GB black)

Schizoid
 
Posts: 26
Joined: August 5th, 2003, 6:20 pm

Post Posted September 21st, 2003, 2:49 pm

What is the latest nightly that still has working java in linux btw?

daihard
Folder@Home

User avatar
 
Posts: 16633
Joined: November 17th, 2002, 6:27 pm
Location: Lynnwood, WA

Post Posted September 21st, 2003, 5:23 pm

Schizoid wrote:What is the latest nightly that still has working java in linux btw?

Since when has it been broken? Java 1.4.2 works fine with my 2003-09-20 build.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a) Gecko/20030920 Firebird/0.7+ (daihard; optimized for P4/SSE)
Kubuntu 8.04 (kernel 2.6.24-25-generic) / KDE 3.5.10
CentOS 4.8 (kernel 2.6.9-78.0.22.ELsmp) / KDE 3.5.10
Mac OS X 10.6.1 (Snow Leopard) / iPhone 3GS (32GB black)

Schizoid
 
Posts: 26
Joined: August 5th, 2003, 6:20 pm

Post Posted September 21st, 2003, 5:32 pm

:confused:

2003-09-20 Builds
Continued regression: 219705 - Java crashes on Linux

From http://www.squarefree.com/burningedge/

The moment I try to load a page with java Firebird is toast.

Java(TM) Plug-in 1.4.2-b28

File name: libjavaplugin_oji.so
Java(TM) Plug-in 1.4.2

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a) Gecko/20030919 Firebird/0.7+ (daihard; XFT+GTK2; optimized for P4/SSE)

daihard
Folder@Home

User avatar
 
Posts: 16633
Joined: November 17th, 2002, 6:27 pm
Location: Lynnwood, WA

Post Posted September 21st, 2003, 9:03 pm

Schizoid wrote:The moment I try to load a page with java Firebird is toast.

Java(TM) Plug-in 1.4.2-b28

File name: libjavaplugin_oji.so
Java(TM) Plug-in 1.4.2

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a) Gecko/20030919 Firebird/0.7+ (daihard; XFT+GTK2; optimized for P4/SSE)

Okay, my XFT+GTK2 build. Does the non-XFT build exhibit the same problem with Java over there? I'll look at the Burning Edge to see what they have to say.

[EDIT] So it's not specific to my build... feels a bit better. :) Bug 219705 says Firebird crashes on this site, but it works fine for me. :?:
Kubuntu 8.04 (kernel 2.6.24-25-generic) / KDE 3.5.10
CentOS 4.8 (kernel 2.6.9-78.0.22.ELsmp) / KDE 3.5.10
Mac OS X 10.6.1 (Snow Leopard) / iPhone 3GS (32GB black)

Schizoid
 
Posts: 26
Joined: August 5th, 2003, 6:20 pm

Post Posted September 22nd, 2003, 4:26 am

yay firebird no longer renders my personal web site! woo hoo!

http://www.patbert.com

I have a dirty little trick in there to center the layer but it never seemed to care before. Oh well....

Worked with the 9/9 build I had before. Glad I kept a backup!

Return to Firefox Builds


Who is online

Users browsing this forum: No registered users and 4 guests