Summary of Can't Connect/timeout Solutions

User Help for Mozilla Firefox

User avatar
Posts: 3103
Joined: February 20th, 2005, 2:12 pm
Location: OZ

Post Posted April 28th, 2005, 5:37 pm

This thread addresses the "This document contains no data" and "The connection was refused when attempting to contact..." issues.

There are many fixes, here are the ones I found going through the 40+ pages. Most have been summarized before. I do not take any credit for any of the answers/post. Thanks goes to the people that found the answers.

There appear to be two separate issues: Firewalls and DNS

I. A software firewall is installed but it isn't properly configured to allow Fx access to the Internet. .

Not exactly sure what a Firewall is?
"A personal firewall is traditionally a piece of software installed on an end-user's PC which controls communications to and from the user's PC, permitting or denying communications based on a Security Policy."

How do I know if I have a firewall:
"If you're using a reasonably recent Windows version, you probably already know Microsoft has included a personal firewall as part of its systems package. If you have upgraded to Service Pack 2, you've noticed that the firewall is turned on by default.<b> If you want to check, go to your control panel and click on the security center icon. It'll tell you whether your personal firewall is installed and running, and if it's not, the security center will help you do this.</b> Incidentally, the security center will also tell you if your anti-virus software is up to date, assuming you're using one a mainstream AV product and it will offer to turn automatic updates on."

An important thing to note: If you have ever had a firewall installed, it is worth checking that it is really gone. There have been numerous cases reported here where firewalls did not fully, or correctly uninstall, and were the source of problems.
This includes limited time free versions included with a new pc purchase.They do not go away on their own, even if your free period has expired. And worth repeating: Many firewalls also still function somewhat, EVEN WHILE DISABLED.

Updating Firefox in most cases will require you to give the new version permission to access the internet.

General Firewall issues.
Even with XP's firewall shutoff it will sometimes block internet access.
Outpost Firewall, NIS and Zonealarm have been known to cause similiar issues.

Zonealarm issues:
It seems some versions of Zonealarm do not like Firefox.
From the ZoneAlarm Forum " Zone Alarm ZA 5.1.033 being a "trouble version" and either recommending people go backwards in versions (removing 5.1.033) or download the new beta version 5.5.035.

Cookies being Blocked:
Zone Alarm Pro automatically blocks persistent cookies on all sites. On some sites, this will cause a "cookies disallowed" error when you attempt to login. The fix is to go into your privacy site list and allow persistent cookies for that site.

The URL has to be the exactly URL of the site, for instance, you can't use, you have to use

Make sure your firewall is configured properly. (If I missed any I apologize, I don't use any of these.)

"Configuration of ZoneAlarm" EZ Trust Armor uses the same engine as Zone Alarm.
If Zone Alarm is not configured correctly it can not only block access to all web pages, it can just block images, animated images and downloads as well. ... 5638ccf559

XP Firewall Configuration

Kerio and pre-v3.0 Tiny PFW Allowing DNS ... y+PFW#2524

Outpost Firewall
"Make sure the Rules Wizard firewall policy is on. This will help you control all the connections that do not come under any rule." ... 06&lang=en

Norton Internet Security(NIS)
"Configure Norton Internet Security"
See also ... highlight= for step by step guide

Windows Firewall
Troubleshooting Windows Firewall settings in Windows XP Service Pack 2

WARNING the following is rather technical. If you DO NOT understand it, please do not try any of the following.
II. DNS lookup fails. Most of the instances of Fx failing to load a webpage that can't be attributed to a misconfigured firewall are probably due to a failure by the ISP's DNS nameservers to resolve the hostname that one wishes to access. This could be caused by actual failure or misconfiguration or overloading of your ISP's DNS nameserver. When such a failure is intermittent, overloading of the server is a likely cause. Many broadband providers have experienced such intermittent failures lately. Examples are OptimumOnline, Verizon, Comcast, RCN, Roadrunner. Perhaps too many people have been signing up for broadband lately, and ISP's are running out of DNS server capacity.

Sometimes, you will experience long load times if your DNS cache becomes corrupted or the address of your ISPs DNS server changes. It's always worth it to run: Start>Run> ipconfig /flushdns

1) In Fx's URL field (the space into which you type a hostname) type and hit <Enter>. If Fx can't load the Google homepage , then there is a problem. Now, clear the URL field, type and hit <Enter>. If Fx can load the Google homepage now, then the problem is failure of DNS lookup. If you have trouble getting through to Google but you can consistently reach it using the IP address, the problem is probably the DNS. DNS service may be intermittent. With an intermittent problem, it takes repeated tests to be sure. The DNS nameservers are there to convert the easy to remember hostname "" to the IP address "" that is actually used by the servers and routers on the Internet. If the nameserver is dead or nonresponsive, "" will get you nowhere but "" will bypass the nameserver and get you to Google more directly. You can also enter the command "nslookup" on the command line, and see whether nslookup tells you that the request timed out ("cannot find server"). "Checking DNS issues "

2. Call your ISP tech support and ask them whether any of the DNS nameservers that your machine automatically connects to through DHCP are experiencing problems (overloading or failure because of Internet attacks) and if so what they are planning to do about it. If you can't get satisfaction from them, discard their DNS nameservers and go to step 3.

3. Rather than using your ISP's DNS nameservers, use stable, reliable and non-congested alternative nameservers such as public nameservers or those of a major university nearby. A list of public nameservers can be found here: . Choose two from the list that are nearby. If you use a router add the DNS servers there.

4. Treewalk :"You need TreeWalk DNS if: (ONLY Works for Windows)
1. Accurately (resolving) Web Sites is a problem
2. You wish to capture or debug DNS routing Data
3. You want to custom configure DNS settings and Servers
4. You'd like faster repeat visits to Sites (cached lookups)
5. Your Internet Service Provider's (ISP) DNS Server is slow or offline
6. You have problems with your wireless or satellite Internet connection"
Download it here:

5. You can also add the IP address of sites you visit frequently to your HOSTS file. (This will also help speed up updates such as your Antivirus.)
If you do not know the IP address try

Here is a way to show that the problem is due to DNS and not just FF.
1. Find your host file in c:\windows or
c:\windows\system32\drivers\etc depending on your version
2. add a line for one of your favourite sites, like
3. Save the hosts file and restart FF.
4. Go to that site. If you can now get there on the first try, you know that DNS is at fault.

III. Antivirus software issues.
Trend Micro : "A faulty update to antivirus software released over the weekend by Trend Micro Inc. caused PCs to slow down or stop working around the world, the company said today." ... ource=x584

McAfee Anti- virus software can also stop Firefox operating corrently. To fix the problem, go to the virusscan console/ Access protection/'prevent downloads from the world wide web'/and add "firefox.exe"

IV. Proxy issues
Firefox is not currently always able to handle OCSP and proxies. If you use a proxy and receive error messages when attempting to access sites which might be expected to have OCSP (eg your webmail), you may need to reset tools>options>advanced>OCSP to "Do not use OCSP" A little more information here

If you are using Privoxy change the value of network.http.proxy.version to 1.0 instead of 1.1

Other solutions that have worked for some.

This also seems to fix problems people are having with Yahoo.
1) Turning off the IPv6.
type about:config in the Navbar/address bar and hit Enter then look for
network.dns.disableIPv6 - right-click and toggle to true
Restart Firefox

2) Create a new Firefox Profile:
In order to create a new profile, you use the Profile Manager. To start the Profile Manager in Windows, follow these steps:
1. Close Firefox completely (select File > Exit from the main menu of Firefox).
2. Select Start > Run... from the Windows Start menu.
3. Enter firefox.exe -profilemanager and press OK."

If you are having crashes as well as other problems take a look at the Standard diagnostic

A shorter version of this article can be found at Error loading any website - MozillaZine Knowledge Base Thanks to np.

Also see Error loading some websites - MozillaZine Knowledge Base

For other Firefox problems please see Issues with Firefox - MozillaZine Knowledge Base

How to block content, parental controls, Surf anonymously

Please let me know if I missed anything or if any of these are not correct. Thanks.
Last edited by craigevil on May 10th, 2006, 11:25 am, edited 11 times in total.
Debian Buster LXDE Raspberry PI 400 Kernel: 5.10.11-v8+ aarch64
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"


User avatar
Posts: 5130
Joined: March 20th, 2005, 5:29 pm
Location: Bradford W.Yorks

Post Posted May 1st, 2005, 6:01 pm

If none of these work for you, you can read your way through and ... t=treewalk

If nothing in there helps, please either post at the end of one of these threads or start a new thread in this forum. In either case, please be specific about the following
  • your OS, version of firefox, installed extensions
  • anything you have installed or updated immediately before the problem started
  • how you have already tried to fix it (if you don't include this information, people will just refer you back to here)
  • what type of connection, firewall, av, anti-spy and other similar software you have
I don't know how to do any of this stuff, I just hire the guys that do
Have you considered reading the HELP folder. Right there on your menu bar.
Image by Juniper http - Xmas special by Ol Grumpy

Posts: 2158
Joined: December 22nd, 2004, 11:47 am

Post Posted June 20th, 2005, 7:44 am

Part of the DNS problem may be due to a bug in Windows that may exacerbate the DNS problem. At least I would call it a bug. I wouldn't be surprised if other OSs do this too. <b>Here's an explanation of the problem and to fix it: How to keep DNS Errors from slowing you down!</b> Here's another explanation. Search for "Reduce DNS errors in Windows 2000/XP".

What happens is that <b>domain name service fails and your computer <i>caches the negative result!</i></b> So when you try again, your computer checks the cache and tells you again (and again and again) that the domain name lookup failed. Then after a little while you try IE, which of course works, with a little help from Murphy's Law, because the cache has finally expired. When Hellene tells you to flush the DNS cache, that helps. But even better, the link <i>tells you how to disable caching of failed lookups.</i>

Caveat: the solution sounds good, but I haven't tried it, and can't try it because I've never had the problem.

Edit: <b>Here's a Microsoft document that shows how to disable the negative cache:</b> ... -us;318803 . Note that the script in the link above appears to be more comprehensive than Microsoft's version, but the names of the fields are somewhat different. I suggest that you look at both and use your own judgement.

Here's a very <b>handy Microsoft reference on using IPCONFIG to diagnose network problems:</b> ... onfig.mspx .

<b>Gory but essential details</b>
The DNS cache program and the syntax to disable it are very different in Wndows 2000 and XP. Doesn't seem to exist in Win 98.
Here are some settings for Win 2000:

Nice overview: .

<b>If you just need a quick, on-the-spot fix</b>
Go to the Windows Start menu. Run --> cmd
(or Run --> command)
In the command processor window type in ipconfig /flushdns
Last edited by AnotherGuest. on August 17th, 2005, 2:50 pm, edited 7 times in total.


Post Posted June 22nd, 2005, 8:20 pm

Win XP w/ service pack 2, have norton utilities

Had Fx 1.03 I think? Just installed 1.04: it won't connect to any website (eg. yahoo, google). Strangely doesn't even give a timeout message, just keeps looking (apparently).

What I've tried:
Uninstalled Fx, re-downloaded & re-installed.
Checked XP and Norton firewall settings: both explicitly allow Fx.
Tried, no luck.
Toggled disableIPv6 to true, no luck.

The only other recent change to this computer was download of the new adaware se version. That won't connect to check for updates?

Any hints? Thanks.


Post Posted June 22nd, 2005, 8:24 pm

I uninstalled adaware, didn't help.

Incidentally, I have restarted both the computer and firefox a couple of times.

Thanks again.

Posts: 1497
Joined: February 18th, 2005, 2:54 pm
Location: Wyoming, USA

Post Posted June 22nd, 2005, 9:05 pm

Delete Firefox from Norton and let Norton Detect Firefox again. After every update you need to allow Firefox access in Norton.
<a href="">A Good place to look for Firefox help </a> <===Click on this.

Why do people Uninstall and reinstall Firefox and say it does not help?

Posts: 2158
Joined: December 22nd, 2004, 11:47 am

Post Posted June 23rd, 2005, 6:04 am

He says Norton <i>is</i> set to allow Fx. What you need to explain is that according to some reports, Norton is brain-damaged, and you need to delete Fx first for the setting to take effect.

heywood22, can you check something? Look at the Norton settings and see if you can tell which version of Fx is allowed. I am guessing it is the previous version. Please, this is important. Maybe we can nail down this problem.


Post Posted June 26th, 2005, 9:09 pm

I have the same problem as heywood22, but don't have Norton or ZoneAlarm running. When I reinstall Fx 1.0, that works fine. 1.0.4 does not. IE works fine. DNS is not the problem: using the numeric code doesn't work any better than the text URL.

I'm using Windows 98, running almost nothing but Fx in the trial.


User avatar
Posts: 5130
Joined: March 20th, 2005, 5:29 pm
Location: Bradford W.Yorks

Post Posted June 27th, 2005, 8:30 am

EGold2, what do you use for a firewall?
I don't know how to do any of this stuff, I just hire the guys that do
Have you considered reading the HELP folder. Right there on your menu bar.
Image by Juniper http - Xmas special by Ol Grumpy


Post Posted June 27th, 2005, 9:42 am

Firewall: I have used ZoneAlarm on each machine, but I also have a router between the machines and the ISP; by itself the router does very well.

For this problem, I've removed ZoneAlarm entirely. The problem continues. Note that I was using 1.0.3 without any problem. When Firefox told me about an available update, I downloaded it. The new version simply times out on every attempt.

Interestingly, an error message comes up for text destinations, but it just hangs when I put in the numeric equivalent.

As I happened to have the install set for V 1.0, I used that. I'm using that now to type this.

Posts: 2158
Joined: December 22nd, 2004, 11:47 am

Post Posted June 27th, 2005, 10:29 am

You may have terminated the user interface of ZoneAlarm but left the engine (TrueVector) running. That's what often seems to happen.

We see this all the time. People have multiple firewalls, and somehow, there's a quirk in one that is blocking the new version of Fx. I suspect that the firewalls are set to permit use of <i>the old version.</i> It says Firefox, but it's not Firefox 1.0.4, it's Firefox 1.0.3.

When you find it, can you let us know, please? Maybe we can confirm my suspicion.


Post Posted June 27th, 2005, 11:41 am

Confirmed. I had removed ZoneAlarm, but not the TrueVector. Due to ignorance, it took me a while to find the spot to kill that, too.

Running now on 1.0.4.

Thank you.

Now to get ZoneAlarm working again....


Post Posted June 27th, 2005, 5:26 pm

This happened to me too. Eventhough my firewall was off, it had detected that I updated to v1.0.4 and would not allow the new exe to communicate. How strange is that?

Posts: 2158
Joined: December 22nd, 2004, 11:47 am

Post Posted June 28th, 2005, 6:15 am

Anonymous wrote:Eventhough my firewall was off, it had detected that I updated to v1.0.4 and would not allow the new exe to communicate. How strange is that?

Not strange. It's making sure that <i>you</i> installed that new file called firefox.exe, and not some virus. That's why, when you check to see if Firefox is allowed access, you have to make sure <i>the current version</i> of Firefox is allowed, and not just the previous version.


Post Posted July 6th, 2005, 12:33 pm

Took me a while to figure the above out on my own after being sent down wrong paths for a couple of days. This thread ought to be in flashing neon lights. I couldn't even delete 1.04 to start over with 1.01 because XP thought Firefox was still running when EVERYthing visible was shut down (Task manager including processes.
Works fine now.


Return to Firefox Support

Who is online

Users browsing this forum: No registered users and 3 guests