MozillaZine

Firefox Upgrade Extortion?

Discussion of general topics about Mozilla Firefox
JCH
 
Posts: 3
Joined: May 21st, 2005, 10:18 am

Post Posted May 21st, 2005, 10:56 am

To Bill Gates Jr,

What’s with the “Firefox upgrade extortion message” I get when trying to go to the extensions site? The message says I have to upgrade my version of Firefox before I can go to the extensions site.
I am running Firefox 1.0.3. and am quite happy with it. I have it set up with the extensions and settings exactly how I like them.
Why should I be forced to upgrade my version of Firefox?
I guess the upgrade options in Firefox are not options at all!

JCH

RandomUser
 
Posts: 727
Joined: July 7th, 2004, 10:52 am

Post Posted May 21st, 2005, 10:59 am

Have you tried <a href="http://www.extensionsmirror.nl">The Extensions Mirror</a>?

Thumper's Evil Twin

User avatar
 
Posts: 6422
Joined: December 9th, 2003, 3:52 pm
Location: Glasgow, Scotland

Post Posted May 21st, 2005, 11:01 am

Security reasons. You lack the acumen to comprehend them or the manners to justify explaining them slowly.

update.mozilla.org wants to keep its reputation for being a reliable upgrade site. it wouldn't do this by allowing browserswhich install extenisons from it to be compromised by a bug in 1.0.3.

If you're happy with your browser the way it is, you shouldn't be whining about not being able to update it, should you?

- Chris

JCH
 
Posts: 3
Joined: May 21st, 2005, 10:18 am

Post Posted May 21st, 2005, 11:07 am

Thumper wrote:Security reasons. You lack the acumen to comprehend them or the manners to justify explaining them slowly.

update.mozilla.org wants to keep its reputation for being a reliable upgrade site. it wouldn't do this by allowing browserswhich install extenisons from it to be compromised by a bug in 1.0.3.

If you're happy with your browser the way it is, you shouldn't be whining about not being able to update it, should you?

- Chris


Hey Dumper,

Read Slowly, AH!

Maybe you should read my original post again! Did I say anything about not being able to upgrade Firefox?

JCH

shakey_snake

User avatar
 
Posts: 1622
Joined: October 25th, 2004, 11:12 pm

Post Posted May 21st, 2005, 11:08 am

You fail to comprehend. I feel sorry for you.

JaredM
 
Posts: 3826
Joined: November 14th, 2004, 4:41 am
Location: Alberta, Canada

Post Posted May 21st, 2005, 11:12 am

JCH wrote:To Bill Gates Jr,

What’s with the “Firefox upgrade extortion message” I get when trying to go to the extensions site? The message says I have to upgrade my version of Firefox before I can go to the extensions site.
I am running Firefox 1.0.3. and am quite happy with it. I have it set up with the extensions and settings exactly how I like them.
Why should I be forced to upgrade my version of Firefox?
I guess the upgrade options in Firefox are not options at all!

JCH


You're not being forced to upgrade, you just can't use the offical extension site to automatically install extensions due to inherant security flaws in the older versions.
I'm moving to Theory, everything works there.
Most issues are solved by going through the Standard Diagnostic

JCH
 
Posts: 3
Joined: May 21st, 2005, 10:18 am

Post Posted May 21st, 2005, 11:20 am

shakey_snake wrote:You fail to comprehend. I feel sorry for you.


There are many versions of extensions designed for different versions of Firefox, hence, not wanting to be forced to blindly upgrade my browser before seeing what effects it will have on it!
Now, is that really that hard to understand?
JCH

Thumper's Evil Twin

User avatar
 
Posts: 6422
Joined: December 9th, 2003, 3:52 pm
Location: Glasgow, Scotland

Post Posted May 21st, 2005, 11:27 am

x.x.x releases are designed to be completely compatible with previous releases; they are security fixes only. None of your extensions will be affected.

You're not allowed to use 1.0.3 to update extensions because this can lead to your browser being taken over. The people running update.mozilla.org don't want to be blamed for this.

Coming in here with all guns blazing was a really stupid way of going about registering your displeasure, especially due to the fact you were completely ignorant of the reason this was put in place. I'd wager that you either don't use the Internet very much or don't have many friends.

- Chris

CritterNYC
 
Posts: 970
Joined: August 27th, 2003, 12:27 am
Location: Astoria, NY

Post Posted May 21st, 2005, 11:29 am

JCH wrote:There are many versions of extensions designed for different versions of Firefox, hence, not wanting to be forced to blindly upgrade my browser before seeing what effects it will have on it!
Now, is that really that hard to understand?


Firefox 1.0.3 has a security flaw that allows non-whitelisted sites to install extensions. The flaw is actually used in conjunction with the whitelisted (by default) site update.mozilla.org. To counteract the bug, Mozilla disabled extension installing into Firefox 1.0.3 from update.mozilla.org, thus protecting Firefox 1.0.3 users from possible exploits elsewhere on the web. So, in order to install extensions from within a webpage (clicking Install...) you will need to upgrade to Firefox 1.0.4.

Firefox 1.0.4 is a simple security update and should not break any extensions. You should be able to safely uninstall 1.0.3 and then install 1.0.4 without your profile being adversely affected. To be safe, make a backup of it. If you encounter an issue, you can always revert to 1.0.3.

Regards,
John
Take your browser, email, office suite, instant messenger, image editor and more with you...
Get portable versions of Firefox, Thunderbird, OpenOffice.org, Pidgin, GIMP and more at PortableApps.com

ericslaw
 
Posts: 4
Joined: August 30th, 2005, 5:27 am

Post Posted August 30th, 2005, 5:30 am

I've tried to upgrade to 1.0.6, but it still wont let me past the 'extortion' page....
I dont mind being told to upgrade, but there is a bug someplace.
I've removed all versions of firefox from my system, and ran the installer.
The Help->About box says I'm running 1.0.6 but the extortion page still shows up.

I've previously seen problems with the firefox version being mangled...
with instructions on how to fix it, but I cannot find that anywhere.

So... I'm running 1.0.6 but cannot add extensions....
time to try the mirrors and see if that works.

_Eric

AnotherGuest.
 
Posts: 2158
Joined: December 22nd, 2004, 11:47 am

Post Posted August 30th, 2005, 5:52 am

Ericslaw,
Sounds like you've been hit by the StumbleUpon extension, possibly the stupidest extension ever. Creating a new profile should fix it, or else edit the user agent string. Search the forums for <b>StumbleUpon</b> and you'll find plenty of info. If in doubt, copy the version info from Help/About back here and we'll look at it. For example, mine reads:
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6 .

ericslaw
 
Posts: 4
Joined: August 30th, 2005, 5:27 am

Post Posted August 30th, 2005, 5:55 am

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.2

Ah HA!
so it seems to think I'm 1.0.2!

ok... now how to fix? (and how to remove that silly extension)

ericslaw
 
Posts: 4
Joined: August 30th, 2005, 5:27 am

Post Posted August 30th, 2005, 6:01 am

went to about:config
scrolled down to: general.useragent.vendorSub
was set to 1.0.2
double-click allowed me to edit it to 1.0.6

ahhhh.... happyness (thanks to you 'AnotherGuest')

AnotherGuest.
 
Posts: 2158
Joined: December 22nd, 2004, 11:47 am

Post Posted August 30th, 2005, 6:08 am

Go to about:config (type that in the address window). In the filter box type useragent . Edit the general.useragent.vendorSub string. From the date, you appear to have version 1.0.6, as far as I know.

One caveat, though. Your message makes two contradictory statements: "I've tried to upgrade to 1.0.6...." and "I'm running 1.0.6...." I assume the second one is correct. It's tricky, isn't it? In my opinion it's a bug to allow users or extensions to edit that information, but it's probably hopeless to figure out what's design and what's an error and to get it fixed.

ericslaw
 
Posts: 4
Joined: August 30th, 2005, 5:27 am

Post Posted August 30th, 2005, 6:14 am

I upgraded, ran Help->About, which shows the firefox logo with 1.0.6 prominently displayed,
but per your reply, there is a little text box at the bottom that shows my general.useragent.vendorSub was
set incorrectly.....
Once I fixed that, I was all set to go.
Thanks again for the tip.

Return to Firefox General


Who is online

Users browsing this forum: No registered users and 2 guests