MozillaZine

Solutions and Known causes of Fx Freezing

User Help for Mozilla Firefox
craigevil

User avatar
 
Posts: 3102
Joined: February 20th, 2005, 2:12 pm
Location: OZ

Post Posted May 23rd, 2005, 4:27 pm

1) Prescott Pentium 4 Hyperthreading.
On some systems Firefox will freeze.

This workaround is recommended:
1.When Firefox is started,launch the Windows Task Manager (press CTRL+ALT+DEL,
or right click the clock display on the Windows Taskbar and select Task Manager)
2.Select the process tab
3.Locate and right-click on the Firefox process
4.Select the set affinity option from the popup menu
5.Uncheck CPU 1 and validate with OK.
6.You can go back to Firefox.
It is essential to change this affinity setting before loading Firefox.

If that fixes your problems temporarily, then you need to download "ImageCFG.exe".
Quit firefox and copy imagecfg to C:\WINDOWS\system32. Open up a cmd window and type:
imagecfg -u 0x1 "C:\Program Files\Mozilla Firefox\firefox.exe" then
imagecfg -a 0x1 "C:\Program Files\Mozilla Firefox\firefox.exe"
this should allow Firefox to retain its processor affinity.

Another workaround is to completely disable Hyper Threading from your motherboard BIOS settings.
Make sure to consult your motherboard user's manual to change its settings.

2) The use of the Switch Proxy extension has been know to cause freezing. Turn off the autoupdating feature.

3) If you recently updated the User Switch Agent through the Firefox autoupdate.
Start FF in safe mode. Uninstall UserAgent extension. Restart FF. Get extension UserAgent and install again. If you are upgrading the extension uninstall the original version before upgrading.

4) There have been a couple of posts stating that the MS Antispyware software have caused numerous problems with Firefox. http://forums.mozillazine.org/viewtopic.php?t=270147

5) McAfee Anti-virus
McAfee Anti- virus software can also stop Firefox operating corrently. To fix the problem, go to the virusscan console/ Access protection/'prevent downloads from the world wide web'/and add "firefox.exe"

6) Freezing during Downloading file:
Tools>Options>Privacy>Download Manager History and click "clear". After that, select the option,
"Remove files from the Download Manager upon successful download"

7) A bad theme or extension may cause crashes, freezes, blank/white screen.
If the problem is with Firefox then try running Firefox in Safe Mode
If all is well, you have a "bad" theme or extension/s that needs updating, replacement or removal.
Tool>Extensions>Right click to disable or uninstall Tool>Themes>uninstall
If the problem still exists it could be a bad profile in which case you need to Create a new profile.


8 ) It could also be a bad plugin. Make sure you have the latest versions of Flash and Java.
You can check what plugins you have by typing about:plugins in the address/location bar.

9 ) Viruses and spyware have been know to cause browser/system crashes and freezing.
Scan your computer for malware including viruses, trojans, adware and spyware.
For ways to secure your system read [url=http://forums.mozillazine.org/viewtopic.php?t=240548]
Secure your system and keep out Spyware, Adware, viruses and Popups.[/url]

Did I miss anything? If so please post the solutions you have found. Thanks.
One Ring to rule them all.

onan38
 
Posts: 536
Joined: April 11th, 2005, 5:47 am
Location: K.Y

Post Posted May 23rd, 2005, 10:01 pm

I have found a easier way to disable hyperthreading is to right click the Firefox icon click>properties>compatibility>put check mark in compatibility mode box and run in windows 98/windows me mode.This will disable hyperthreading for Firefox on a windows system.
Intel Core 2 Duo 1024MB DDR2 Windows Vista Home Premium
Firefox 13.0 Thunderbird 13.0

craigevil

User avatar
 
Posts: 3102
Joined: February 20th, 2005, 2:12 pm
Location: OZ

Post Posted May 23rd, 2005, 10:15 pm

Cool I do not have windows so I was going by the info I could find using Google and searching the forum.

Your method is much easier. :)
One Ring to rule them all.

craigevil

User avatar
 
Posts: 3102
Joined: February 20th, 2005, 2:12 pm
Location: OZ

Post Posted May 24th, 2005, 12:19 am

PLEASE DO NOT POST unless you have SOLUTIONS.

"Hyper-Threading (HTT = Hyper Threading Technology) is Intel's trademark for their implementation of the simultaneous multithreading technology on the Pentium 4 microarchitecture. It is basically a more advanced form of Super-threading that first debuted on the Intel Xeon processors and was later added to Pentium 4 processors. The technology improves processor performance under certain workloads by providing useful work for execution units that would otherwise be idle, for example during a cache miss.

The advantages of Hyper-Threading are listed as improved support for multi-threaded code, allowing multiple threads to run simultaneously, improved reaction and response time, and increased number of users a server can support"
http://en.wikipedia.org/wiki/Hyperthreading
One Ring to rule them all.

KRH

User avatar
 
Posts: 1094
Joined: October 14th, 2004, 11:47 pm
Location: Seattle, WA

Post Posted May 24th, 2005, 12:36 am

craigevil wrote:2) The use of the Switch Proxy extension has been know to cause freezing. Turn off the autoupdating feature.


I don't know if it's going to make a difference, but it appears that Jeremy Gillick has a new home site. I think the problem with the auto-update feature has been pretty much due to his old site being down so much. (Personally, I would disable the feature anyway).

SwitchProxy | Round Two
http://www.roundtwo.com/product/switchproxy
If you've been helped (or not) by a suggestion from anyone in these forums, please post back for the benefit of others.

Guest
Guest
 

Post Posted July 19th, 2005, 10:45 pm

Thanks for the information. I haven't had any freezing yet only crashing when go to certain web sites. I read that some others are having trouble as well. Will be looking into the Forum for more input plus update as well. Again, thanks for the time and effort.

neonfrog
 
Posts: 10
Joined: July 14th, 2004, 10:20 am

Post Posted July 22nd, 2005, 9:09 am

FWIW, I had the problem of Firefox (1.04 and 1.06) going to 99% CPU on load and never actually loading. System = Win2K(SP4 with latest security roll-up), AthlonXP 1800+, 1gb memory, Gigabyte Radeon 9000 video card.

The culprit turned out to be Windows Update downloading drivers for the video card. I uninstalled all things ATI, then reinstalled the latest drivers and Hydravision from ATI's website. All better. Phew!

seimia
 
Posts: 8
Joined: July 19th, 2005, 8:51 pm

Post Posted July 24th, 2005, 5:48 am

onan38 wrote:I have found a easier way to disable hyperthreading is to right click the Firefox icon click>properties>compatibility>put check mark in compatibility mode box and run in windows 98/windows me mode.This will disable hyperthreading for Firefox on a windows system.


LOL.... veerrrrry nice solution, I made this way and FF is running excellent as always =)
thanks

poop
Guest
 

Post Posted August 4th, 2005, 9:21 pm

when i click on the firefox icon, firefox safe mode pops up and no firefox, can anyone help me

Guest
Guest
 

Post Posted August 10th, 2005, 12:57 pm

poop wrote:when i click on the firefox icon, firefox safe mode pops up and no firefox, can anyone help me


That doesnt really belong in this thread, consider searching for it.

Scarlettrunner20

User avatar
 
Posts: 993
Joined: February 13th, 2003, 5:06 pm

Post Posted August 15th, 2005, 2:22 am

Who would disable Hyperthreading in the bios? That is a bad solution. I paid a lot to get the world's first SATA drive with hyperthreading back in Nov 2003. I would stop using Fx first and I have used it for years as my main browser if there was not some other solution. But I don't have the Prescott chip. I have Intel's 865G (Springdale) and haven't have Fx freeze except once in a great while.

Guest
Guest
 

Post Posted August 19th, 2005, 2:08 pm

Sigo teniendo este problema, no se como solucionar a pesar que segui las directivas sigue frezandose. Mejor si me ayudan es español. Sdls

edwardIBARRA
Guest
 

Post Posted August 19th, 2005, 2:13 pm

Sigo teniendo este problema, no se como solucionar a pesar que segui las directivas sigue frezandose. Mejor si me ayudan es español. Sdls

mmiked

User avatar
 
Posts: 9
Joined: August 29th, 2005, 3:15 am

Post Posted August 31st, 2005, 5:12 am

onan38 wrote:I have found a easier way to disable hyperthreading is to right click the Firefox icon click>properties>compatibility>put check mark in compatibility mode box and run in windows 98/windows me mode.This will disable hyperthreading for Firefox on a windows system.


Thanks a lot for your tip.It is perfect.
Greetings
Firefox eats ie.Firefox ißt das ie.Firefox mange l'cIe.Firefox come el ie.Firefox 吃ie 。Ateş tilkisi ieyi yiyor.
Firefox

AnotherGuest.
 
Posts: 2158
Joined: December 22nd, 2004, 11:47 am

Post Posted August 31st, 2005, 5:59 am

<b>PLEASE DON'T POST THANK-YOU NOTES OR REQUESTS FOR HELP. AND PLEASE DO NOT DOUBLE POST. THIS THREAD IS FOR SOLUTIONS ONLY.</b>

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot] and 12 guests