MozillaZine

Linux gtk2 builds broken?

Discussion of bugs in Mozilla Firefox
Old Persist
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted October 3rd, 2003, 6:49 am

The official linux gtk2+xft builds don't work for me at the moment. The build from the 29th of Sept works but all the gtk2 builds since don't run. There's been some discusion of it in this thread http://forums.mozillazine.org/viewtopic ... 487#215487 but the title doesn't mention gtk2, it seems to have wandered off topic a bit and I thought it should be in Firebird bugs.

Soap
 
Posts: 31
Joined: July 15th, 2003, 3:06 pm

Post Posted October 3rd, 2003, 10:24 am

I tried the latest build last night and it worked fine for me.

Old Persist
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted October 3rd, 2003, 12:19 pm

Which version of Linux do you use? I wonder if that makes a difference. I should have said in the original post I use Mandrake 9.1 and it doesn't matter if I use KDE or Gnome, current gtk2 nightlies aren't working.

U5f/vln<N?{%5cVr8.KT7z
 
Posts: 23
Joined: July 20th, 2003, 2:26 pm

Post Posted October 3rd, 2003, 1:46 pm

I have the same problem.
I'm running Gentoo GNU/Linux and compiled Firebird-CVS with GCC-3.3.1-r4 and got a segmentation-fault error.

First I thought that it's a Gentoo-specific problem, but the same happened with the newest precompiled nightly-build.
Error:
Code: Select all
/home/lems/MozillaFirebird/run-mozilla.sh: line 454: 19383 Segmentation fault                                                                                              "$prog" ${1+"$@"}


Now, I'm using Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a) Gecko/20030929 Firebird/0.7+ which runs just fine.

dulljeff
 
Posts: 2
Joined: August 16th, 2003, 4:26 am

Post Posted October 4th, 2003, 7:48 am

Has the bug been fixed in the meanwhile???

Coz I'm still experiencing it, and I would like to go use Firebird.

Help appreciated!

manojav
 
Posts: 7
Joined: June 4th, 2003, 6:22 pm

Post Posted October 4th, 2003, 8:27 am

I am exeriencing the same problem with RH9 gtk2-2.2.1-4 and gcc-3.2.2-5.

CatamountJack
 
Posts: 30
Joined: November 5th, 2002, 8:53 pm
Location: New England, USA

Post Posted October 4th, 2003, 7:28 pm

I'm running a 10/01 Firebird Nightly from daihard w/o any troubles.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a) Gecko/20031001 Firebird/0.7+ (daihard; XFT+GTK2; optimized for P4/SSE)

RH9, GCC 3.2.2, gtk ? .... (how do I find my GTK version anyway?) - KDE 3
Dairy Management student, Mozilla/Phoenix user, Linux convert... scary!

DonPete
 
Posts: 269
Joined: July 7th, 2003, 5:10 pm

Post Posted October 4th, 2003, 11:07 pm

Okay, I reversed the patch for bug 128688 (Use GNOME application associations) on my local source tree, and voila! it works now. There is now no question in my mind that bug 128688 is at fault here.

alanjstr
Moderator

User avatar
 
Posts: 9100
Joined: November 5th, 2002, 4:43 pm
Location: Anywhere but here

Post Posted October 4th, 2003, 11:35 pm

DonPete wrote:Okay, I reversed the patch for bug 128688 (Use GNOME application associations) on my local source tree, and voila! it works now. There is now no question in my mind that bug 128688 is at fault here.


bryner agrees that's probably it. mconner removed that one and it builk ok for him, too.
Former UMO Admin, Former MozillaZine General Mod
I am rarely on mozillaZine, so please do not send me a private message.
My Old Firefox config files

Brad
 
Posts: 3
Joined: August 27th, 2003, 11:28 pm
Location: Dubai

Post Posted October 5th, 2003, 5:24 am

It's this line

_gnome_program_init("Gecko", "1.0", _libgnome_module_info_get(),
1, argv, NULL);

in
uriloader/exthandler/unix/nsGNOMERegistry.cpp

If you don't have gnome installed then the _gnome_program_init is a NULL.

Mozilla bug 221217

gdb is your friend :p)

Return to Firefox Bugs


Who is online

Users browsing this forum: No registered users and 1 guest