MozillaZine


aebrahim: Unofficial Win32 2003-10-07 Nightly

Discussion about official Mozilla Firefox builds
aebrahim
 
Posts: 1234
Joined: November 10th, 2002, 2:47 am
Location: Hong Kong

Post Posted October 7th, 2003, 7:16 am

I built Mozilla Firebird today from CVS with MSVC++ .NET 2002. I'm not using any special optimisations, and I'm not using any hacks at all to get this code to compile. Therefore this build platform is 100% supported and should not cause any problems at all, unless of course, the underlying code itself is broken.

This build isn't optimised for any specific processor. This is just a build that's uses exactly the same .mozconfig as the official builds, because right now the official Win32 build machine seems to be down.

The builds are here:
http://pryan.org/firebird/aebrahim/Mozi ... 031007.zip (6.03MB - zip)
http://pryan.org/firebird/aebrahim/Mozi ... 031007.exe (4.44MB - 7z sfx)

Because of some changes to the bookmarks format, I suggest taking a look at this thread before reporting any problems with this build:
http://forums.mozillazine.org/viewtopic.php?t=27954

You can find a copy of these builds (and my older builds) on pryan's mirror:
http://pryan.org/firebird/aebrahim

My .mozconfig is as follows:

. $topsrcdir/browser/config/mozconfig
ac_add_options --disable-tests
ac_add_options --disable-debug
ac_add_options --enable-optimize
ac_add_options --enable-static
ac_add_options --disable-shared

My builds have the following preference set:
pref("general.useragent.vendorComment", "aebrahim");

Please try with a new profile (delete or rename the Phoenix folder in %AppData% while Firebird is NOT running) before reporting any problems. Please test sites before importing data from your old profile. You should also test without any extensions installed. Also, if you're having problems please state what OS you're running on, what processor you have, and whether you downloaded the Zip or EXE version.

bangbang023

User avatar
 
Posts: 1726
Joined: July 7th, 2003, 12:23 am
Location: Brooklyn, NY

Post Posted October 7th, 2003, 7:59 am

works fine for me. thanks.

irkregent
 
Posts: 176
Joined: July 15th, 2003, 9:04 am

Post Posted October 7th, 2003, 8:06 am

Does not work for me, even after wiping out previous profile directory. It either crashes on startup, or does nothing and never appears on screen. 2003-10-06 build behaved the same way. Weird. No biggie, though. I'll just hang out on the optimized 2003-10-04 build until a better one comes along.

Lost User 15175
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted October 7th, 2003, 8:08 am

Pop-ups crash this build and every build since 04 I think. This site is a guarenteed crash: http://www.24fun.com/downloadcenter/ben ... nchjs.html

Been like this since about 04 I think. I'm still using 03 Athon Otimized as my primary build until this crash bug gets fixed.

(Clicking on 'Add Smilies' also crashed FB)

AthonXP 1800+
Win XP
Downloaded the .zip file

*Edit - Well, nix that; new profile allowed it to run better than ever. Maybe it has to do with an extention I have installed. (ugh)

Lost User 15175
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted October 7th, 2003, 8:25 am

/em cries .. I've narrowed it down to Tab Extensions. It crashes Moz FB on popup windows. /sigh

Lost User 15175
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted October 7th, 2003, 8:34 am

Here's a lagitamit problem: I keep getting a popup error saying Moz FB can't load cause it can't find MSVCR70.DLL and MSVCR71.DLL

No doubt they are related to Visual C++.

BigFire
 
Posts: 94
Joined: February 24th, 2003, 2:31 pm

Post Posted October 7th, 2003, 8:39 am

guice wrote:Pop-ups crash this build and every build since 04 I think. This site is a guarenteed crash: http://www.24fun.com/downloadcenter/ben ... nchjs.html

Been like this since about 04 I think. I'm still using 03 Athon Otimized as my primary build until this crash bug gets fixed.

(Clicking on 'Add Smilies' also crashed FB)

AthonXP 1800+
Win XP
Downloaded the .zip file

*Edit - Well, nix that; new profile allowed it to run better than ever. Maybe it has to do with an extention I have installed. (ugh)


Odd, that link didn't crash my 10-04 SS2 optimized.

Lost User 15175
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted October 7th, 2003, 8:42 am

BigFire wrote:
guice wrote:Pop-ups crash this build and every build since 04 I think. This site is a guarenteed crash: http://www.24fun.com/downloadcenter/ben ... nchjs.html

Been like this since about 04 I think. I'm still using 03 Athon Otimized as my primary build until this crash bug gets fixed.

(Clicking on 'Add Smilies' also crashed FB)

AthonXP 1800+
Win XP
Downloaded the .zip file

*Edit - Well, nix that; new profile allowed it to run better than ever. Maybe it has to do with an extention I have installed. (ugh)


Odd, that link didn't crash my 10-04 SS2 optimized.


I found out it's related to TBE. Exactly why, I'm unsure. But it effects the 05, 06 and 07 builds posted by aebrahim.

bangbang023

User avatar
 
Posts: 1726
Joined: July 7th, 2003, 12:23 am
Location: Brooklyn, NY

Post Posted October 7th, 2003, 9:33 am

guys please remember to create a new profile. you have to do so if you want to get this build to run. I needed to completely fresh install it and start a new profile, otherwise it would never show up on the screen,

TeddyBerlin

User avatar
 
Posts: 340
Joined: August 10th, 2003, 9:53 am
Location: Berlin(Germany)

Post Posted October 7th, 2003, 9:45 am

Unfortunately also the newest TBE-test-build from today doesn't function.
But otherwise: this FB build works very well.

Heinrich Witt
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040309 Firefox/0.8.0+
Mozilla Thunderbird 0.5+ (20040304)

bangbang023

User avatar
 
Posts: 1726
Joined: July 7th, 2003, 12:23 am
Location: Brooklyn, NY

Post Posted October 7th, 2003, 10:04 am

TeddyBerlin wrote:Unfortunately also the newest TBE-test-build from today doesn't function.
But otherwise: this FB build works very well.

Heinrich Witt


tbe works fine for me

Eisprinz

User avatar
 
Posts: 10
Joined: October 6th, 2003, 5:19 pm
Location: Heidelberg, Germany

Post Posted October 7th, 2003, 10:08 am

Okay, so TBE doesn't work, see also the thread on the 2003-10-06 build. But what I still don't know is whether this is TBE's fault or aebrahim's? :-k
I mean, since this works flawlessy in the latest official nightly (see sig), I would guess something is bad with aebrahim's build. But I may be way wrong, since I don't have any insight in TBE nor in the compiling of FB builds.
XP SP2, Athlon TB 1200, 256MB
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040922 Firefox/0.10

Mozilla-Hulk
 
Posts: 69
Joined: July 14th, 2003, 2:48 pm

Post Posted October 7th, 2003, 10:12 am

I am currently able to cause firebird to crash if I go to www.memoryexpress.com and then select MEMORY and then immediately select DDR SDRAM. I am consitantly getting a seg fault from Firebird. It looks like it works fine if you allow it to load the MEMORY page fully before selecting the DDR SDRAM sub catagory. Also it looks to work OK if the page is in the cache. I haven't seen this problem anywhere else yet and it looks like the site is just running a PHP script to build the page.

Other than that everything looks to be working pretty decently. I am running without any extenstions and I always install Firebird in a new directory. I rebuilt my profile yesterday but didn't do it today. I haven't had any other problems with any of the other sites I usually visit.
Mozilla is the strongest one there is!!!

TeddyBerlin

User avatar
 
Posts: 340
Joined: August 10th, 2003, 9:53 am
Location: Berlin(Germany)

Post Posted October 7th, 2003, 10:13 am

I installed the today's version with new profile.
And: without other theme and without each extension everything functioned.
But as soon as i installed TBE, i got problems.
The intended popups came and the FB didn't crashes, but in these popups nothing was indicated.
I saw only a white side.

Heinrich Witt
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040309 Firefox/0.8.0+
Mozilla Thunderbird 0.5+ (20040304)

NightlyBuild
 
Posts: 23
Joined: September 20th, 2003, 8:01 pm
Location: close

Post Posted October 7th, 2003, 11:28 am

Wfm with a new profile
finally 219150 seems resolved
no problems here yet

Return to Firefox Builds


Who is online

Users browsing this forum: No registered users and 0 guests