MozillaZine


aebrahim: Unofficial Win32 2003-10-12 Nightly

Discussion about official Mozilla Firefox builds
aebrahim
 
Posts: 1234
Joined: November 10th, 2002, 2:47 am
Location: Hong Kong

Post Posted October 12th, 2003, 9:33 am

I built Mozilla Firebird today from CVS with MSVC++ .NET 2003. To build on MSVC++ .NET 2003, I had to apply a somewhat dirty trick with my MSVC++ .NET 2003 install, where I'm using some libraries from MSVC++ .NET 2002. However, it's using the MSVC++ .NET 2003 compilers and linkers. The one bug that's blocking full native build support on MSVC++ .NET 2003 (without any code modifications) is:

http://bugzilla.mozilla.org/show_bug.cgi?id=208314

If you'd like to see native build support for MSVC++ .NET 2003, please sign into Bugzilla and vote for this bug, or better yet, contribute a patch. Thanks.

This build will run on any Win32/x86 platform, and does not require SSE or SSE2 instructions.

The builds are here:
http://pryan.org/firebird/aebrahim/Mozi ... Oxs-G7.zip (6.07MB - zip)
http://pryan.org/firebird/aebrahim/Mozi ... Oxs-G7.exe (4.46MB - 7z sfx)

I should note that I can't guarantee that these builds will work with Windows 95, but they will work with Windows 98/NT4 or better.

You can find a copy of these builds (and my older builds) on pryan's mirror:
http://pryan.org/firebird/aebrahim

My .mozconfig is as follows:

. $topsrcdir/browser/config/mozconfig
ac_add_options --disable-tests
ac_add_options --disable-debug
ac_add_options --enable-optimize="-Oxs -G7"
ac_add_options --enable-static
ac_add_options --disable-shared

My builds have the following preference set:
pref("general.useragent.vendorComment", "aebrahim");

Please try with a new profile (delete or rename the Phoenix folder in %AppData% while Firebird is NOT running) and with no extensions before reporting any bugs. Do not overwrite your old Firebird install tree, you need to delete it completely before installing new builds. Also, please test sites before importing data from your old profile.

Toxikk

User avatar
 
Posts: 159
Joined: December 1st, 2002, 1:24 pm

Post Posted October 12th, 2003, 9:49 am

aebrahim, you rule!

lynchknot
 
Posts: 6253
Joined: November 4th, 2002, 7:36 pm

Post Posted October 12th, 2003, 10:02 am

aebrahim, I'm not positive if it's just your build (20031012 Firebird/0.7+ aebrahim) but when using the "my assistant" feature that many Invision boards have, Firebird crashes as shown here:
*Also, the status bar will show this: javascript:buddy_pop0;

Image

I do not get this error with other builds such as: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Last edited by lynchknot on October 12th, 2003, 10:06 am, edited 1 time in total.

Daywalker
 
Posts: 22
Joined: August 23rd, 2003, 9:03 am
Location: Germany

Post Posted October 12th, 2003, 10:06 am

Build working fine up to now, although "View Source" is still broken.

aebrahim
 
Posts: 1234
Joined: November 10th, 2002, 2:47 am
Location: Hong Kong

Post Posted October 12th, 2003, 10:07 am

lynchknot wrote:aebrahim, I'm not positive if it's just your builds but when using the "my assistant" feature that many Invision boards have, Firebird crashes as shown here:
*Also, the status bar will show this: javascript:buddy_pop0;

Image

I do not get this error with other builds.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031012 Firebird/0.7+ (aebrahim)

I don't know. I'd be surprised if its a bug relating specifically to my build. It's more likely that its a general bug affecting Win32 (or maybe all platforms) that's new today or something. Have you tried with a clean profile and no extensions? Also don't forget to delete the previous MozillaFirebird directory before extracting the new one, or you could run into crashes like these.

bangbang023

User avatar
 
Posts: 1726
Joined: July 7th, 2003, 12:23 am
Location: Brooklyn, NY

Post Posted October 12th, 2003, 10:09 am

is the problem with cookies fixed? Yesterdays build, even with fresh profile, would not save my cookies.

lynchknot
 
Posts: 6253
Joined: November 4th, 2002, 7:36 pm

Post Posted October 12th, 2003, 10:14 am

This also occurred with yesterdays build. Using same profile and going back to .07 build, there is no problem.
Last edited by lynchknot on October 12th, 2003, 10:16 am, edited 1 time in total.

Geronimo

User avatar
 
Posts: 449
Joined: July 27th, 2003, 9:43 am

Post Posted October 12th, 2003, 10:14 am

I have had problems with Java and Flash using these builds. What might I be doing wrong?

ehume

User avatar
 
Posts: 6743
Joined: November 17th, 2002, 12:33 pm
Location: Princeton, NJ, USA

Post Posted October 12th, 2003, 10:19 am

bangbang023 wrote:is the problem with cookies fixed? Yesterdays build, even with fresh profile, would not save my cookies.
Cookies don't seem to be a problem for me. Build is Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031012 Firebird/0.7+ (aebrahim) --this means it is on Windows XP -- but I had no problem with yeasterday's build, either.

I installed yeasterday by first deleting the old installdir and profile, then making new ones from scratch. Also, although I'm using 18 extensions, TBE isn't one of them.
Firefox: Sic transit gloria mundi.

NewHarlock

User avatar
 
Posts: 90
Joined: September 24th, 2003, 6:37 am

Post Posted October 12th, 2003, 10:30 am

This build starts really fast :D Nice done Aebrahim ( under my old Amd k6-2 400mhz with WinXP sp1).

Cookies work too.

But, our TBE problem with real popup window is still here:

# a new profile without TBE = Everything is fine with true popup openning.
# with my old profile (with TBE in ~'open new browser only when i open them' mode in advanced options)= a crash
# with my old profile (with TBE in 'single window anytime')= the popup is opening fine in a new tab.

So I don't know from who this bug come from ... but I hope this precision could help :|

Ewokuk
 
Posts: 416
Joined: January 31st, 2003, 7:26 am

Post Posted October 12th, 2003, 10:43 am

ehume wrote:I installed yeasterday by first deleting the old installdir and profile, then making new ones from scratch. Also, although I'm using 18 extensions, TBE isn't one of them.


rofl, 18 extensions?

NanoBaka
 
Posts: 30
Joined: February 21st, 2003, 9:36 pm

Post Posted October 12th, 2003, 10:45 am

Geronimo wrote:I have had problems with Java and Flash using these builds. What might I be doing wrong?


I also have problem with Flash. Flash menus don't work on ESPN's MLB section.
I have had this problem for a while now with nightlies since September. I'm using
Flash 6 right now.


Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6a) Gecko/20031012 Firebird/0.7+ (aebrahim)

aebrahim
 
Posts: 1234
Joined: November 10th, 2002, 2:47 am
Location: Hong Kong

Post Posted October 12th, 2003, 10:55 am

bangbang023 wrote:is the problem with cookies fixed? Yesterdays build, even with fresh profile, would not save my cookies.

Someone was having the same problem as you yesterday, and fixed it by deleting the MozillaFirebird directory and extracting the build build into a brand new directory.

ehume

User avatar
 
Posts: 6743
Joined: November 17th, 2002, 12:33 pm
Location: Princeton, NJ, USA

Post Posted October 12th, 2003, 11:07 am

Ewokuk wrote:
ehume wrote:I installed yeasterday by first deleting the old installdir and profile, then making new ones from scratch. Also, although I'm using 18 extensions, TBE isn't one of them.


rofl, 18 extensions?
Yup. Use 'em all, too. Yet I'm an advocate for the lean core browser, because I don't want/need TBE, which would get included in a fat browser.
Firefox: Sic transit gloria mundi.

fearnot
 
Posts: 2
Joined: September 19th, 2003, 2:09 am

Post Posted October 12th, 2003, 11:08 am

i am downloading the build now.

and a question?
wasn't the yesterday build compiled with vc++ .net 2002?
this build is compiled with vc++ .net 2003. why?

Return to Firefox Builds


Who is online

Users browsing this forum: No registered users and 0 guests