MozillaZine


Permission denied to get property XULElement.selectedIndex

Discussion of bugs in Mozilla Firefox
bauhsoj
 
Posts: 97
Joined: June 20th, 2004, 7:45 am
Location: US

Post Posted September 4th, 2005, 6:46 pm

I found 155 topics on this when searching in Google. Some dating back as far as 0.9.2. I am suprised that this bug would still be showing up in 1.0.6.

This error always occurs when setting the focus to a <select> element from an <input> element of type "text", regardless of whether the input element has anything in it or not.

Here is the full error:
Error: [
Exception... "'Permission denied to get property XULElement.selectedIndex' when calling method:
[nsIAutoCompletePopup::selectedIndex]"
nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"
location: "JS frame :: http://localhost/test_script.js :: switchOnKeyPress :: line 386"
data: no
]
Source File: http://localhost/test_script.js
Line: 386

Unarmed
 
Posts: 4941
Joined: July 31st, 2003, 1:26 pm

Post Posted September 4th, 2005, 7:11 pm


bauhsoj
 
Posts: 97
Joined: June 20th, 2004, 7:45 am
Location: US

Post Posted September 4th, 2005, 10:03 pm

Thanks. I added my contribution to the bug data.

bauhsoj
 
Posts: 97
Joined: June 20th, 2004, 7:45 am
Location: US

Post Posted March 29th, 2006, 10:01 am

Any word on when this will be fixed? This bug has been around since Firefox 1.0.6 and is still plaguing the browser in 1.5.0.1.

I have several JavaScript programs that are currently dysfunctional because focus cannot be transferred to a select box when it was previously in a text box.

Unarmed
 
Posts: 4941
Joined: July 31st, 2003, 1:26 pm

Post Posted March 29th, 2006, 4:55 pm

The workaround of disabling autocomplete on the form element still works. mconner set blocking-firefox2 on it, so hopefully it’ll get some attention before 2.0 goes final.

bauhsoj
 
Posts: 97
Joined: June 20th, 2004, 7:45 am
Location: US

Post Posted March 30th, 2006, 2:29 pm

Unarmed wrote:The workaround of disabling autocomplete on the form element still works. mconner set blocking-firefox2 on it, so hopefully it’ll get some attention before 2.0 goes final.

How can autocomplete be disabled on an element-per-element basis? Is there a form element attribute to prevent Firefox from doing this?

bauhsoj
 
Posts: 97
Joined: June 20th, 2004, 7:45 am
Location: US

Post Posted March 30th, 2006, 2:36 pm

Nevermind, I just remembered that "autocomplete" attribute. :-P

Bastard_
 
Posts: 5
Joined: September 30th, 2005, 12:19 pm

Post Posted July 27th, 2006, 1:15 am

The beauty of Javascript is the fact that there is more than one way to get at what you need. I was running into this exact issue for something I was working on. I solved it by taking another approach. This may not work for everything, but in my case it was just the ticket.

document.formname.formfield.options[value].selected = true

Return to Firefox Bugs


Who is online

Users browsing this forum: No registered users and 0 guests