MozillaZine

extremely angry - 1.5 deleted all my search plugins

User Help for Mozilla Firefox
AsnoT
 
Posts: 11
Joined: November 30th, 2005, 2:06 am

Post Posted November 30th, 2005, 2:12 am

there is NO good reason for this, and it feels like being microsofted.
"we will think for you, oh stupid user"

not to mention all the disabled plugins that of course work perfectly when re-enabled by trickery in about::config (and NO help from mozilla there)

in short, i'm extremely pissed at mozilla

EDIT: it gets worse - newly installed search plugins do not work at all.
they show up as an empty line in the search window dropdown - nothing gets written to the \mozilla firefox\search plugins\ folder

:((

antx
 
Posts: 5
Joined: October 17th, 2004, 11:03 am

Post Posted November 30th, 2005, 2:25 am

I also don't like it that my search engines are gone. And more than that -> the add engine function doesn't work properly anymore. I get blank entries when I try to add certain engines. Also I miss a remove function there. When I can add something then I should also have the ability to remove it again.

AsnoT
 
Posts: 11
Joined: November 30th, 2005, 2:06 am

Post Posted November 30th, 2005, 2:28 am

they now get stored in the profile, but get truncated at 63 bytes
in addition, mycroft.mozdev.org has a mysql problem

EDIT: mycroft doesn't install searchplugins correctly for previous firefox version, either, at the moment.

Davio
 
Posts: 58
Joined: October 17th, 2003, 10:12 am

Post Posted November 30th, 2005, 2:31 am

Yes, the Add Search Engine option adds empty entries to my list of engines. Non of the engines I added here https://addons.mozilla.org/search-engines.php works. All blank entries.

I did a clean install of firefox 1.5. :(

old FatJohn
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted November 30th, 2005, 2:32 am

AsnoT, what Firefox version did you have? How did you update?

AsnoT
 
Posts: 11
Joined: November 30th, 2005, 2:06 am

Post Posted November 30th, 2005, 2:40 am

version doesn't seem to matter when the reason is a broken mycroft (see Davio's post)
i updated from 1.0.7 to 1.5

and the new installer deletes the previous searchplugins - not a version thing either.
Last edited by AsnoT on November 30th, 2005, 2:43 am, edited 1 time in total.

old FatJohn
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted November 30th, 2005, 2:43 am

I was thinking about your claim that the update had deleted your search plugins. Did you delete 1.0.7 installation folder?

AsnoT
 
Posts: 11
Joined: November 30th, 2005, 2:06 am

Post Posted November 30th, 2005, 2:44 am

ohh, nope, didn't delete anything myself

old FatJohn
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted November 30th, 2005, 2:45 am

So you just downloaded 1.5 and installed it? And they were gone? Are they in the installation folder/seachplugins?

AsnoT
 
Posts: 11
Joined: November 30th, 2005, 2:06 am

Post Posted November 30th, 2005, 2:49 am

except for my hand-edited (and WRITE PROTECTED) google.src, everything in there is gone - apart from the unwanted ebay and yahoo spam plugins that the installer put in.

seems that the plugins installed by 1.5 go to \proram files\mozilla firefox\searchplugins, wheras user installed ones go to the profile, btw.

old FatJohn
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted November 30th, 2005, 2:54 am

In adventure games there was this recurring quote, save often...

AsnoT
 
Posts: 11
Joined: November 30th, 2005, 2:06 am

Post Posted November 30th, 2005, 2:56 am

i save my PROFILE daily - but the program folder......
but - its really no business of the installer to go deleting user-installed features.

EDIT: especially in light of the fact that at the moment, noone can REinstall those deleted plugins because of the mysql errors on mycroft
Last edited by AsnoT on November 30th, 2005, 2:59 am, edited 1 time in total.

old FatJohn
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted November 30th, 2005, 2:58 am

I agree, and to me it would seem that the devs agree too, since as you wrote above, the custom searchengines have been transferred to profile...

AsnoT
 
Posts: 11
Joined: November 30th, 2005, 2:06 am

Post Posted November 30th, 2005, 3:02 am

lol
this is what gets installed as a .src file if you visit the search plugin page:

Access denied for user: 'petejc@localhost' (Using password: NO)

same text in the .gif

AsnoT
 
Posts: 11
Joined: November 30th, 2005, 2:06 am

Post Posted November 30th, 2005, 3:03 am

Warning: mysql_connect(): Host 'localhost' is blocked because of many connection errors. Unblock with 'mysqladmin flush-hosts' in /mozdev/sandbox/data/helm/htdoc/php/include/connect.h on line 21

Warning: mysql_select_db(): Access denied for user: 'petejc@localhost' (Using password: NO) in /mozdev/sandbox/data/helm/htdoc/php/include/connect.h on line 23

Warning: mysql_select_db(): A link to the server could not be established in /mozdev/sandbox/data/helm/htdoc/php/include/connect.h on line 23



from the website....

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot] and 24 guests