MozillaZine

1.5 Timeouts on Dual Core

User Help for Mozilla Thunderbird
cRaCKh0rN
 
Posts: 5
Joined: January 13th, 2006, 3:16 am

Post Posted January 13th, 2006, 3:27 am

Both myself and my college have installed 1.5 and have found it to be a little unstable on our machines. On Startup I get a message window saying every server has timed out (2 pop and 1 Imap). My college has the same thing on a different lan connection.
From then on my machine seems ok, as long as I don't do a manual Send/Receive, however my friends constantly gets timeouts.

Before 1.5 we were both happily running v1.0.7 with no problems whatsoever.

Specs of machines:-

Athlon 64 X2
Windows XP SP2 (32bit)
8meg DSL with fixed IP

[EDIT]

We have both re-installed 1.0.7 and the problems have gone away which does point to a problem with 1.5.

Cheers

RiceRemodeling
Moderator

User avatar
 
Posts: 2837
Joined: January 30th, 2005, 11:18 am
Location: Lawrenceville, Georgia

Post Posted January 13th, 2006, 3:41 am

Check if you have a maximum message size limit is set in tools->account settings->disk space.

Change Timeout to 180 seconds

If you add the following line to either your prefs.js or user.js file it will set the POP3 server timeout to 180 seconds. It defaults to 45 seconds. I suspect you're timing out.

user_pref("mail.pop3_response_timeout", 180);

You can use a text editor or you might find it easiest to install the chromedit extension.
It lets you edit user.js from within Thunderbird, thus eliminating your having to know where your profile is stored etc.
---> http://www.extensionsmirror.nl/index.php?showtopic=22

Info on --> Modify Thunderbird response timeout settings
More Info --> <Here>

~ Bill
.,,,,,
(•¿•) ... [√] Peºple d•ing a g∞d thing... Join us, the MozillaZine Folding Team #39340

cRaCKh0rN
 
Posts: 5
Joined: January 13th, 2006, 3:16 am

Post Posted January 13th, 2006, 3:52 am

Bill,

Many thanks for the response. I will try the settings now. However, something I failed to mention is that the message window appears instantly. When I open 1.5 There is no delay between the app initialising and the message window appearing. This is the same for pressing the Send and Receive button. My college is getting the same thing.

On checking netstat there is no timewait from the server which leads me to believe its not even getting to the connection stage to timeout.
Additioanlly overwriting 1.5 with 1.0.7 makes the problem go away for both of us.

Can you tell me what would have changed in the preferences between the 2 versions?

Many thanks

Dave

RiceRemodeling
Moderator

User avatar
 
Posts: 2837
Joined: January 30th, 2005, 11:18 am
Location: Lawrenceville, Georgia

Post Posted January 13th, 2006, 4:09 am

What is the "server has timed out" error message.
Google that "message".

~ Bill
.,,,,,
(•¿•) ... [√] Peºple d•ing a g∞d thing... Join us, the MozillaZine Folding Team #39340

Zeikzeil
Guest
 

Post Posted January 13th, 2006, 4:18 am

I'm having the same problem, as soon as I start Thunderbird 1.5 I get this time out message. I also have a dual core CPU (Athlon 64 X2 4800+). After setting the afinity of thunderbird.exe to only one core it worked fine. This means the problem is most likely dual core (or better: multi cpu) related.

cRaCKh0rN
 
Posts: 5
Joined: January 13th, 2006, 3:16 am

Post Posted January 13th, 2006, 4:24 am

Zeikzeil,

Many thanks for the reply. We both suspected that it could be processor related as it works fine on other x86 machines. I guess this is something to add to the TODO list then.

Dave

JeffreyReid
 
Posts: 11
Joined: January 13th, 2006, 1:10 am

Post Posted January 13th, 2006, 4:58 am

Same problem here; Athalon 64 X2 4400+.

JeffreyReid
 
Posts: 11
Joined: January 13th, 2006, 1:10 am

Post Posted January 13th, 2006, 5:05 am

RiceRemodeling wrote:Change Timeout to 180 seconds

If you add the following line to either your prefs.js or user.js file it will set the POP3 server timeout to 180 seconds. It defaults to 45 seconds. I suspect you're timing out.


I've changed my timeout to 600, without any success. The timeout mesage generally appears within 5-10 seconds of starting Thunderbird. It also seems to randomly happen when I click on a folder / message, after 5-10 seconds. I can click on another message/folder and they load, and than I can return to the message that gave me to error without a problem.

It all seems to be random! This is from IMAP, BTW.

JeffreyReid
 
Posts: 11
Joined: January 13th, 2006, 1:10 am

Post Posted January 13th, 2006, 5:07 am

-- Duplicate Post --
Last edited by JeffreyReid on January 13th, 2006, 5:55 am, edited 1 time in total.

cRaCKh0rN
 
Posts: 5
Joined: January 13th, 2006, 3:16 am

Post Posted January 13th, 2006, 5:09 am

JeffreyReid:

Everything is pointing to using only one core of the processor pointed out by Zeikzeil.
I have found an app that allows you to set programs to permantly use one core found here:-

http://www.microsoft.com/downloads/deta ... laylang=en

Instructions can be found here:-

http://episteme.arstechnica.com/groupee ... 2005236731

Hope this helps.

dave

tanstaafl
Moderator

User avatar
 
Posts: 45559
Joined: July 30th, 2003, 5:06 pm

Post Posted January 13th, 2006, 5:31 am

See http://www.robpol86.com/Pages/imagecfg.php . It has a link to download the imagecfg.exe program which you can use to permanently bind a application to one core, plus instructions. Supposedly that tool is also available from the Windows 2000 or Windows XP Server Resource Kit.

Zeikzeil

User avatar
 
Posts: 5
Joined: January 13th, 2006, 4:59 am
Location: Netherlands

Post Posted January 13th, 2006, 5:40 am

Thanks for that link, that tool will come in handy. I can use it for a few games as well. Up until now I just created a batch file which ran sleep.exe and process.exe.
This tool works fine btw :)
Asking for relationship advice on IRC is like asking for computer help at McDonald's

JeffreyReid
 
Posts: 11
Joined: January 13th, 2006, 1:10 am

Post Posted January 13th, 2006, 7:47 am

Thank you for the link, the imagecfg program worked perfectly. Now I can enjoy Thunderbird again, and receive my work emails. Oh, wait.... enjoy? ;)

tanstaafl
Moderator

User avatar
 
Posts: 45559
Joined: July 30th, 2003, 5:06 pm

Post Posted January 13th, 2006, 10:42 am

I added a http://kb.mozillazine.org/Timeout_on_dual_core knowledge base article.

Guest
Guest
 

Post Posted January 31st, 2006, 8:32 am

This other option (from the kb article above) seems to have solved this problem for me:

If changing the timer settings doesn't help download the nspr4.dll file and save it to the C:\Program Files\Mozilla Thunderbird directory, overwriting the existing file. This is the intended (but as of yet unreleased) production fix for Thunderbird 1.5 .

Return to Thunderbird Support


Who is online

Users browsing this forum: Google Adsense [Bot] and 4 guests