MozillaZine

File associations

User Help for Mozilla Firefox
robin043
 
Posts: 6
Joined: February 9th, 2006, 6:12 am

Post Posted February 9th, 2006, 6:15 am

Hi everyone. I recently installed FF and tried it for awhile and decided I would wait and try it again at a later date.

However, once I uninstalled I went to one of my folders that has my HMTL files in it and they all still have the little FF icons. They open with IE, but I think there may have been a problem where I didn't change IE back to the default browser before uninstalling FF.

How can I fix the problem?
Thanks so much,
Robin

Guest
Guest
 

Post Posted February 9th, 2006, 8:05 pm

Try either right-clicking on one of these files and selecting Open-With, select the program you want them to open in (IE), and check the box that says "Always Use the Slected Program to Open this king of file."
Or...
Go to Start> Control Panel> Folder Options> File Types, select the HTML extension from the list (they're in alphabetical order), then click change and finish with instructions above.
Or...
If FF is still the defualt browser like you say, go to Start> Set Program Access and Defaults, expand Custom if it isn't expanded so you can see the settings. At the very top should be a selection for "Choose a default web browser."

Alice

User avatar
 
Posts: 2627
Joined: April 23rd, 2003, 11:47 am

Post Posted February 9th, 2006, 8:37 pm

There's also some links to third-party freeware utilities to help you set a default browser, here:
http://kb.mozillazine.org/Default_browser
Alice Wyman

robin043
 
Posts: 6
Joined: February 9th, 2006, 6:12 am

Post Posted February 10th, 2006, 5:06 am

Thank you Guest and Alice for your replies. I have done both suggestions and the files open with IE. However the FF Icon is still showing for all HTML associated files. So I don't think that file association is the problem. I am beginning to think it's just an icon thing that was left over when I uninstalled FF. Would this be correct? And if so, how can I fix it?
I tried the "change icon" button. There is no icon for IE there...

Thanks
Robin

Alice

User avatar
 
Posts: 2627
Joined: April 23rd, 2003, 11:47 am

Post Posted February 10th, 2006, 6:03 am

When you use the "Change Icon" button for HTML Filetypes try the "Browse" button and select C:\Program Files\Internet Explorer\IEXPLORE.EXE to get the IE icon.
Alice Wyman

robin043
 
Posts: 6
Joined: February 9th, 2006, 6:12 am

Post Posted February 10th, 2006, 6:12 am

Alice wrote:When you use the "Change Icon" button for HTML Filetypes try the "Browse" button and select C:\Program Files\Internet Explorer\IEXPLORE.EXE to get the IE icon.
Ok thank you very much :)
Robin

robin043
 
Posts: 6
Joined: February 9th, 2006, 6:12 am

Post Posted February 10th, 2006, 6:16 am

That fixed it :) Again, thank you for all your help. Both of you.

Robin

Alice

User avatar
 
Posts: 2627
Joined: April 23rd, 2003, 11:47 am

Post Posted February 10th, 2006, 6:26 am

You're welcome.

I hope you give Firefox another try one day... you don't need to make it the default browser if you don't want to... just say "No" when it asks :)

Take care,
Alice Wyman

robin043
 
Posts: 6
Joined: February 9th, 2006, 6:12 am

Post Posted February 10th, 2006, 6:28 am

I have given it a try twice and I just can't seem to get used to the tabs and I am not sure which extensions/plugins are necessary and such. I may try it again someday tho.

Thanks
Robin

Alice

User avatar
 
Posts: 2627
Joined: April 23rd, 2003, 11:47 am

Post Posted February 15th, 2006, 12:19 pm

For the record:
https://bugzilla.mozilla.org/show_bug.cgi?id=248497
Bug 248497 - Uninstalling in Windows does not reset (keeps) files associations
Alice Wyman

robin043
 
Posts: 6
Joined: February 9th, 2006, 6:12 am

Post Posted February 15th, 2006, 12:25 pm

Thanks for the link. I believe I will second that post :)
Robin

jwindwalker
Guest
 

Post Posted April 27th, 2008, 11:34 pm

I wish I had found this thread before I installed Firefox, I could have saved myself a lot of headache by not installing it.

I was suing IE 6 and decided to try Firefox.

I set it to my default browser for a while. I changed to an ISP which is based on IE and it beacme an issue not to have IE as my default browser.

That is where the problem arose. I could not remove Firefox as the default browser. Restoring system defaults did not work. Windows xp SP 2 and IE are default so the issue did not exist until firefox.

Opening IE and setting it to default does not restore the default. Pages still open with Firefox. I tried Opera and did not have this problem with Opera.
I tried Netscape and did not have the problem there either.

I simply set IE as my default browser and uninstalled Opera, the same process worked with Netscape.

This problem only surfaced for me with Firefox.

From reading all the bug information on this thread https://bugzilla.mozilla.org/show_bug.cgi?id=255225 it would seem that Firefox is willing to blame the bug on everything but Firefox.

I will not try Firefox a second time. Considering the number of repeat issues and the length of time with firefox not correcting the problem or accepting responsibility for it is enough to discourage me from seeing what other bugs may be ignored.

Bugs are not the problem, not owning up to them is the problem.

I may have to completely reinstall Windows XP to get this problem resolved, but I will remove all traces of Firefox and it will not surface on any machine I have again.

Ignoring bugs is not how one lives up to the boasts I have seen from some Fire Fox open source programmers on many different forums.

Come on guys,
If it is reoccurring with Firefox, it is likely a firefox issue. Does not happen with Opera, does not happen with Netscape, does happen with Firefox, it isn't rocket science.

Windwalker

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot] and 3 guests