MozillaZine

Thunderbird 0.4 Release Candidate 1 Now Available

Discussion about official Mozilla Thunderbird builds
mscott

User avatar
 
Posts: 2516
Joined: April 2nd, 2003, 4:10 pm
Location: Thunderbird Research Center, CA

Post Posted December 2nd, 2003, 12:47 am

Our first release candidate for 0.4 is now available. Hopefully we'll drive the remaining 0.4 bugs to zero in short order. I can't thank everyone enough for all the great testing you have been doing over the last couple days!

Without further ado:

http://ftp.mozilla.org/pub/mozilla.org/ ... 2-01-trunk

**NOTE: Windows and Mac RC1 builds late 12/02 / early early morning 12/03 depending on the mirror site. The build ID in Help / About will show 20031202 if you have the latest Win and Mac builds. More details below **

What's New:
--------------
1) Mailing list dialog, subscribe dialog, search addresses dialog, offline dialog are now using the new icons. Thanks to Stephen Walker for the fix.

2) Results in the search Addresses dialog now only show a subset of the available columns by default instead of showing all the address book columns.

3) David Bienvenu landed an IMAP fix where you got stuck with an hour glass when selecting the Inbox while new mail is being downloaded.

4) Find in message now always forces focus on the message pane so you no longer have to do it yourself.

5) The offline extension for 0.4 builds: http://ftp.mozilla.org/pub/mozilla.org/ ... fline/0.4/

6) If you haven't found it already, there is also a Palm Sync Extension for 0.4 for synching with palm address books. Still working on the user page to explain the extension.

http://ftp.mozilla.org/pub/mozilla.org/ ... msync/0.4/

7) Find in dialog works again for standalone message window in 12/02 Win32 Respin

8) Security button can now be dragged into the customize toolbar dialog in mail compose. 12/02 Respin (Win32, OSX)

9) Attachments with non-ASCII file names can now be saved correctly. 12/02 Win32 Respin.

Note: Some of these things aren't in the GK2 build because Andre made it before I checked some of these items in.

Known Issues Blocking the Release:
------------------------------------------
1) Hooded One's problem with making thunderbird the default client on windows

2) The remaining 0.4 bugs in bugzilla


-Scott
Last edited by mscott on December 4th, 2003, 12:52 am, edited 4 times in total.
Thunderbirds are Go!

TeddyBerlin

User avatar
 
Posts: 340
Joined: August 10th, 2003, 9:53 am
Location: Berlin(Germany)

Post Posted December 2nd, 2003, 1:41 am

Where is the difference between this Linux-build
http://ftp.mozilla.org/pub/mozilla.org/ ... -01-trunk/
and this Linux-build
http://ftp.mozilla.org/pub/mozilla.org/ ... -07-trunk/
???

Heinrich Witt
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040309 Firefox/0.8.0+
Mozilla Thunderbird 0.5+ (20040304)

fishbert

User avatar
 
Posts: 941
Joined: November 29th, 2002, 12:02 am

Post Posted December 2nd, 2003, 1:59 am

Is there anything new relative to the last 11/30 build?

MozJF
 
Posts: 2007
Joined: July 14th, 2003, 10:07 am
Location: Near Atlantic Ocean

Post Posted December 2nd, 2003, 2:16 am

Well, Scott listed all new things.

I will release 0.4rc1 gcc builds (i686, AthlonXP and Pentium 4 optimized) in something like 4 or 5 hours. Just giving the time to my computer to make them :)
MozJF

fishbert

User avatar
 
Posts: 941
Joined: November 29th, 2002, 12:02 am

Post Posted December 2nd, 2003, 2:31 am

MozJF wrote:Well, Scott listed all new things.

I will release 0.4rc1 gcc builds (i686, AthlonXP and Pentium 4 optimized) in something like 4 or 5 hours. Just giving the time to my computer to make them :)

Yeah, I wasn't sure if that list was between 11/30 and 0.4RC1, or if maybe it was a summary of a few important things that have been introduced since 0.3 or the last month or something like that.

Barleyman
 
Posts: 60
Joined: October 30th, 2003, 11:54 am

Post Posted December 2nd, 2003, 3:25 am

Typing recipient name into the "TO:"-field kicks up the name lookup function:

Image

However, clicking on the scrollbar and/or arrows does not function as you'd expect, instead you get whatever email is present on that row!

My pet peeve, automatic downloading of attachments which are downloaded again when saved is still present, too.
--
Olli

SilentJ
 
Posts: 251
Joined: November 8th, 2002, 6:42 am

Post Posted December 2nd, 2003, 3:56 am

there is a bug with the default theme, this happens with a clean install and new profile,
it affects my imap inbox, after the first 2 or 3 times i open tb (haven't pinned it down to
an exact number) the icon for the inbox reverts back to the netscape 4 icon

Image

-J

oh, and the conversation icon isn't the qute style either (in newsgroups)

Image
Last edited by SilentJ on December 2nd, 2003, 4:08 am, edited 2 times in total.

mscha

User avatar
 
Posts: 33
Joined: May 22nd, 2003, 4:31 am

Post Posted December 2nd, 2003, 3:57 am

Hi,

Just is case:
This build still contains the regression (since the nov 26 build, AFAICT) that, when you "Get Mail" on an IMAP account with many folders to be checked, the spinner stops spinning after checking the first folder.

Best regards,

– Michael

teksaver
 
Posts: 66
Joined: May 15th, 2003, 6:22 am
Location: Nancy

Post Posted December 2nd, 2003, 4:05 am

Clicking on a link does not open it in any browser
using gnome under linux..
Starting to work (not too well) with mid-november nighties but does not anymore with this rc
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b) Gecko/20031216 Firebird/0.7+ (Optimized for Athlon XP SSE by Yek)

jilles
 
Posts: 54
Joined: November 27th, 2002, 6:08 am

Post Posted December 2nd, 2003, 6:06 am

I've so far not experienced anything out of the ordinary. The icons look great.

One thing that has annoyed me for some time is that the mail notification icon doesn't always go away when you maximize the mail client (even when double clicking the icon). You have to deselect and then reselect the inbox folder (at least that seems to do the trick for me).

Anyway I just noticed that there were three junk mails (properly filtered) and no notification icon. Thanks man! I hadn't noticed this had been fixed. Three unnecessary notifications less, that kind of thing is important to me.

pzesar

User avatar
 
Posts: 75
Joined: September 1st, 2003, 4:50 am
Location: Austria

Post Posted December 2nd, 2003, 6:52 am

everything working with rc1 over here...

with all the theme-issues around here lately, I think I should mention this - I haven't seen it around although it's very disturbing - sorry if it's already a very well known problem - I just wonder if it just happens to me...

in the toolbar-customization-drawer-thing in mail-compose, the security-icon is shown very odd. If it is dragged onto the toolbar (large icons, captions enabled), it shows without any problem (the usual lock-picture). But if it's dragged off the toolbar into the drawer, something strange happens:

Image

My profile exists since TB 0.3 - maybe this is related to my "old" profile - i don't know.

please notify me if this problem is well-known - i'll then edit my post and remove the image, because the image is quite large and it's useless to show it if it has no use... well... :)

GinoCyber
 
Posts: 75
Joined: June 15th, 2003, 5:22 pm

Post Posted December 2nd, 2003, 7:32 am

I get the same problem when using the quicknote extension.

John Liebson
 
Posts: 6452
Joined: July 29th, 2003, 1:09 pm

Post Posted December 2nd, 2003, 7:52 am

GinoCyber wrote:I get the same problem when using the quicknote extension.


That's been there in QuickNotes for some time now, but causes no actual problems that I'm aware of.

jhirshon

User avatar
 
Posts: 762
Joined: June 11th, 2003, 3:24 pm

Post Posted December 2nd, 2003, 7:58 am

Ever since I installed RC 1 going from the 11/26 build, I cannot send emails - going back to 11/26 fixes the problem. I am connecting standard, no SSL via IMAP.

This is on Windows 2K.

Anyone else experiencing this?

cheers, JH

arunsub

User avatar
 
Posts: 254
Joined: April 14th, 2003, 11:25 am
Location: http://www.arun-prabha.com

Post Posted December 2nd, 2003, 8:07 am

Barleyman wrote:Typing recipient name into the "TO:"-field kicks up the name lookup function:

Image

However, clicking on the scrollbar and/or arrows does not function as you'd expect, instead you get whatever email is present on that row!



I can confirm that.

Return to Thunderbird Builds


Who is online

Users browsing this forum: No registered users and 0 guests