MozillaZine

Daily build thread: April 2-8, 2006

Discussion about official Mozilla Thunderbird builds
supernova_00
 
Posts: 4832
Joined: June 24th, 2004, 8:03 pm
Location: Maryland, USA

Post Posted April 2nd, 2006, 3:38 pm

Image Thunderbird Builds RSS Feed

<a name="8"></a>The April 8th, 2006 builds are out
(Fixes for Core (Mailnews), Toolkit and Thunderbird are included. OS in [])

Fixed:
  1. #193923[Core:Keyboard: Find as you Type]-[win32] use system beep on Windows for notification [All] (Trunk, Branch)

Patched:
  1. #162361[Core:Internationalization]-Unicode file i/o in XPCOM/IO (cannot open files whose names contain characters outside the current locale: e.g. Japanese/Chinese on French Windows) [Win] (Branch)


<a name="7"></a>The April 7th, 2006 builds are out
(Fixes for Core (Mailnews), Toolkit and Thunderbird are included. OS in [])

Fixed:
  1. #45715[Core:MailNews: Composition]-"Reply to List" [button/(context) menu item] [All] (Trunk)
  2. #330710[Core:DOM: Events]-Replace obsolete preventBubble/preventCapture with stopPropagation [All] (Branch)
  3. #333065[Core:MailNews: Networking]-offlineStartup.js needs to know about nsIIOService2 [All] (Trunk)

Patched:
  • None


<a name="6"></a>The April 6th, 2006 builds are out
(Fixes for Core (Mailnews), Toolkit and Thunderbird are included. OS in [])

Fixed:
  1. #329156[Firefox:Software Update]-Updater should fail rather than report success when update.manifest is empty [All] (Trunk, Branch)

Patched:
  1. #78081[Core:Build Config]-Don't export intermediate libraries [Lin] (Trunk)
  2. #324953[Thunderbird:Mail Window Front End]-Run Junk Mail Controls (on selected messages) broken [Lin] (Trunk)


<a name="5"></a>The April 5th, 2006 [Trunk] builds are out
(Fixes for Core (Mailnews), Toolkit and Thunderbird are included. OS in [])

Fixed:
  1. #223730[Thunderbird:Mail Window Front End]-"Opening folder..." remains in status bar after folder has been fully opened [All] (Trunk/Branch)
  2. #239136[Thunderbird:Mail Window Front End]-Thunderbird needs to integrate with the new download manager [Win] (Trunk)
  3. #312793[Core:XP Miscellany]-Support DBUS and listen to NetworkManager events [Lin] (Trunk)
  4. #320927[Core:Networking: POP]-crash when checking pop3 mail [@ msvcrt.dll + 0x378c0 ][@ msvcrt!strlen + 0x20 - nsPop3Protocol::CapaResponse] [Win] (Trunk/Branch)
  5. #330276[Core:Widget: Win32]-Drop support for pre-Win2k platforms. [Win] (Trunk)
  6. #332285[Core:DOM]-nsGlobalWindow.cpp and nsCommandManager.cpp should use nsContentUtils::IsCallerChrome [Win] (Trunk)
  7. #332632[Thunderbird:General]-String assertion in libmime when reading mail from mail.app [Win] (Trunk/Branch)
  8. #332745[Core:XPCOM]-remove uses of MOZ_DECL_CTOR_COUNTER [All] (Trunk)

Patched:
  • None


<a name="4"></a>The April 4th, 2006 builds are out
(Fixes for Core (Mailnews), Toolkit and Thunderbird are included. OS in [])

Fixed:
  1. #308499[Thunderbird:Message Compose Window]-"Spell as you type" wording needs to be changed [All] (Branch)
  2. #315633[Firefox:Startup and Profile System]-"Create Profile" dialog text doesn't match button text: "Click Finish"->"Done", "click Next"->"Continue" [Mac] (Trunk, Branch)
  3. #329990[Core:Security: S/MIME]-Unwind S/Mime signature verification from UI thread [All] (Trunk)

Patched:
  • None


<a name="3"></a>The April 3rd, 2006 builds are out
(Fixes for Core (Mailnews), Toolkit and Thunderbird are included. OS in [])

Fixed:
  1. #252393[Firefox:Toolbars]-toolbarbutton XUL elements with the orient attribute set to horizontal are broken (Add a dropmarker to Thunderbird's File button) [All] (Trunk)
  2. #332119[Core:MailNews: Database]-IMAP folders: if sum of characters in foldernames to long TB craches or loops when you access the last folder in chain. [@ nsMsgDatabase::GetTableCreateIfMissing] [Win] (Trunk)

Patched:
  1. #131040[Core:MailNews: Import]-reduce duplicated import code [All] (Trunk)


<a name="2"></a>The April 2nd, 2006 builds are out
(Fixes for Core (Mailnews), Toolkit and Thunderbird are included. OS in [])

Fixed:
  • None

Patched:
  • None



Regressions/confirmed/annoying bugs (Branch and Trunk):
  • #333051[Core:Layout]-Menus (top-level and context) no longer work [Win]
____________

Need to manually download the latest nightly build?
Trunk || Mozilla 1.8 || Mozilla 1.8.0
Branch Tinderbox | Bonsai || Trunk Tinderbox | Bonsai

Thunderbird bug stats for ALL operating systems: (=day of last update)
Bugs nominated for blocking Thunderbird 2.0 = 24 ( 25 )
Bugs confirmed for blocking Thunderbird 2.0 = 4 ( 4 )
Last edited by supernova_00 on April 9th, 2006, 3:46 pm, edited 23 times in total.

supernova_00
 
Posts: 4832
Joined: June 24th, 2004, 8:03 pm
Location: Maryland, USA

Post Posted April 2nd, 2006, 3:40 pm

wth, something happend to my profile today. I upgraded, restarted and asked me to set up a new account. For some reason there are three profiles, one called default which appears to have all my stuff and then two others that don't show up in the profile manager and appear to have never been setup because of missing files like the trainer and mail files. anybody "lose" their profile today?

EDIT: I manually edited the profile config file to add the other two profiles and they both give me the same thing when starting up asking to setup a mail account. :(

EDIT EDIT: Copied all the files from one profile to a new one and same thing. Anyone know which files need to be copied over to a new profile to save all emails, account, passwords, rss feeds, settings, trainer files and all the other good stuff?

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted April 2nd, 2006, 4:29 pm

howdy supernova_00,

lookee ...
http://kb.mozillazine.org/Profile_Folde ... he_profile

... and especially here ...
http://kb.mozillazine.org/Migrating_set ... ew_profile

hope that helps,
lee

supernova_00
 
Posts: 4832
Joined: June 24th, 2004, 8:03 pm
Location: Maryland, USA

Post Posted April 2nd, 2006, 5:06 pm

Didn't work either, same thing. Created a new profile from scratch. grr Don't think I really needed anything from it anyways except my feeds.

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted April 2nd, 2006, 7:20 pm

howdy supernova_00,

sorry to hear that ... i take it you didn't have a backup of the profile? sounds like mozback time ... [*grin*]

take care,
lee

ChaKy

User avatar
 
Posts: 72
Joined: March 13th, 2004, 1:44 pm
Location: City of Dubrovnik, Croatia; Europe

Post Posted April 3rd, 2006, 3:27 am

Where are Linux builds? The latest one is from 30.03.2006, as looking in this directory here
http://ftp.mozilla.org/pub/mozilla.org/ ... ozilla1.8/
Image

therearenoteams

User avatar
 
Posts: 168
Joined: August 12th, 2004, 5:46 am
Location: Pittsburgh, PA

Post Posted April 3rd, 2006, 8:52 am

I'm noticing an odd white space in the compose window, above the From: field:

Image

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20060403 Thunderbird/2.0a1 ID:2006040306
compactfolder 0.0.5
Nightly Tester Tools 0.8b2
Quote Colors 0.2.7
Talkback 2.0a1

Andreasm82
 
Posts: 535
Joined: April 5th, 2005, 11:30 am
Location: Germany, Saarland

Post Posted April 3rd, 2006, 8:55 am

@therearenoteams : lol , I think that's not a real problem... there are lot's of bigger, more important problems :)
Greets, Andreas
My german energy-saving page - let's stop wasting of energy!

therearenoteams

User avatar
 
Posts: 168
Joined: August 12th, 2004, 5:46 am
Location: Pittsburgh, PA

Post Posted April 3rd, 2006, 9:02 am

Andreasm82 wrote:@therearenoteams : lol , I think that's not a real problem... there are lot's of bigger, more important problems :)

Sure, it's not a big problem. (I could nominate a few large problems--such as format=flowed bungling--but I think most are aware of these.) Should the issue go unreported? I disagree; it's better to fix it early when it might have been the result of a recent check-in, then to wait.

supernova_00
 
Posts: 4832
Joined: June 24th, 2004, 8:03 pm
Location: Maryland, USA

Post Posted April 3rd, 2006, 9:03 am

Its due to last weeks checkins to use firefox theme propeties, the bar is just a few pixels too wide

mscott

User avatar
 
Posts: 2516
Joined: April 2nd, 2003, 4:10 pm
Location: Thunderbird Research Center, CA

Post Posted April 3rd, 2006, 11:02 am

ChaKy wrote:Where are Linux builds? The latest one is from 30.03.2006, as looking in this directory here
http://ftp.mozilla.org/pub/mozilla.org/ ... ozilla1.8/


I can't even reach the build machine. Looks like the machine has locked up. May take a day or so to get someone over to the server center to restart the machine.

Thanks for bringing this up.
Thunderbirds are Go!

mscott

User avatar
 
Posts: 2516
Joined: April 2nd, 2003, 4:10 pm
Location: Thunderbird Research Center, CA

Post Posted April 3rd, 2006, 11:03 am

therarenoteams --> let's file a bug on that and post back here linking to your screen shot in the bug. I'm not sure what would be causing that.
Thunderbirds are Go!

Old RPGM35
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted April 3rd, 2006, 12:28 pm

therearenoteams wrote:I'm noticing an odd white space in the compose window, above the From: field:

Image

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20060403 Thunderbird/2.0a1 ID:2006040306
compactfolder 0.0.5
Nightly Tester Tools 0.8b2
Quote Colors 0.2.7
Talkback 2.0a1
Look Like It's a Win Classic Bug:

Image

therearenoteams

User avatar
 
Posts: 168
Joined: August 12th, 2004, 5:46 am
Location: Pittsburgh, PA

Post Posted April 3rd, 2006, 12:58 pm

RPGMarker35 wrote:Look Like It's a Win Classic Bug:

Yep. I confirmed by checking w/Windows XP style.

sansibar
 
Posts: 133
Joined: September 2nd, 2003, 12:22 pm
Location: Vienna, Austria

Post Posted April 3rd, 2006, 4:15 pm

I have a problem with attachments. When a directory of the attachment path contains "ä" or "ö" or "ü" or "ß" (german special signs), thunderbird does not upload the attachment and gives an error message. Can someone confirm this?

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060403 Thunderbird/3.0a1 ID:2006040310

Return to Thunderbird Builds


Who is online

Users browsing this forum: No registered users and 3 guests