MozillaZine

IMAP issues

Discussion of general topics about Mozilla Thunderbird
instigata

User avatar
 
Posts: 14
Joined: July 28th, 2003, 1:26 pm
Location: new york, ny

Post Posted December 11th, 2003, 5:52 pm

I'm using Thunderbird 0.4 (20031205)

1) Since installing, I am plagued with alerts telling me that Thunderbird keeps losing the conncection to my IMAP account (Hit OK). Every time this happens it seems to feel it necessary to tell me no less than 4 times. Can I turn this off? Is this a bug? It's annoying as heck...

2) I've been using Thunderbird for a long time, and I love it. I just wish I could purge my IMAP account of deleted messages. Whenever I check my mailbox through the web from a different locale, there are usually about 30 deleted messages still on the server that do not show up in TB at home. Is there a command that does this that's not labeled as such? This also is annoying as heck...

Many thanks to whoever replies to this. (And <i>please</i> don't just say "WFM" in your reply. This is much more annoying than heck. Thank you.)

old Neil Parks
Moderator
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted December 11th, 2003, 9:22 pm

Different IMAP servers work differently regarding how they handle deletes. Next time you're on the web site, see if there's a configurable option to delete immediately, or purge deletes, or something like that.

If it's checked, try unchecking it and vice versa.

gdboling
 
Posts: 9
Joined: December 10th, 2003, 1:22 pm

Post Posted December 13th, 2003, 9:40 pm

Go to File - Compact Folders. From my understanding, this is basically a purge command to the IMAP server. I was having the same problem and since using that method, my mail seems to be getting deleted that I delete.

On an aside, my webmail and TB are rarely in sync as far as the INBOX goes. My webmail reports o messages, but I have 5 in thunderbird. And I should have 5 on my webmail. So I don't know what that is all about. :)
Gregg

mjc

User avatar
 
Posts: 95
Joined: December 2nd, 2002, 8:55 am

Post Posted December 14th, 2003, 7:10 am

Neil Parks wrote:Different IMAP servers work differently regarding how they handle deletes. Next time you're on the web site, see if there's a configurable option to delete immediately, or purge deletes, or something like that.

If it's checked, try unchecking it and vice versa.


Huh? This is rather misleading. In the IMAP model, it is the job of the client to request an EXPUNGE, not the server. Which IMAP servers offer automatic expunging, anyhow?

It would be more accurate to say that at this early point in TB's evolution, TB handles deleted messages poorly. This isn't the server's fault. It's TB's fault. In comparison, the Mulberry client offers "Automatic expunge option for deletion of messages, with or without warning, available on the close of any mailbox". There is an enhancement request for this feature at <a href="http://bugzilla.mozilla.org/show_bug.cgi?id=223525">http://bugzilla.mozilla.org/show_bug.cgi?id=223525</a>.

TB 0.4 has problems counting deleted-and-unread-but-not-expunged messages, too, which makes things extra confusing: <a href="http://bugzilla.mozilla.org/show_bug.cgi?id=227927">http://bugzilla.mozilla.org/show_bug.cgi?id=227927</a>.

You can, of course manually compact each folder using the "File - Compact this folder" command, after every message move or delete. And you can set the INBOX to be compacted upon exiting the program, but not any sub-folders.

- Mike

old Neil Parks
Moderator
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted December 15th, 2003, 11:09 am

mjc wrote:
Neil Parks wrote:Different IMAP servers work differently regarding how they handle deletes. Next time you're on the web site, see if there's a configurable option to delete immediately, or purge deletes, or something like that.

If it's checked, try unchecking it and vice versa.


Huh? This is rather misleading. In the IMAP model, it is the job of the client to request an EXPUNGE, not the server. Which IMAP servers offer automatic expunging, anyhow?


My only experience with IMAP mail is www.myrealbox.com . Under "options" it has "Purge--default to on: yes/no". I had to set that to "no" to get deletes via Tbird to properly clear msgs from the server. I don't know why. Seems counter-intuitive to me.

MiguelC

User avatar
 
Posts: 66
Joined: September 5th, 2003, 7:06 am
Location: In hyperspace with Rogue Squadron

Post Posted December 16th, 2003, 12:23 pm

I have TB 0.4 (20031205) and the following happens : I have an IMAP account on a local server and sometimes, when I change folders, it says "connected to (address)" and stays there. I have to close TB and open it again and THEN, it accesses the folder. Since 0.2 I have this problem.

instigata

User avatar
 
Posts: 14
Joined: July 28th, 2003, 1:26 pm
Location: new york, ny

Post Posted December 18th, 2003, 3:20 pm

Neil Parks wrote:My only experience with IMAP mail is www.myrealbox.com . Under "options" it has "Purge--default to on: yes/no". I had to set that to "no" to get deletes via Tbird to properly clear msgs from the server. I don't know why. Seems counter-intuitive to me.


nice...i'm using myrealbox, so i'll try this. thanks.

Return to Thunderbird General


Who is online

Users browsing this forum: No registered users and 3 guests