MozillaZine

How do I change the File Association of an attachment (.DOC)

User Help for Mozilla Thunderbird
Ptaker
 
Posts: 34
Joined: September 22nd, 2004, 11:09 am

Post Posted May 1st, 2006, 10:13 am

I am using Windows 2000, TB Version version 1.5.0.2 (20060308).
When I double click on a .doc (word document) in windows explore, it properly opens Microsoft Word to view the document.

Problem: When I double click on a .doc attachment (word document) in Thunderbird, it keeps opening it in Word Pad.

Since my association outside of TB is correct, how do I get TB to open the document in Microsoft Word. There is no OPEN WITH when you right click on the attachment, only OPEN.

Any help would be greatly appreciated.

Bob
xxx@xxx.net

** e-mail address remove by moderator **

smsmith
Moderator

User avatar
 
Posts: 18797
Joined: December 7th, 2004, 8:51 pm
Location: Illinois

Post Posted May 1st, 2006, 10:52 am

Please take a look at Tools -> Options -> Attachments. Press the "View and Edit Actions" button. .DOC should be one of the entries. Edit the action so that the files open in Word.
Give a man a fish, and he eats for a day. Teach a man to fish, and he eats for a lifetime.
I like poetry, long walks on the beach and poking dead things with a stick.
Please do not PM me for personal support. Keep posts here in the Forums instead and we all learn.

Daifne
Moderator

User avatar
 
Posts: 122728
Joined: July 31st, 2005, 9:17 pm
Location: Where the Waters Meet, Wisconsin

Post Posted May 1st, 2006, 2:15 pm

I removed your e-mail address because we do not give email support, but more importantly, spammers harvest email addresses from public forums like this.
JE SUIS CHARLIE
“If you make people think they're thinking, they'll love you; but if you really make them think, they'll hate you.” ― Harlan Ellison
Please do not PM me for personal support. Keep posts here in the Forums instead and we all learn.

Ptaker
 
Posts: 34
Joined: September 22nd, 2004, 11:09 am

Post Posted May 1st, 2006, 7:35 pm

There is nothing in the View & Edit Actions section. All is grayed out.

Can you tell me how to add something so the TB program will look to Microsoft Word to open future .doc extensions?

Bob

smsmith
Moderator

User avatar
 
Posts: 18797
Joined: December 7th, 2004, 8:51 pm
Location: Illinois

Post Posted May 1st, 2006, 8:58 pm

Unfortunately, this is not as easy as it sounds. It involves manually editing a file that I am not completely comfortable with.

But, since your Actions are not defined, you can try copying the following into a file called mimeTypes.rdf:

Code: Select all
<?xml version="1.0"?>
<RDF:RDF xmlns:NC="http://home.netscape.com/NC-rdf#"
         xmlns:RDF="http://www.w3.org/1999/02/22-rdf-syntax-ns#">
  <RDF:Seq RDF:about="urn:mimetypes:root">
    <RDF:li RDF:resource="urn:mimetype:application/msword"/>
  </RDF:Seq>
  <RDF:Description RDF:about="urn:mimetype:application/msword"
                   NC:value="application/msword"
                   NC:editable="true"
                   NC:fileExtensions="doc"
                   NC:description="Microsoft Word Document">
    <NC:handlerProp RDF:resource="urn:mimetype:handler:application/msword"/>
  </RDF:Description>
  <RDF:Description RDF:about="urn:mimetype:externalApplication:application/msword"
                   NC:prettyName=""
                   NC:path="" />
  <RDF:Description RDF:about="urn:mimetypes">
    <NC:MIME-types RDF:resource="urn:mimetypes:root"/>
  </RDF:Description>
  <RDF:Description RDF:about="urn:mimetype:handler:application/msword"
                   NC:alwaysAsk="false"
                   NC:useSystemDefault="true">
    <NC:externalApplication RDF:resource="urn:mimetype:externalApplication:application/msword"/>
  </RDF:Description>
</RDF:RDF>

The file will be in your profile folder:
http://kb.mozillazine.org/Profile_folder

Add that code to the file (just replace anything in the file with that text above). Make sure that Tb is closed when you try this. Then, save the file and open Tb. Try opening an attachment or checking the Actions to see if it is listed now (Tools -> Options -> Attachments). You can edit that file using Notepad or Wordpad.

I was hoping to find an extension to make this simpler, but couldn't find anything.

tanstaafl
Moderator

User avatar
 
Posts: 38792
Joined: July 30th, 2003, 5:06 pm
Location: Massachusetts

Post Posted May 2nd, 2006, 3:05 am

I suspect your mimetypes.rdf file is corrupt. I suggest you delete it. The next time you run Thunderbird it will create a new one with default values. Then try to open a .doc attachment. It should not know how to do that and will ask you what to use. Tell it to use MS-Word (by browsing to the executable) AND check the checkbox to remember that setting.

http://kb.mozillazine.org/Actions_for_a ... file_types

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 15 guests