MozillaZine

linker major version does not match the compiler suilte ver7

Discussion about Seamonkey builds
dongdongyang
 
Posts: 13
Joined: April 24th, 2006, 1:14 am

Post Posted July 11th, 2006, 10:06 pm

When build mozilla, I run into the the problem: The linker major version does not match the compiler suite version7 .
Anyone can give some idea? I am confused by the error. I'm using vc7,and following is my script file:

set HOME=E:\mozilla_all
set VCVARS=D:\ProgramFiles\MicrosoftVisualStudio.NET2003\Vc7\bin\VCVARS32.BAT
set MSSDK=D:\ProgramFiles\MicrosoftPlatformSDK
set MOZ_TOOLS=E:\mozilla_all\moztools
set CYGWINBASE=c:\cygwin
set PATH=%CYGWINBASE%\bin;%PATH%;
call "%VCVARS%"
set PATH=%MSSDK%\bin;%PATH%;
set INCLUDE=%MSSDK%\Include;%INCLUDE%
set LIB=%MSSDK%\Lib;%LIB%
set PATH=%MOZ_TOOLS%\bin;%PATH%;
bash --login -i


Thanks a lot in advance.

RDaneel
 
Posts: 442
Joined: January 19th, 2004, 2:43 pm
Location: Seattle, WA

Post Posted July 12th, 2006, 12:08 pm

This may or may not relate to your problem, but I use Cygwin as a build environment, retaining the Microsoft actual compilers, linker, and librarian... if there is any way that the Cygwin "link.exe" is seen before the Microsoft file of the same name, hilarity ensues. ;)

So I rename the Cygwin link.exe to something (anything) else.

dongdongyang
 
Posts: 13
Joined: April 24th, 2006, 1:14 am

Post Posted July 12th, 2006, 10:30 pm

Thanks a lot. After renaming the link.exe, it worked. But it reported:"target pattern contains no '%', stop" , then stopped, when I make it. I think it's my script file's falt. I am using vc7, windowsXP, and following is my script file:
set HOME=E:\mozilla_all
set VCVARS=D:\ProgramFiles\MicrosoftVisualStudio.NET2003\Vc7\bin\VCVARS32.BAT
set MOZ_TOOLS=E:\mozilla_all\moztools
set CYGWINBASE=c:\cygwin
set PATH=%CYGWINBASE%\bin;%PATH%;
call "%VCVARS%"
set PATH=%MSSDK%\bin;%PATH%;
set INCLUDE=%MSSDK%\Include;%MSVC%\include;%INCLUDE%
set LIB=%MSSDK%\Lib;;%MSVC%\lib;%LIB%
set PATH=%PATH%;%MOZ_TOOLS%\bin;
set MOZ_BITS=32
set MOZ_DEBUG=1
set MOZ_SRC=E:\mozilla_all\mozilla
set OS_TARGET=WINNT
set WINOS=%OS_TARGET%
set _MSC_VER=1310
bash --login -i

Anyone can help me point to the falt? Any suggestion is appreciated. Thanks a lot in advance.

RDaneel
 
Posts: 442
Joined: January 19th, 2004, 2:43 pm
Location: Seattle, WA

Post Posted July 12th, 2006, 10:46 pm

Offhand, that sounds like a problem with the Makefile itself... and building Moz/SM is a pretty big job, with multiple commands, scripts, and [sub]makefiles running.

I would make *sure* that the build env is worked out by trying some simpler builds with small test makefiles, then you can work up to the big one by trying limited targets.

Remember that you can do "make -n [targets]" to see what *would* be done for a specific make operation. This is good for quickly and easily repeating the same test, since you aren't actually changing anything in the filesystem.

RyanVM
 
Posts: 1264
Joined: June 16th, 2004, 6:00 am
Location: Exton, PA

Post Posted July 13th, 2006, 6:25 am

make sure the cygwin bin directory is in the path after the MSVC bin directory

old jasonb
Moderator
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted July 15th, 2006, 6:51 am

-> SeaMonkey Builds.

I'm not sure why this got moved, but SeaMonkey Builds is also about users compiling SeaMonkey themselves - or at least it's been that way for a couple of years now. It's only when something is introduced outside of the code that it becomes a "3rd party" (forked) build. This kind of disussion has always remained here in the past...

InvisibleSmiley

User avatar
 
Posts: 69
Joined: November 10th, 2002, 1:19 am

Post Posted September 9th, 2006, 3:48 am

@dongdongyang:

As for the "target pattern contains no '%', stop." problem: You probably ran into Bug 345482, just as I did. See the bug report or http://smtt.blogspot.com/ for details.
SeaMonkey Trunk Tracker: http://smtt.blogspot.com/

Return to SeaMonkey Builds


Who is online

Users browsing this forum: No registered users and 1 guest